initial import of PyQt-3.1, a Python binding for Qt 2.3.1
This commit is contained in:
parent
a2980fd754
commit
9d1f733407
8 changed files with 140 additions and 0 deletions
4
x11/py-qt2/DESCR
Normal file
4
x11/py-qt2/DESCR
Normal file
|
@ -0,0 +1,4 @@
|
|||
PyQt is a set of Python bindings for the Qt toolkit. The bindings are
|
||||
implemented as a set of Python modules: qt, qtcanvas, qtgl,
|
||||
qtnetwork, qtsql, qttable and qtxml, and contains 300
|
||||
classes and over 5,750 functions and methods.
|
31
x11/py-qt2/Makefile
Normal file
31
x11/py-qt2/Makefile
Normal file
|
@ -0,0 +1,31 @@
|
|||
# $NetBSD: Makefile,v 1.1.1.1 2002/04/17 10:31:36 drochner Exp $
|
||||
#
|
||||
|
||||
DISTNAME= PyQt-3.1-Qt-2.3.1
|
||||
PKGNAME= ${PYPKGPREFIX}-qt2-3.1
|
||||
WRKSRC= ${WRKDIR}/PyQt-3.1
|
||||
CATEGORIES= x11
|
||||
MASTER_SITES= http://www.riverbankcomputing.co.uk/download/PyQt/
|
||||
|
||||
MAINTAINER= drochner@netbsd.org
|
||||
HOMEPAGE= http://www.riverbankcomputing.co.uk/pyqt/index.php
|
||||
COMMENT= Python bindings for the Qt tooltit
|
||||
|
||||
USE_LIBTOOL= yes
|
||||
LIBTOOL_OVERRIDE= ${WRKSRC}/libtool
|
||||
USE_BUILDLINK_ONLY= yes
|
||||
|
||||
HAVE_CONFIGURE= YES
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ARGS= --with-python=${PYTHONBIN} \
|
||||
--with-qt-dir=${QT_BUILDLINK_DIR}
|
||||
|
||||
PY_PATCHPLIST= yes
|
||||
PLIST_SUBST+= PYVERSSUFFIX=${PYVERSSUFFIX}
|
||||
MAKE_ENV+= PYVERSSUFFIX=${PYVERSSUFFIX}
|
||||
|
||||
.include "../../x11/py-qt2-sip/buildlink.mk"
|
||||
.include "../../lang/python/extension.buildlink.mk"
|
||||
.include "../../x11/qt2-libs/buildlink.mk"
|
||||
.include "../../mk/x11.buildlink.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
53
x11/py-qt2/PLIST
Normal file
53
x11/py-qt2/PLIST
Normal file
|
@ -0,0 +1,53 @@
|
|||
@comment $NetBSD: PLIST,v 1.1.1.1 2002/04/17 10:31:36 drochner Exp $
|
||||
bin/eric${PYVERSSUFFIX}
|
||||
bin/pyuic${PYVERSSUFFIX}
|
||||
${PYSITELIB}/eric/AsyncIO.py
|
||||
${PYSITELIB}/eric/Config.py
|
||||
${PYSITELIB}/eric/DebugClient.py
|
||||
${PYSITELIB}/eric/DebugProtocol.py
|
||||
${PYSITELIB}/eric/DebugServer.py
|
||||
${PYSITELIB}/eric/Explorer.py
|
||||
${PYSITELIB}/eric/Icons.py
|
||||
${PYSITELIB}/eric/Info.py
|
||||
${PYSITELIB}/eric/Scanner.py
|
||||
${PYSITELIB}/eric/Shell.py
|
||||
${PYSITELIB}/eric/SourceViewer.py
|
||||
${PYSITELIB}/eric/UserInterface.py
|
||||
${PYSITELIB}/eric/eric.py
|
||||
${PYSITELIB}/libqtcanvascmodule-${PKGVERSION}.so
|
||||
${PYSITELIB}/libqtcanvascmodule.a
|
||||
${PYSITELIB}/libqtcanvascmodule.la
|
||||
${PYSITELIB}/libqtcanvascmodule.so
|
||||
${PYSITELIB}/libqtcmodule-${PKGVERSION}.so
|
||||
${PYSITELIB}/libqtcmodule.a
|
||||
${PYSITELIB}/libqtcmodule.la
|
||||
${PYSITELIB}/libqtcmodule.so
|
||||
${PYSITELIB}/libqtglcmodule-${PKGVERSION}.so
|
||||
${PYSITELIB}/libqtglcmodule.a
|
||||
${PYSITELIB}/libqtglcmodule.la
|
||||
${PYSITELIB}/libqtglcmodule.so
|
||||
${PYSITELIB}/libqtnetworkcmodule-${PKGVERSION}.so
|
||||
${PYSITELIB}/libqtnetworkcmodule.a
|
||||
${PYSITELIB}/libqtnetworkcmodule.la
|
||||
${PYSITELIB}/libqtnetworkcmodule.so
|
||||
${PYSITELIB}/libqttablecmodule-${PKGVERSION}.so
|
||||
${PYSITELIB}/libqttablecmodule.a
|
||||
${PYSITELIB}/libqttablecmodule.la
|
||||
${PYSITELIB}/libqttablecmodule.so
|
||||
${PYSITELIB}/libqtxmlcmodule-${PKGVERSION}.so
|
||||
${PYSITELIB}/libqtxmlcmodule.a
|
||||
${PYSITELIB}/libqtxmlcmodule.la
|
||||
${PYSITELIB}/libqtxmlcmodule.so
|
||||
${PYSITELIB}/qt.py
|
||||
${PYSITELIB}/qt.pyc
|
||||
${PYSITELIB}/qtcanvas.py
|
||||
${PYSITELIB}/qtcanvas.pyc
|
||||
${PYSITELIB}/qtgl.py
|
||||
${PYSITELIB}/qtgl.pyc
|
||||
${PYSITELIB}/qtnetwork.py
|
||||
${PYSITELIB}/qtnetwork.pyc
|
||||
${PYSITELIB}/qttable.py
|
||||
${PYSITELIB}/qttable.pyc
|
||||
${PYSITELIB}/qtxml.py
|
||||
${PYSITELIB}/qtxml.pyc
|
||||
@dirrm ${PYSITELIB}/eric
|
6
x11/py-qt2/buildlink.mk
Normal file
6
x11/py-qt2/buildlink.mk
Normal file
|
@ -0,0 +1,6 @@
|
|||
# $NetBSD: buildlink.mk,v 1.1.1.1 2002/04/17 10:31:36 drochner Exp $
|
||||
|
||||
.include "../../lang/python/pyversion.mk"
|
||||
|
||||
BUILDLINK_DEPENDS.pyqt2?= ${PYPKGPREFIX}-qt2-[0-9]*
|
||||
DEPENDS+= ${BUILDLINK_DEPENDS.pyqt2}:../../x11/py-qt2
|
7
x11/py-qt2/distinfo
Normal file
7
x11/py-qt2/distinfo
Normal file
|
@ -0,0 +1,7 @@
|
|||
$NetBSD: distinfo,v 1.1.1.1 2002/04/17 10:31:36 drochner Exp $
|
||||
|
||||
SHA1 (PyQt-3.1-Qt-2.3.1.tar.gz) = 3cadbd3b4c6d113bc3fb9a0106ca5e7c6642348e
|
||||
Size (PyQt-3.1-Qt-2.3.1.tar.gz) = 2298356 bytes
|
||||
SHA1 (patch-aa) = bd3f4cb232b6f299e82f8c5e642d3b560a7f1b65
|
||||
SHA1 (patch-ab) = c5d08b7da76a024896fe135a16410138fa9a5399
|
||||
SHA1 (patch-ac) = 436ae469d05c4421bad812bf61842d31e1643cfb
|
13
x11/py-qt2/patches/patch-aa
Normal file
13
x11/py-qt2/patches/patch-aa
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-aa,v 1.1.1.1 2002/04/17 10:31:36 drochner Exp $
|
||||
|
||||
--- pyuic/Makefile.in.orig Tue Apr 16 17:27:31 2002
|
||||
+++ pyuic/Makefile.in Tue Apr 16 17:29:58 2002
|
||||
@@ -68,7 +68,7 @@
|
||||
host_alias = @host_alias@
|
||||
host_triplet = @host@
|
||||
|
||||
-EXEEXT = @EXEEXT@
|
||||
+EXEEXT = ${PYVERSSUFFIX}
|
||||
OBJEXT = @OBJEXT@
|
||||
PATH_SEPARATOR = @PATH_SEPARATOR@
|
||||
AMTAR = @AMTAR@
|
13
x11/py-qt2/patches/patch-ab
Normal file
13
x11/py-qt2/patches/patch-ab
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-ab,v 1.1.1.1 2002/04/17 10:31:36 drochner Exp $
|
||||
|
||||
--- debugger/Makefile.in.orig Fri Mar 22 11:58:02 2002
|
||||
+++ debugger/Makefile.in Wed Apr 17 10:15:51 2002
|
||||
@@ -54,7 +54,7 @@
|
||||
install_sh_PROGRAM = $(install_sh) -c
|
||||
INSTALL_SCRIPT = @INSTALL_SCRIPT@
|
||||
INSTALL_HEADER = $(INSTALL_DATA)
|
||||
-transform = @program_transform_name@
|
||||
+transform = s|$$|${PYVERSSUFFIX}|
|
||||
NORMAL_INSTALL = :
|
||||
PRE_INSTALL = :
|
||||
POST_INSTALL = :
|
13
x11/py-qt2/patches/patch-ac
Normal file
13
x11/py-qt2/patches/patch-ac
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-ac,v 1.1.1.1 2002/04/17 10:31:36 drochner Exp $
|
||||
|
||||
--- configure.orig Wed Apr 17 10:45:30 2002
|
||||
+++ configure Wed Apr 17 10:45:57 2002
|
||||
@@ -8041,7 +8041,7 @@
|
||||
|
||||
|
||||
|
||||
- SIP_CPPFLAGS=
|
||||
+ SIP_CPPFLAGS=${CPPFLAGS}
|
||||
SIP_CXXFLAGS=
|
||||
SIP_LDLIBDIRS=
|
||||
|
Loading…
Reference in a new issue