fix packaging bugs noted by Geoff Wing (gcw@pobox.com) (thanks)
This commit is contained in:
parent
402f6fb72c
commit
9d2c7f1dd7
4 changed files with 32 additions and 11 deletions
|
@ -1,7 +1,8 @@
|
|||
# $NetBSD: Makefile,v 1.97 2009/09/22 13:17:00 spz Exp $
|
||||
# $NetBSD: Makefile,v 1.98 2009/09/25 11:06:00 spz Exp $
|
||||
|
||||
DISTNAME= inn-2.5.0
|
||||
CATEGORIES= news
|
||||
PKGREVISION= 1
|
||||
MASTER_SITES= ftp://ftp.isc.org/isc/inn/ \
|
||||
ftp://ftp.fu-berlin.de/unix/news/inn/
|
||||
|
||||
|
@ -33,8 +34,8 @@ CONFIGURE_ARGS+= --enable-setgid-inews \
|
|||
--enable-largefiles \
|
||||
--bindir=${PREFIX}/${INN_PATHBIN} \
|
||||
--sbindir=${PREFIX}/${INN_PATHBIN} \
|
||||
--sysconfdir=${PREFIX}/etc/inn \
|
||||
--with-openssl=${SSLBASE:Q} \
|
||||
--with-etc-dir=${PREFIX}/etc/inn \
|
||||
--with-doc-dir=${PREFIX}/share/doc/inn \
|
||||
--with-control-dir=${PREFIX}/${INN_PATHBIN}/control \
|
||||
--with-filter-dir=${PREFIX}/${INN_PATHBIN}/filter \
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
@comment $NetBSD: PLIST,v 1.19 2009/09/22 13:17:00 spz Exp $
|
||||
@comment $NetBSD: PLIST,v 1.20 2009/09/25 11:06:00 spz Exp $
|
||||
bin/inews
|
||||
bin/rnews
|
||||
include/inn/buffer.h
|
||||
|
@ -9,16 +9,21 @@ include/inn/hashtab.h
|
|||
include/inn/history.h
|
||||
include/inn/innconf.h
|
||||
include/inn/inndcomm.h
|
||||
include/inn/libinn.h
|
||||
include/inn/list.h
|
||||
include/inn/md5.h
|
||||
include/inn/messages.h
|
||||
include/inn/mmap.h
|
||||
include/inn/network.h
|
||||
include/inn/newsuser.h
|
||||
include/inn/nntp.h
|
||||
include/inn/options.h
|
||||
include/inn/ov.h
|
||||
include/inn/overview.h
|
||||
include/inn/paths.h
|
||||
include/inn/qio.h
|
||||
include/inn/sequence.h
|
||||
include/inn/storage.h
|
||||
include/inn/system.h
|
||||
include/inn/timer.h
|
||||
include/inn/tst.h
|
||||
|
@ -26,11 +31,6 @@ include/inn/utility.h
|
|||
include/inn/vector.h
|
||||
include/inn/version.h
|
||||
include/inn/wire.h
|
||||
include/inn/libinn.h
|
||||
include/inn/nntp.h
|
||||
include/inn/ov.h
|
||||
include/inn/paths.h
|
||||
include/inn/storage.h
|
||||
lib/innreport_inn.pm
|
||||
lib/innshellvars
|
||||
lib/innshellvars.pl
|
||||
|
@ -38,6 +38,7 @@ lib/innshellvars.tcl
|
|||
lib/libinn.a
|
||||
lib/libinnhist.a
|
||||
lib/libstorage.a
|
||||
lib/perl/INN/Config.pm
|
||||
${INN_PATHBIN}/actmerge
|
||||
${INN_PATHBIN}/actsync
|
||||
${INN_PATHBIN}/actsyncd
|
||||
|
@ -48,6 +49,7 @@ ${INN_PATHBIN}/auth/resolv/domain
|
|||
${INN_PATHBIN}/auth/resolv/ident
|
||||
${INN_PATHBIN}/batcher
|
||||
${INN_PATHBIN}/buffchan
|
||||
${INN_PATHBIN}/buffindexed_d
|
||||
${INN_PATHBIN}/cnfsheadconf
|
||||
${INN_PATHBIN}/cnfsstat
|
||||
${INN_PATHBIN}/control/checkgroups.pl
|
||||
|
@ -84,6 +86,7 @@ ${INN_PATHBIN}/getlist
|
|||
${INN_PATHBIN}/grephistory
|
||||
${INN_PATHBIN}/imapfeed
|
||||
${INN_PATHBIN}/inews
|
||||
${INN_PATHBIN}/innbind
|
||||
${INN_PATHBIN}/inncheck
|
||||
${INN_PATHBIN}/innconfval
|
||||
${INN_PATHBIN}/innd
|
||||
|
@ -118,6 +121,7 @@ ${INN_PATHBIN}/prunehistory
|
|||
${INN_PATHBIN}/pullnews
|
||||
${INN_PATHBIN}/rc.news
|
||||
${INN_PATHBIN}/rnews
|
||||
${INN_PATHBIN}/rnews.libexec/bunbatch
|
||||
${INN_PATHBIN}/rnews.libexec/c7unbatch
|
||||
${INN_PATHBIN}/rnews.libexec/decode
|
||||
${INN_PATHBIN}/rnews.libexec/encode
|
||||
|
@ -136,6 +140,7 @@ ${INN_PATHBIN}/simpleftp
|
|||
${INN_PATHBIN}/sm
|
||||
${INN_PATHBIN}/tally.control
|
||||
${INN_PATHBIN}/tdx-util
|
||||
${INN_PATHBIN}/tinyleaf
|
||||
${INN_PATHBIN}/writelog
|
||||
man/man1/convdate.1
|
||||
man/man1/fastrm.1
|
||||
|
@ -211,8 +216,8 @@ man/man8/expireover.8
|
|||
man/man8/expirerm.8
|
||||
man/man8/filechan.8
|
||||
man/man8/ident.8
|
||||
man/man8/inncheck.8
|
||||
man/man8/innbind.8
|
||||
man/man8/inncheck.8
|
||||
man/man8/innd.8
|
||||
man/man8/inndf.8
|
||||
man/man8/innreport.8
|
||||
|
@ -249,6 +254,7 @@ man/man8/tinyleaf.8
|
|||
man/man8/writelog.8
|
||||
sbin/cnfsstat
|
||||
sbin/ctlinnd
|
||||
sbin/innbind
|
||||
sbin/makehistory
|
||||
share/doc/inn/CONTRIBUTORS
|
||||
share/doc/inn/GPL
|
||||
|
@ -291,8 +297,8 @@ share/examples/inn/motd.news
|
|||
share/examples/inn/news2mail.cf
|
||||
share/examples/inn/newsfeeds
|
||||
share/examples/inn/newsgroups.minimal
|
||||
share/examples/inn/nntpsend.ctl
|
||||
share/examples/inn/nnrpd.track
|
||||
share/examples/inn/nntpsend.ctl
|
||||
share/examples/inn/nocem.ctl
|
||||
share/examples/inn/ovdb.conf
|
||||
share/examples/inn/passwd.nntp
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: distinfo,v 1.21 2009/09/22 13:17:00 spz Exp $
|
||||
$NetBSD: distinfo,v 1.22 2009/09/25 11:06:00 spz Exp $
|
||||
|
||||
SHA1 (inn-2.5.0.tar.gz) = f009da670e2594d9079e7fb26f32d10c640d24e6
|
||||
RMD160 (inn-2.5.0.tar.gz) = 0b9583eef8fe86131297d403323ab6ff2906fe06
|
||||
|
@ -10,3 +10,4 @@ SHA1 (patch-ad) = d36131ad21a1d8ea0edb463dfff6f1800dc8291d
|
|||
SHA1 (patch-ag) = 8041d7d78c26fd7b505d9955dbdb91f2b8cb8ab2
|
||||
SHA1 (patch-ah) = bf0a72348958a89dc28d08dd324e5ee9acfae2c8
|
||||
SHA1 (patch-ai) = 28ab36f22920a3bcd2c99578a5b75db3012cf106
|
||||
SHA1 (patch-ak) = 1b92f93a78a08b570c2f9b5360982644d6d2d065
|
||||
|
|
13
news/inn/patches/patch-ak
Normal file
13
news/inn/patches/patch-ak
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-ak,v 1.1 2009/09/25 11:06:00 spz Exp $
|
||||
|
||||
--- perl/INN/Config.pm.in.orig 2009-05-21 22:08:33.000000000 +0200
|
||||
+++ perl/INN/Config.pm.in
|
||||
@@ -20,7 +20,7 @@ our $exec_prefix = "@exec_prefix@";
|
||||
|
||||
## Then, process the variables provided by innconfval.
|
||||
my @INNCONFVAR = ();
|
||||
-my @values = `${exec_prefix}/bin/innconfval -p`;
|
||||
+my @values = `@bindir@/innconfval -p`;
|
||||
foreach $line (@values) {
|
||||
eval 'our '.$line;
|
||||
if ($line =~ /^(.*?) = /m) {
|
Loading…
Reference in a new issue