sandboxctl: don't use tar -e on netbsd. it's not supported by the newly
default libarchive tar. From Robert Nestor on pkgsrc-users. bump PKGREVISION
This commit is contained in:
parent
9e53461fdf
commit
9d5045c8a8
3 changed files with 33 additions and 2 deletions
|
@ -1,6 +1,7 @@
|
|||
# $NetBSD: Makefile,v 1.2 2019/01/14 10:52:49 jmmv Exp $
|
||||
# $NetBSD: Makefile,v 1.3 2019/09/20 22:31:30 maya Exp $
|
||||
|
||||
DISTNAME= sandboxctl-1.1
|
||||
PKGREVISION= 1
|
||||
CATEGORIES= sysutils
|
||||
MASTER_SITES= ${MASTER_SITE_GITHUB:=jmmv/}sandboxctl/releases/download/sandboxctl-1.1/
|
||||
|
||||
|
|
|
@ -1,6 +1,7 @@
|
|||
$NetBSD: distinfo,v 1.2 2019/01/14 10:52:49 jmmv Exp $
|
||||
$NetBSD: distinfo,v 1.3 2019/09/20 22:31:30 maya Exp $
|
||||
|
||||
SHA1 (sandboxctl-1.1.tar.gz) = 9157936300f3a95086ebf856dfbb4cf848e75f44
|
||||
RMD160 (sandboxctl-1.1.tar.gz) = 52001bd2dade10866d588268094dc7b1d36b93af
|
||||
SHA512 (sandboxctl-1.1.tar.gz) = 066c188f3d5a058c2260c30fbbf208b340060cdc37fa84d594a3b409443ef40c07857ef568107aae1027b75f5533f574d84fcfe984941298e7147c19336957f9
|
||||
Size (sandboxctl-1.1.tar.gz) = 99040 bytes
|
||||
SHA1 (patch-sandbox.subr.in) = 45fa0c7f9e9539317581f5ff2570ff04b78e948b
|
||||
|
|
29
sysutils/sandboxctl/patches/patch-sandbox.subr.in
Normal file
29
sysutils/sandboxctl/patches/patch-sandbox.subr.in
Normal file
|
@ -0,0 +1,29 @@
|
|||
$NetBSD: patch-sandbox.subr.in,v 1.1 2019/09/20 22:31:30 maya Exp $
|
||||
|
||||
Don't use tar -e on netbsd. It's not supported by libarchive tar,
|
||||
the default since NetBSD 9.x.
|
||||
|
||||
--- sandbox.subr.in.orig 2019-01-14 02:17:11.000000000 +0000
|
||||
+++ sandbox.subr.in
|
||||
@@ -366,19 +366,12 @@ sandbox_extract() {
|
||||
*) shtk_cli_error "Cannot determine compression format for ${file}"
|
||||
esac
|
||||
|
||||
- local tar_extra_flags=
|
||||
- case "$(uname -s)" in
|
||||
- NetBSD)
|
||||
- tar_extra_flags=e # Stop on first error.
|
||||
- ;;
|
||||
- esac
|
||||
-
|
||||
if shtk_cli_log_level debug && which progress >/dev/null 2>&1 \
|
||||
&& [ "${format}" = z ]; then
|
||||
- progress -zf "${file}" tar "-${tar_extra_flags}xp" -C "${dir}" \
|
||||
+ progress -zf "${file}" tar "-xp" -C "${dir}" \
|
||||
-f - "${@}" || shtk_cli_error "Extraction of ${file} failed"
|
||||
else
|
||||
- tar "-${tar_extra_flags}x${format}p" -f "${file}" -C "${dir}" "${@}" \
|
||||
+ tar "-x${format}p" -f "${file}" -C "${dir}" "${@}" \
|
||||
|| shtk_cli_error "Extraction of ${file} failed"
|
||||
fi
|
||||
}
|
Loading…
Reference in a new issue