Initial import of "xm7" package.

X11-based FM-7 emulator
This commit is contained in:
kei 2000-12-13 17:12:19 +00:00
parent d97a637b50
commit 9d51806bb7
10 changed files with 178 additions and 0 deletions

35
emulators/xm7/Makefile Normal file
View file

@ -0,0 +1,35 @@
# $NetBSD: Makefile,v 1.1.1.1 2000/12/13 17:12:19 kei Exp $
#
DISTNAME= xm71010s
PKGNAME= xm7-1010s
CATEGORIES= emulators
MASTER_SITES= http://www.ipc-tokai.or.jp/~ytanaka/fm7/
EXTRACT_SUFX= .lzh
MAINTAINER= tech-pkg-ja@jp.NetBSD.org
HOMEPAGE= http://www.ipc-tokai.or.jp/~ytanaka/fm7/xm7.shtml
NO_WRKSUBDIR= # empty
WRKSRC= ${WRKDIR}/vm
RESTRICTED= source archive is not redistributable
RESTRICTED+= no-commercial-use
NO_SRC_ON_CDROM= ${RESTRICTED}
NO_SRC_ON_FTP= ${RESTRICTED}
MIRROR_DISTFILES= no
LHA= lha
# convert CRLF to LF and sjis encoding to EUC-JP in text files.
EXTRACT_CMD= ${LHA} xqte ${DOWNLOADED_DISTFILE}
BUILD_DEPENDS+= nkf:../../japanese/nkf
NO_CONFIGURE= yes
MAKEFILE= Makefile.X11
post-extract:
@cd ${WRKDIR}; ${MV} linux/* vm
do-install:
${INSTALL_PROGRAM} ${WRKDIR}/vm/xm7 ${PREFIX}/bin
.include "../../mk/bsd.pkg.mk"

3
emulators/xm7/files/md5 Normal file
View file

@ -0,0 +1,3 @@
$NetBSD: md5,v 1.1.1.1 2000/12/13 17:12:19 kei Exp $
MD5 (xm71010s.lzh) = bb0dba4de2ecc79118d799ecf37849aa

View file

@ -0,0 +1,6 @@
$NetBSD: patch-sum,v 1.1.1.1 2000/12/13 17:12:19 kei Exp $
MD5 (patch-aa) = 27b354d42d60d26bf5bf8098e80db8a6
MD5 (patch-ab) = 72fb243899d05bdd7323174ec114a1bb
MD5 (patch-ac) = c16c72eb0608659f9102333c5c045ebe
MD5 (patch-ad) = 770a8b8692228e08ece906817b9d77d6

View file

@ -0,0 +1,78 @@
$NetBSD: patch-aa,v 1.1.1.1 2000/12/13 17:12:19 kei Exp $
--- Makefile.X11.orig Thu Mar 23 01:01:00 2000
+++ Makefile.X11 Sat Aug 12 12:54:54 2000
@@ -6,21 +6,29 @@
COMMONSRC = \
debug.c disasm.c gui.c \
- cpu_x86.asm fdc.c keyboard.c kanji.c tapelp.c \
+ fdc.c keyboard.c kanji.c tapelp.c \
maincpu.c mainmem.c mainetc.c system.c multipag.c \
subcpu.c submem.c display.c subctrl.c tools.c ttlpalet.c \
opn.c opna.cpp fmgen.cpp psg.cpp
+.if defined(__i386__)
+COMMONSRC += cpu_x86.asm
+.endif
+
LOCALSRC = \
xw_disp.c xw_key.c xw_main.c xw_file.c xw_snd.cpp
COMMONOBJ = \
debug.o disasm.o gui.o \
- cpu_x86.o fdc.o keyboard.o kanji.o tapelp.o \
+ fdc.o keyboard.o kanji.o tapelp.o \
maincpu.o mainmem.o mainetc.o system.o multipag.o \
subcpu.o submem.o display.o subctrl.o tools.o ttlpalet.o \
opn.o opna.o fmgen.o psg.o
+.if defined(__i386__)
+COMMONSRC += cpu_x86.o
+.endif
+
LOCALOBJ = \
xw_disp.o xw_key.o xw_main.o xw_file.o xw_snd.o
@@ -29,22 +37,27 @@
SRCS = ${COMMONSRC} ${LOCALSRC}
OBJS = ${COMMONOBJ} ${LOCALOBJ}
#LIBS = -L/usr/X11R6/lib -lX11 -lXt -lXext -lm -lc
-LIBS = -L/usr/X11R6/lib -lX11 -lXt -lXext -lm -lc -lstdc++
+LIBS = -L/usr/X11R6/lib -R/usr/X11R6/lib -lX11 -lXt -lXext -lm -lc -lstdc++ \
+ -lossaudio
#CFLAGS = -D_XWIN -DNDEBUG -O3 -funroll-loops -I/usr/X11R6/include -I.
+.if defined(__i386__)
CFLAGS = -D_XWIN -DNDEBUG -DCPU_ASM -O3 -I/usr/X11R6/include -I.
+.else
+CFLAGS = -D_XWIN -DNDEBUG -O3 -I/usr/X11R6/include -I.
+.endif
ASFLAGS = -f elf -d _XWIN
all: xm7
xm7: ${OBJS}
- gcc -o xm7 ${OBJS} ${LIBS}
+ ${CC} -o xm7 ${OBJS} ${LIBS}
.c.o:
- gcc ${CFLAGS} -o $@ -c $<
+ ${CC} ${CFLAGS} -o $@ -c $<
.cpp.o:
- g++ ${CFLAGS} -o $@ -c $<
+ ${CC} ${CFLAGS} -o $@ -c $<
.asm.o:
nasm ${ASFLAGS} $<
@@ -56,7 +69,7 @@
find . -type l -exec rm -f {} \;
convert:
- ./convert.sh
+ sh ./convert.sh
symlink:
- ./symlink.sh
+ sh ./symlink.sh

View file

@ -0,0 +1,12 @@
$NetBSD: patch-ab,v 1.1.1.1 2000/12/13 17:12:19 kei Exp $
--- convert.sh.orig Sat Aug 12 12:17:15 2000
+++ convert.sh Sat Aug 12 12:18:36 2000
@@ -7,3 +7,7 @@
rm t t.lzh
done
+for X in *.cpp;do
+nkf -e < $X > t
+mv t $X
+done

View file

@ -0,0 +1,20 @@
$NetBSD: patch-ac,v 1.1.1.1 2000/12/13 17:12:19 kei Exp $
--- xw_disp.c.orig Thu Mar 23 01:01:00 2000
+++ xw_disp.c Sat Aug 12 12:32:32 2000
@@ -24,11 +24,14 @@
#include <X11/Xatom.h>
#include <X11/keysym.h>
#include <string.h>
+#if defined(__NetBSD__)
+#include <errno.h>
+#endif
#include <sys/time.h>
#include <sys/errno.h>
/**/
#include <X11/extensions/XShm.h>
-#ifdef __FreeBSD__
+#if defined(__FreeBSD__) || defined(__NetBSD__)
#include <machine/param.h>
#endif
#include <sys/types.h>

View file

@ -0,0 +1,13 @@
$NetBSD: patch-ad,v 1.1.1.1 2000/12/13 17:12:19 kei Exp $
--- xw_snd.cpp.orig Sat Aug 12 12:33:21 2000
+++ xw_snd.cpp Sat Aug 12 12:36:19 2000
@@ -24,6 +24,8 @@
#include <sys/time.h>
#ifdef __FreeBSD__
#include <machine/soundcard.h>
+#elif defined(__NetBSD__)
+#include <soundcard.h>
#else
#include <linux/soundcard.h>
#endif

View file

@ -0,0 +1 @@
X11-based FM-7 emulator

8
emulators/xm7/pkg/DESCR Normal file
View file

@ -0,0 +1,8 @@
XM7 is the X11 based emulator of FM-7, which was the very
popular personal computer in Japan at 8-bits age. It has a
built-in ROM BASIC, two M6809 microprocessors, and many other
good features. It was produced by FUJITSU LIMITED.
You must own a real machine and make required ROM files from
it to run FM-7 software on it. But it'd be rather difficalt
in these days.

2
emulators/xm7/pkg/PLIST Normal file
View file

@ -0,0 +1,2 @@
@comment $NetBSD: PLIST,v 1.1.1.1 2000/12/13 17:12:19 kei Exp $
bin/xm7