Taking the address of a temporary object is not valid C++.
This commit is contained in:
parent
d62ed74ad0
commit
9d5d782e0a
3 changed files with 33 additions and 1 deletions
|
@ -1,8 +1,10 @@
|
|||
$NetBSD: distinfo,v 1.16 2012/01/03 01:18:46 dholland Exp $
|
||||
$NetBSD: distinfo,v 1.17 2012/10/20 22:03:01 joerg Exp $
|
||||
|
||||
SHA1 (boolean_6_99.tgz) = 03e8dc7c9aa2886b0d5663669248c507524c5b22
|
||||
RMD160 (boolean_6_99.tgz) = 7977bb140169fa15a7dde9709ba1867e763b7b9c
|
||||
Size (boolean_6_99.tgz) = 4270460 bytes
|
||||
SHA1 (patch-aa) = 0ca93dd87f8c314d718b63a14a94cbea7739b5a3
|
||||
SHA1 (patch-ab) = 688efee8aeb2f2616a6f67a2dbfd1055d48cb9b3
|
||||
SHA1 (patch-apps_edit_src_drivers_printer.cpp) = fcbe44d1f059bb9ee2cf8301a7f02ec0686b318a
|
||||
SHA1 (patch-apps_edit_src_gdssourc_text.cpp) = da50d4d3156e807177cdc7d71c8de586dbd04f6d
|
||||
SHA1 (patch-apps_edit_src_intrface_strucdlg_cpp) = 44637ca6b71f722c55f0986ee31ee29f35fe8858
|
||||
|
|
14
cad/boolean/patches/patch-apps_edit_src_drivers_printer.cpp
Normal file
14
cad/boolean/patches/patch-apps_edit_src_drivers_printer.cpp
Normal file
|
@ -0,0 +1,14 @@
|
|||
$NetBSD: patch-apps_edit_src_drivers_printer.cpp,v 1.1 2012/10/20 22:03:01 joerg Exp $
|
||||
|
||||
--- apps/edit/src/drivers/printer.cpp.orig 2012-10-20 12:02:42.000000000 +0000
|
||||
+++ apps/edit/src/drivers/printer.cpp
|
||||
@@ -87,7 +87,8 @@ bool PrintDriver::OnPrintPage(int)
|
||||
// Multiply the points with the relative matrix
|
||||
for (int i = 0; i < 4; i++)
|
||||
{
|
||||
- corners[i].Transform(&GLOB->SCRDRV->GetInverseMappingMatrix());
|
||||
+ wxTransformMatrix tmp(GLOB->SCRDRV->GetInverseMappingMatrix());
|
||||
+ corners[i].Transform(&tmp);
|
||||
}
|
||||
x = (int) corners[0].GetX();
|
||||
y = (int) corners[0].GetY();
|
16
cad/boolean/patches/patch-apps_edit_src_gdssourc_text.cpp
Normal file
16
cad/boolean/patches/patch-apps_edit_src_gdssourc_text.cpp
Normal file
|
@ -0,0 +1,16 @@
|
|||
$NetBSD: patch-apps_edit_src_gdssourc_text.cpp,v 1.1 2012/10/20 22:03:01 joerg Exp $
|
||||
|
||||
--- apps/edit/src/gdssourc/text.cpp.orig 2012-10-20 11:58:47.000000000 +0000
|
||||
+++ apps/edit/src/gdssourc/text.cpp
|
||||
@@ -61,9 +61,10 @@ void Text::DoWrite(DrawDriver& dr)
|
||||
|
||||
dr.SetSelected(GetSelect());
|
||||
|
||||
+ wxTransformMatrix tmp(*dr.GetMatrix() * *GetRelativeMatrix());
|
||||
dr.GDSDrawText(_text, min_point.GetX(), min_point.GetY(),
|
||||
max_point.GetX(), max_point.GetY(),
|
||||
- this, &(*dr.GetMatrix() * *GetRelativeMatrix()));
|
||||
+ this, &tmp);
|
||||
|
||||
}
|
||||
|
Loading…
Reference in a new issue