Fix building with Clang; Fix installing on Mac OS X

This commit is contained in:
adam 2012-01-16 20:36:08 +00:00
parent d93a046ff6
commit 9d8a5f4713
4 changed files with 31 additions and 2 deletions

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.19 2012/01/13 10:55:31 obache Exp $
# $NetBSD: Makefile,v 1.20 2012/01/16 20:36:08 adam Exp $
DISTNAME= qca-2.0.3
PKGNAME= qca2-${DISTNAME:C/.*-//}
@ -27,6 +27,7 @@ CONFIGURE_ARGS+= --prefix=${QTDIR}
CONFIGURE_ARGS+= --qtdir=${QTDIR}
CONFIGURE_ARGS+= --disable-tests
CONFIGURE_ARGS+= --certstore-internal
CONFIGURE_ARGS+= --no-framework
post-install:
${INSTALL_DATA} ${DESTDIR}${QTDIR}/lib/pkgconfig/qca2.pc ${DESTDIR}${PREFIX}/lib/pkgconfig/qca2.pc

View file

@ -1,6 +1,8 @@
$NetBSD: distinfo,v 1.5 2010/12/02 15:03:56 wiz Exp $
$NetBSD: distinfo,v 1.6 2012/01/16 20:36:08 adam Exp $
SHA1 (qca-2.0.3.tar.bz2) = 9c868b05b81dce172c41b813de4de68554154c60
RMD160 (qca-2.0.3.tar.bz2) = 333cfdce91fedfaec09c205528de52d7b569c521
Size (qca-2.0.3.tar.bz2) = 4530731 bytes
SHA1 (patch-aa) = e9c7791aac4b8764100a95a596e109e6ebb6abf0
SHA1 (patch-configure) = c114e4f6c2982f8293d37b332a44781fd884412b
SHA1 (patch-src_botantools_botan_botan_secmem.h) = 4cb74801291dadb4d2c15c741bbb3b836135fcd9

View file

@ -0,0 +1,13 @@
$NetBSD: patch-configure,v 1.1 2012/01/16 20:36:08 adam Exp $
--- configure.orig 2012-01-16 20:32:17.000000000 +0000
+++ configure
@@ -977,7 +977,7 @@ public:
{
bundled = false;
-#if defined(Q_OS_WIN) || defined(Q_OS_MAC)
+#if defined(Q_OS_WIN)
// use built-in
return true;
#else

View file

@ -0,0 +1,13 @@
$NetBSD: patch-src_botantools_botan_botan_secmem.h,v 1.1 2012/01/16 20:36:08 adam Exp $
--- src/botantools/botan/botan/secmem.h.orig 2012-01-16 18:21:07.000000000 +0000
+++ src/botantools/botan/botan/secmem.h
@@ -214,7 +214,7 @@ class SecureVector : public MemoryRegion
SecureVector(u32bit n = 0) { MemoryRegion<T>::init(true, n); }
SecureVector(const T in[], u32bit n)
- { MemoryRegion<T>::init(true); set(in, n); }
+ { MemoryRegion<T>::init(true); this->set(in, n); }
SecureVector(const MemoryRegion<T>& in)
{ MemoryRegion<T>::init(true); set(in); }
SecureVector(const MemoryRegion<T>& in1, const MemoryRegion<T>& in2)