Added a chunk to patch-aa that comments out unnecessary code (statvfs). Now

the package builds on NetBSD-1.6.2. Bumped PKGREVISION.
This commit is contained in:
rillig 2005-09-25 10:40:18 +00:00
parent 7ab846256d
commit 9dc93f3d48
3 changed files with 22 additions and 6 deletions

View file

@ -1,6 +1,7 @@
# $NetBSD: Makefile,v 1.8 2005/07/12 09:55:57 adam Exp $
# $NetBSD: Makefile,v 1.9 2005/09/25 10:40:18 rillig Exp $
DISTNAME= dbench-3.03
PKGREVISION= 1
CATEGORIES= benchmarks
MASTER_SITES= http://samba.org/ftp/tridge/dbench/

View file

@ -1,6 +1,6 @@
$NetBSD: distinfo,v 1.6 2005/07/12 09:55:57 adam Exp $
$NetBSD: distinfo,v 1.7 2005/09/25 10:40:18 rillig Exp $
SHA1 (dbench-3.03.tar.gz) = 9261e6c3d800ee6822be579ac37a9d531a03e4c2
RMD160 (dbench-3.03.tar.gz) = 1fc311e3d598f25b96448002006a94e24ae8424a
Size (dbench-3.03.tar.gz) = 2076982 bytes
SHA1 (patch-aa) = d31fca72a9b733f6e6540b75a8acc9da44fe74d8
SHA1 (patch-aa) = b2a134ef7650bef60551972f5c3c0209d6d41112

View file

@ -1,7 +1,7 @@
$NetBSD: patch-aa,v 1.3 2005/03/25 15:44:38 minskim Exp $
$NetBSD: patch-aa,v 1.4 2005/09/25 10:40:18 rillig Exp $
--- fileio.c.orig Wed Oct 15 20:59:00 2003
+++ fileio.c
--- fileio.c.orig Mon Dec 13 03:47:59 2004
+++ fileio.c Sat Sep 24 23:06:17 2005
@@ -19,6 +19,10 @@
*/
@ -13,3 +13,18 @@ $NetBSD: patch-aa,v 1.3 2005/03/25 15:44:38 minskim Exp $
#define MAX_FILES 200
@@ -375,12 +379,14 @@ void nb_qfileinfo(struct child_struct *c
void nb_qfsinfo(struct child_struct *child, int level, const char *status)
{
+#if 0 /* does this code do anything useful? */
struct statvfs st;
(void)level;
(void)status;
statvfs(child->directory, &st);
+#endif
}
void nb_findfirst(struct child_struct *child, char *fname, int level, int maxcnt,