print/poppler016: Fix poppler-qt.pc (Fixes KOffice, kdegraphics3)

Remove a dependency to poppler-0.16 in the poppler-qt.pc file so
that pkg-config --cflags "poppler-qt >= 0.3.1" returns valid information.

Default poppler version is now 0.20.x.  Since this package explicitly uses
0.16.x, @PC_REQUIRES_PRIVATE@ introduces a dependency to poppler-0.16.x in
the .pc file; pkg-config will then print messages such as "Package
'poppler-qt' requires 'poppler = 0.16.7' but version of poppler is 0.20.2"
instead of the required information.  Removing the Requires.private line
entirely fixes the issue.

After applying this patch and rebuilding poppler-qt, graphics/kdegraphics3
and misc/koffice now build on DragonFly.  Previously they failed with
poppler-related errors.

Patch provided by F.Tigeot.
This commit is contained in:
marino 2012-08-13 16:15:20 +00:00
parent 3d9792f84a
commit 9e8e6f9300
3 changed files with 28 additions and 3 deletions

View file

@ -1,7 +1,7 @@
# $NetBSD: Makefile,v 1.1 2012/07/04 20:15:46 drochner Exp $
# $NetBSD: Makefile,v 1.2 2012/08/13 16:15:20 marino Exp $
#
PKGREVISION= 1
PKGREVISION= 2
.include "../../print/poppler016/Makefile.common"

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.1 2012/07/04 20:15:46 drochner Exp $
$NetBSD: distinfo,v 1.2 2012/08/13 16:15:21 marino Exp $
SHA1 (poppler-0.16.7.tar.gz) = 26c735f863688f62b57d5159863fdad4272be89f
RMD160 (poppler-0.16.7.tar.gz) = 279330e6feaf97a207f3396eab1af836d3d1f16c
@ -12,3 +12,4 @@ SHA1 (patch-ao) = cf7e0f086522147a91f59b1b26ca510d1971ac74
SHA1 (patch-aq) = 17db7fb50937611ff253f48241503281fb642f63
SHA1 (patch-ar) = d24b92939deaccde42bbb0be48930b37d0f1a87f
SHA1 (patch-as) = f0f4f8d9f5a49173a27e2349be4b7536ed77eaae
SHA1 (patch-poppler-qt.pc.in) = e4449465d05dd517efb600101e4de3d9d8478698

View file

@ -0,0 +1,24 @@
$NetBSD: patch-poppler-qt.pc.in,v 1.1 2012/08/13 16:15:21 marino Exp $
Remove a dependency to poppler-0.16 in the poppler-qt.pc file so
that pkg-config --cflags "poppler-qt >= 0.3.1" returns valid information.
Default poppler version is now 0.20.x.
Since this package explicitely uses 0.16.x, @PC_REQUIRES_PRIVATE@
introduces a dependency to poppler-0.16.x in the .pc file;
pkg-config will then print messages such as
"Package 'poppler-qt' requires 'poppler = 0.16.7' but version of poppler is 0.20.2"
instead of the required information.
Removing the Requires.private line entirely fixes the issue.
--- poppler-qt.pc.in.orig 2010-12-27 20:44:27.000000000 +0000
+++ poppler-qt.pc.in
@@ -7,7 +7,6 @@ Name: poppler-qt
Description: Qt bindings for poppler
Version: @VERSION@
Requires: @PC_REQUIRES@
-@PC_REQUIRES_PRIVATE@
Libs: -L${libdir} -lpoppler-qt
Cflags: -I${includedir}/poppler/qt3