dbus: update to 1.12.2.

dbus 1.12.2 (2017-11-13)
========================

The “spider pumpkin” release.

Enhancements:

• Log a warning if a new connection cannot be accepted due to an
  out-of-memory condition or failure to identify its AppArmor or
  SELinux context (fd.o #103592, Simon McVittie)

Fixes:

• Make use of $(MKDIR_P) compatible with install-sh, fixing build when a
  GNU-compatible `mkdir -p` is not available (fd.o #103521, ilovezfs)

• When building for Windows with Autotools, avoid `echo -e`, fixing
  cross-compilation on non-GNU platforms like macOS
  (fd.o #103493, Tony Theodore)

• Fix crashes in the server side of the nonce-tcp: transport under
  various error conditions. This transport should normally only be used
  on Windows, where AF_UNIX sockets are unavailable; the unix: transport
  is the only one recommended for production use on Unix platforms.
  (fd.o #103597, Simon McVittie)

Internal changes:

• Improve test coverage on Travis-CI (Simon McVittie)

dbus 1.12.0 (2017-10-30)
========================

The “gingerbread skull” release.

1.12.x is a new stable branch, recommended for use in OS
distributions.

Summary of major changes between 1.10.x and 1.12.0
--------------------------------------------------

Dependencies:

• Expat >= 2.1.0 is required.
• GLib >= 2.40 is required if full test coverage is enabled.
• [Linux] libselinux >= 2.0.86 is required if SELinux support is
  enabled.
• [Unix] dbus now requires an <inttypes.h> that defines C99 constants
  such as PRId64 and PRIu64, except when building for Windows.
• [Autotools] Building from git (but not from tarballs) with Autotools
  now requires macros from the GNU Autoconf Archive.
• [CMake] Builds done using CMake now require CMake 3.0.2.

Build-time configuration changes:

• Expat is now found using pkg-config. See the release notes for
  1.11.14.
• The --disable-compiler-optimisations and --enable-compiler-coverage
  options no longer exist.  See the release notes for 1.11.4 and 1.11.8.
• [Unix] The --enable-abstract-sockets and --disable-abstract-sockets
  options no longer exist. See the release notes for 1.11.20.
• [Unix] Flag files in /var/run/console/${username} are no longer
  checked for at_console by default. See the release notes for 1.11.18.
• [Unix, Cygwin] Init scripts are no longer provided by upstream dbus,
  and packagers will now need to add these downstream (most already do).
  See the release notes for 1.11.18.
• [Unix] The process ID file no longer has a different default location
  on Red Hat derivatives. See the release notes for 1.11.18.
• [Unix] ${runstatedir} is now independent of ${localstatedir} with
  recent Autotools versions. See the release notes for 1.11.16.
• [Windows] The WINDRES variable is no longer used. See the release
  notes for 1.11.22.

Deprecations:

• Eavesdropping is officially deprecated in favour of BecomeMonitor.
  See the release notes for spec version 0.31 (in dbus 1.11.14).
• [Unix] Flag files in /var/run/console/${username} are deprecated.
  See the release notes for 1.11.18.

New APIs:

• <allow> and <deny> rules in dbus-daemon configuration can now
  include send_broadcast="true", send_broadcast="false",
  max_unix_fds="N", min_unix_fds="N" (for some integer N).
  See the release notes for 1.11.18.
• dbus_try_get_local_machine_id() is like
  dbus_get_local_machine_id(), but returns a DBusError.
• New APIs around DBusMessageIter to simplify cleanup.
  See the release notes for 1.11.16.
• The message bus daemon now implements the standard Introspectable,
  Peer and Properties interfaces. See the release notes for
  dbus 1.11.14 and spec version 0.31.
• DTDs for introspection XML and bus configuration are installed.
• dbus can be compiled to be relocatable, making it more suitable for
  binary bundling with other software. On Windows, this is on by
  default.
• [Unix] A new unix:dir=… address family resembles unix:tmpdir=… but
  never uses Linux abstract sockets, which is advantageous for
  containers. On non-Linux it is equivalent to unix:tmpdir=….
  See the release notes for dbus 1.11.14 and spec version 0.31.
• [Unix] New option "dbus-launch --exit-with-x11".
• [Unix] Session managers can create transient .service files in
  $XDG_RUNTIME_DIR/dbus-1/services. See the release notes for 1.11.12.
• [Unix] A sysusers.d snippet can create the messagebus user on-demand.

Miscellaneous behaviour changes:

• [Unix] The session bus now logs to syslog if it was started by
  dbus-launch.
• [Unix] Internal warnings are logged to syslog if configured.
• [Unix] Exceeding an anti-DoS limit is logged to syslog if configured,
  or to stderr.
This commit is contained in:
wiz 2017-11-23 14:43:23 +00:00
parent d82acd7955
commit 9eaaf17403
6 changed files with 39 additions and 36 deletions

View file

@ -1,6 +1,6 @@
# $NetBSD: Makefile,v 1.110 2017/10/02 13:36:34 wiz Exp $
# $NetBSD: Makefile,v 1.111 2017/11/23 14:43:23 wiz Exp $
DISTNAME= dbus-1.10.24
DISTNAME= dbus-1.12.2
CATEGORIES= sysutils
MASTER_SITES= http://dbus.freedesktop.org/releases/dbus/
@ -38,7 +38,6 @@ CONFIGURE_ARGS+= --localstatedir=${VARBASE:Q}
# directory. See the commit message on revision 1.35
CONFIGURE_ARGS+= --with-session-socket-dir=/tmp
CONFIGURE_ARGS+= --without-init-scripts
CONFIGURE_ARGS+= --disable-ansi
CONFIGURE_ARGS+= --disable-console-owner-file
CONFIGURE_ARGS+= --disable-doxygen-docs
@ -66,7 +65,6 @@ PTHREAD_AUTO_VARS= yes
.if ${OPSYS} == "Linux"
PLIST.linux= yes
.else
CONFIGURE_ARGS+= --disable-abstract-sockets
CONFIGURE_ARGS+= --disable-selinux
.endif
@ -109,5 +107,6 @@ post-install:
.include "../../mk/pthread.buildlink3.mk"
.include "../../devel/gettext-lib/buildlink3.mk"
BUILDLINK_ABI_DEPENDS.expat+= expat>=2.1.0
.include "../../textproc/expat/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

View file

@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.20 2015/08/30 15:08:00 wiz Exp $
@comment $NetBSD: PLIST,v 1.21 2017/11/23 14:43:23 wiz Exp $
${PLIST.launchd}Library/LaunchAgents/org.freedesktop.dbus-session.plist
bin/dbus-cleanup-sockets
bin/dbus-daemon
@ -26,6 +26,8 @@ include/dbus-1.0/dbus/dbus-syntax.h
include/dbus-1.0/dbus/dbus-threads.h
include/dbus-1.0/dbus/dbus-types.h
include/dbus-1.0/dbus/dbus.h
lib/cmake/DBus1/DBus1Config.cmake
lib/cmake/DBus1/DBus1ConfigVersion.cmake
lib/dbus-1.0/include/dbus/dbus-arch-deps.h
lib/libdbus-1.la
lib/pkgconfig/dbus-1.pc
@ -62,3 +64,5 @@ share/doc/dbus/examples/example-system-enable-stats.conf
share/doc/dbus/introspect.dtd
share/doc/dbus/introspect.xsl
share/doc/dbus/system-activation.txt
share/xml/dbus-1/busconfig.dtd
share/xml/dbus-1/introspect.dtd

View file

@ -1,13 +1,13 @@
$NetBSD: distinfo,v 1.84 2017/10/02 13:36:34 wiz Exp $
$NetBSD: distinfo,v 1.85 2017/11/23 14:43:23 wiz Exp $
SHA1 (dbus-1.10.24.tar.gz) = 85585fdfbaf83b7183f70eb840727172206592f9
RMD160 (dbus-1.10.24.tar.gz) = 156d6c4c089f244cbbdd6aeec03909276bc06f70
SHA512 (dbus-1.10.24.tar.gz) = fc0b88b756affdb4fc7a62e84a6f7757121293afeadc38acf8aac48b6c2b82531e136a575be2ab503a39d7669cb7b609a021e20c1064e28c965c091e94c4f68c
Size (dbus-1.10.24.tar.gz) = 1991358 bytes
SHA1 (patch-ak) = ebb0c291297577a9cff246e7bc71412bf6157254
SHA1 (patch-al) = c70be84ae79698cc4d83087427646bfb0500f194
SHA1 (dbus-1.12.2.tar.gz) = 701da5c72a721ea1c4af66bc8606ac2deb5f7159
RMD160 (dbus-1.12.2.tar.gz) = c032fedc852a1a6fccb11cea1f41c49df7466d8b
SHA512 (dbus-1.12.2.tar.gz) = 523698ae543a4f1d9142898351ed38827882a3ca583ca7934676af48d09219ea562ae77d734cd142e5ca0d5e74f9e8d0fdeb1019592ca3524e2b690c6283f7cd
Size (dbus-1.12.2.tar.gz) = 2063143 bytes
SHA1 (patch-ak) = 4535584537a22a2e42824fe45e2d75253b484147
SHA1 (patch-al) = ffaa8f224c3dd6a97ffa42fe2e9ca924160fa68c
SHA1 (patch-am) = ed334bc76911c9db9f5472c58fb762c56255c5b4
SHA1 (patch-configure) = 9dee6306aa07b60449a0f9f0f1ea3dccbc70dcb4
SHA1 (patch-dbus_dbus-sysdeps-unix.c) = 3dfc60eba7ab9d5a29d2a842ce0baa1b109df716
SHA1 (patch-dbus_dbus-sysdeps-util-unix.c) = 9c967cdac585220a3e65443dc9642e7d4478567c
SHA1 (patch-dbus_dbus-sysdeps-util-unix.c) = 1a25e53514064e452a207ad8b2a0057c11d5c190
SHA1 (patch-tools_dbus-print-message.c) = 96267d3cff2c5207911615735748ef81604a69ec

View file

@ -1,15 +1,15 @@
$NetBSD: patch-ak,v 1.5 2015/12/06 11:35:55 wiz Exp $
$NetBSD: patch-ak,v 1.6 2017/11/23 14:43:23 wiz Exp $
Adapt path for pkgsrc.
--- dbus/Makefile.in.orig 2015-08-25 15:52:09.000000000 +0000
--- dbus/Makefile.in.orig 2017-11-13 13:36:10.000000000 +0000
+++ dbus/Makefile.in
@@ -589,7 +589,7 @@ dbusdatadir = $(datadir)/dbus-1
AM_CPPFLAGS = -I$(top_builddir) -I$(top_srcdir) \
$(DBUS_STATIC_BUILD_CPPFLAGS) $(SYSTEMD_CFLAGS) \
$(VALGRIND_CFLAGS) -DDBUS_COMPILATION \
@@ -619,7 +619,7 @@ dbusdatadir = $(datadir)/dbus-1
AM_CPPFLAGS = $(CODE_COVERAGE_CPPFLAGS) -I$(top_builddir) \
-I$(top_srcdir) $(DBUS_STATIC_BUILD_CPPFLAGS) \
$(SYSTEMD_CFLAGS) $(VALGRIND_CFLAGS) -DDBUS_COMPILATION \
- -DDBUS_MACHINE_UUID_FILE=\""$(localstatedir)/lib/dbus/machine-id"\" \
+ -DDBUS_MACHINE_UUID_FILE=\""$(localstatedir)/db/dbus/machine-id"\" \
-DDBUS_SYSTEM_CONFIG_FILE=\""$(dbusdatadir)/system.conf"\" \
-DDBUS_SESSION_CONFIG_FILE=\""$(dbusdatadir)/session.conf"\" \
$(NULL) $(am__append_2)
-DDBUS_RUNSTATEDIR=\""$(runstatedir)"\" $(NULL) \

View file

@ -1,10 +1,10 @@
$NetBSD: patch-al,v 1.5 2015/12/06 11:35:55 wiz Exp $
$NetBSD: patch-al,v 1.6 2017/11/23 14:43:23 wiz Exp $
Adapt path for pkgsrc.
--- tools/Makefile.in.orig 2015-07-21 16:32:32.000000000 +0000
--- tools/Makefile.in.orig 2017-11-13 13:36:10.000000000 +0000
+++ tools/Makefile.in
@@ -428,7 +428,7 @@ AM_CPPFLAGS = \
@@ -515,7 +515,7 @@ AM_CPPFLAGS = \
$(DBUS_STATIC_BUILD_CPPFLAGS) \
$(DBUS_X_CFLAGS) \
-DDBUS_COMPILATION \
@ -12,10 +12,10 @@ Adapt path for pkgsrc.
+ -DDBUS_MACHINE_UUID_FILE=\""$(localstatedir)/db/dbus/machine-id"\" \
$(NULL)
@@ -847,9 +847,9 @@ uninstall-am: uninstall-binPROGRAMS
.PRECIOUS: Makefile
AM_CFLAGS = \
@@ -1092,9 +1092,9 @@ uninstall-am: uninstall-binPROGRAMS unin
@DBUS_WIN_TRUE@disable-uac.rc: Win32.Manifest
@DBUS_WIN_TRUE@ echo '1 24 "$<"' > $@
-# create the /var/lib/dbus directory for dbus-uuidgen
+# create the /var/db/dbus directory for dbus-uuidgen

View file

@ -1,12 +1,12 @@
$NetBSD: patch-dbus_dbus-sysdeps-util-unix.c,v 1.3 2014/09/13 09:47:11 richard Exp $
$NetBSD: patch-dbus_dbus-sysdeps-util-unix.c,v 1.4 2017/11/23 14:43:23 wiz Exp $
add solaris specific console_user test
--- dbus/dbus-sysdeps-util-unix.c.orig 2014-01-25 12:39:25.000000000 +0000
--- dbus/dbus-sysdeps-util-unix.c.orig 2017-10-30 12:26:18.000000000 +0000
+++ dbus/dbus-sysdeps-util-unix.c
@@ -54,6 +54,10 @@
#include <syslog.h>
#endif
@@ -51,6 +51,10 @@
#include <dirent.h>
#include <sys/un.h>
+#if defined(__sun) && defined(__SVR4)
+#include <pwd.h>
@ -15,8 +15,8 @@ add solaris specific console_user test
#ifdef HAVE_SYS_SYSLIMITS_H
#include <sys/syslimits.h>
#endif
@@ -556,8 +560,31 @@ _dbus_user_at_console (const char *usern
@@ -551,8 +555,31 @@ _dbus_user_at_console (const char *usern
#ifdef DBUS_CONSOLE_AUTH_DIR
DBusString u, f;
dbus_bool_t result;
+#if defined(__sun) && defined(__SVR4)
@ -47,11 +47,11 @@ add solaris specific console_user test
if (!_dbus_string_init (&f))
{
_DBUS_SET_OOM (error);
@@ -582,6 +609,7 @@ _dbus_user_at_console (const char *usern
@@ -577,6 +604,7 @@ _dbus_user_at_console (const char *usern
out:
_dbus_string_free (&f);
+#endif
return result;
}
#else