Some maintainous to dbus pacakge, approved by agc@.
* Change "${VARBASE}/lib/dbus" to "${VARBASE}/db/dbus". * Create "${VARBASE}/db/dbus" with OWN_DIRS_PERMS at install time. * Generate "${VARBASE}/db/dbus/machine-id" file at install time. * Install dbus-daemon-launch-helper with mode 04550 instead of 04750. It solves start gimp successfully without running dbus-daemon as before. Bump PKGREVISION.
This commit is contained in:
parent
dc6f08ef29
commit
9ec7528abd
7 changed files with 73 additions and 14 deletions
9
sysutils/dbus/INSTALL
Normal file
9
sysutils/dbus/INSTALL
Normal file
|
@ -0,0 +1,9 @@
|
|||
# $NetBSD: INSTALL,v 1.1 2008/09/24 11:37:31 taca Exp $
|
||||
|
||||
DBUS_UUIDGEN="@PREFIX@/bin/dbus-uuidgen"
|
||||
|
||||
case ${STAGE} in
|
||||
POST-INSTALL)
|
||||
${DBUS_UUIDGEN} --ensure
|
||||
;;
|
||||
esac
|
|
@ -1,7 +1,8 @@
|
|||
# $NetBSD: Makefile,v 1.31 2008/08/15 12:15:17 wiz Exp $
|
||||
# $NetBSD: Makefile,v 1.32 2008/09/24 11:37:31 taca Exp $
|
||||
#
|
||||
|
||||
DISTNAME= dbus-1.2.3
|
||||
PKGREVISION= 1
|
||||
CATEGORIES= sysutils
|
||||
MASTER_SITES= http://dbus.freedesktop.org/releases/dbus/
|
||||
|
||||
|
@ -24,6 +25,8 @@ PKG_DESTDIR_SUPPORT= user-destdir
|
|||
|
||||
BUILD_DEFS+= VARBASE
|
||||
|
||||
OWN_DIRS_PERMS+= ${VARBASE}/db/dbus ${DBUS_USER} ${DBUS_GROUP} 0755
|
||||
|
||||
.include "../../mk/bsd.prefs.mk"
|
||||
|
||||
CONFIGURE_ARGS+= --localstatedir=${VARBASE:Q}
|
||||
|
|
|
@ -1,10 +1,12 @@
|
|||
$NetBSD: distinfo,v 1.25 2008/08/16 16:38:01 drochner Exp $
|
||||
$NetBSD: distinfo,v 1.26 2008/09/24 11:37:31 taca Exp $
|
||||
|
||||
SHA1 (dbus-1.2.3.tar.gz) = ceb8d496bc1a9c2dcdbe559515c01ec9c0cdcf81
|
||||
RMD160 (dbus-1.2.3.tar.gz) = d1a207b2a4c744f27c9c01388e80cebdb61f43f0
|
||||
Size (dbus-1.2.3.tar.gz) = 1564475 bytes
|
||||
SHA1 (patch-aa) = e527a1a1f937781ce4204a325e3ff7f31fd6afa8
|
||||
SHA1 (patch-aa) = e81529adf01e9e6153fc401c903bd4136d592192
|
||||
SHA1 (patch-ab) = 139feeab7d469140384a30f49d70da80fa4c03bc
|
||||
SHA1 (patch-ac) = afec419973f339e846dc109866148529f80998b3
|
||||
SHA1 (patch-ag) = 999071b782982c12329025ea8e393bfed940b654
|
||||
SHA1 (patch-ai) = a45bd8d29955e9c14a4d8b3f44b42242d70c1cd8
|
||||
SHA1 (patch-ak) = 56c0a917e770b8d6ffc37ec7ab8beb631dd8ef72
|
||||
SHA1 (patch-al) = fad2f4df4537b2a3e21aaef29138060724ba8286
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
#!@RCD_SCRIPTS_SHELL@
|
||||
#
|
||||
# $NetBSD: dbus.sh,v 1.7 2006/12/15 19:06:00 drochner Exp $
|
||||
# $NetBSD: dbus.sh,v 1.8 2008/09/24 11:37:31 taca Exp $
|
||||
#
|
||||
# PROVIDE: dbus
|
||||
# REQUIRE: DAEMON
|
||||
|
@ -16,12 +16,12 @@ pidfile="@VARBASE@/run/dbus/pid"
|
|||
start_precmd=dbus_prestart
|
||||
|
||||
dbus_prestart() {
|
||||
for f in "@VARBASE@/lib/dbus" "@VARBASE@/run/dbus"; do
|
||||
if @TEST@ ! -d $f; then
|
||||
@MKDIR@ $f
|
||||
@CHMOD@ 0755 $f
|
||||
@CHOWN@ @DBUS_USER@:@DBUS_GROUP@ $f
|
||||
fi
|
||||
dir="@VARBASE@/run/dbus"
|
||||
if @TEST@ ! -d $dir; then
|
||||
@MKDIR@ $dir
|
||||
@CHMOD@ 0755 $dir
|
||||
@CHOWN@ @DBUS_USER@:@DBUS_GROUP@ $dir
|
||||
fi
|
||||
done
|
||||
@PREFIX@/bin/dbus-uuidgen --ensure
|
||||
}
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
$NetBSD: patch-aa,v 1.7 2008/06/13 11:28:35 drochner Exp $
|
||||
$NetBSD: patch-aa,v 1.8 2008/09/24 11:37:31 taca Exp $
|
||||
|
||||
--- bus/Makefile.in.orig 2008-02-26 13:36:18.000000000 -0500
|
||||
--- bus/Makefile.in.orig 2008-08-07 04:43:39.000000000 +0900
|
||||
+++ bus/Makefile.in
|
||||
@@ -411,7 +411,7 @@ target_os = @target_os@
|
||||
@@ -412,7 +412,7 @@ target_os = @target_os@
|
||||
target_vendor = @target_vendor@
|
||||
top_builddir = @top_builddir@
|
||||
top_srcdir = @top_srcdir@
|
||||
|
@ -11,7 +11,7 @@ $NetBSD: patch-aa,v 1.7 2008/06/13 11:28:35 drochner Exp $
|
|||
INCLUDES = -I$(top_srcdir) $(DBUS_BUS_CFLAGS) @PIE_CFLAGS@ \
|
||||
-DDBUS_SYSTEM_CONFIG_FILE=\""$(configdir)/system.conf"\" \
|
||||
-DDAEMON_NAME=\"dbus-daemon\" -DDBUS_COMPILATION
|
||||
@@ -1291,9 +1291,6 @@ install-data-hook:
|
||||
@@ -1291,16 +1291,13 @@ install-data-hook:
|
||||
chmod 755 $(DESTDIR)$(DBUS_DAEMONDIR); \
|
||||
fi
|
||||
$(INSTALL_PROGRAM) dbus-daemon $(DESTDIR)$(DBUS_DAEMONDIR)
|
||||
|
@ -21,3 +21,11 @@ $NetBSD: patch-aa,v 1.7 2008/06/13 11:28:35 drochner Exp $
|
|||
$(mkinstalldirs) $(DESTDIR)$(datadir)/dbus-1/services
|
||||
$(mkinstalldirs) $(DESTDIR)$(datadir)/dbus-1/system-services
|
||||
$(mkinstalldirs) $(DESTDIR)$(libexecdir)/dbus-1
|
||||
$(INSTALL_PROGRAM) dbus-daemon-launch-helper $(DESTDIR)$(libexecdir)
|
||||
if test `id -u` -eq 0; then \
|
||||
chown root:$(DBUS_USER) $(DESTDIR)$(libexecdir)/dbus-daemon-launch-helper; \
|
||||
- chmod 4750 $(DESTDIR)$(libexecdir)/dbus-daemon-launch-helper; \
|
||||
+ chmod 4550 $(DESTDIR)$(libexecdir)/dbus-daemon-launch-helper; \
|
||||
else \
|
||||
echo "Not installing $(DESTDIR)$(libexecdir)/dbus-daemon-launch-helper binary setuid!"; \
|
||||
echo "You'll need to manually set permissions to root:$(DBUS_USER) and permissions 4750"; \
|
||||
|
|
13
sysutils/dbus/patches/patch-ak
Normal file
13
sysutils/dbus/patches/patch-ak
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-ak,v 1.1 2008/09/24 11:37:31 taca Exp $
|
||||
|
||||
--- dbus/Makefile.in.orig 2008-08-07 04:43:39.000000000 +0900
|
||||
+++ dbus/Makefile.in
|
||||
@@ -310,7 +310,7 @@ top_builddir = @top_builddir@
|
||||
top_srcdir = @top_srcdir@
|
||||
configdir = $(sysconfdir)/dbus-1
|
||||
INCLUDES = -I$(top_builddir) -I$(top_srcdir) $(DBUS_CLIENT_CFLAGS) @PIC_CFLAGS@ -DDBUS_COMPILATION \
|
||||
- -DDBUS_MACHINE_UUID_FILE=\""$(localstatedir)/lib/dbus/machine-id"\" \
|
||||
+ -DDBUS_MACHINE_UUID_FILE=\""$(localstatedir)/db/dbus/machine-id"\" \
|
||||
-DDBUS_SYSTEM_CONFIG_FILE=\""$(configdir)/system.conf"\" \
|
||||
-DDBUS_SESSION_CONFIG_FILE=\""$(configdir)/session.conf"\"
|
||||
|
24
sysutils/dbus/patches/patch-al
Normal file
24
sysutils/dbus/patches/patch-al
Normal file
|
@ -0,0 +1,24 @@
|
|||
$NetBSD: patch-al,v 1.1 2008/09/24 11:37:31 taca Exp $
|
||||
|
||||
--- tools/Makefile.in.orig 2008-08-07 04:43:39.000000000 +0900
|
||||
+++ tools/Makefile.in
|
||||
@@ -301,7 +301,7 @@ target_vendor = @target_vendor@
|
||||
top_builddir = @top_builddir@
|
||||
top_srcdir = @top_srcdir@
|
||||
configdir = $(sysconfdir)/dbus-1
|
||||
-INCLUDES = -I$(top_srcdir) $(DBUS_CLIENT_CFLAGS) $(DBUS_X_CFLAGS) -DDBUS_LOCALEDIR=\"@EXPANDED_DATADIR@/locale\" -DDBUS_COMPILATION -DDBUS_DAEMONDIR=\"@DBUS_DAEMONDIR@\" -DDBUS_MACHINE_UUID_FILE=\""$(localstatedir)/lib/dbus/machine-id"\"
|
||||
+INCLUDES = -I$(top_srcdir) $(DBUS_CLIENT_CFLAGS) $(DBUS_X_CFLAGS) -DDBUS_LOCALEDIR=\"@EXPANDED_DATADIR@/locale\" -DDBUS_COMPILATION -DDBUS_DAEMONDIR=\"@DBUS_DAEMONDIR@\" -DDBUS_MACHINE_UUID_FILE=\""$(localstatedir)/db/dbus/machine-id"\"
|
||||
dbus_send_SOURCES = \
|
||||
dbus-print-message.c \
|
||||
dbus-print-message.h \
|
||||
@@ -337,8 +337,8 @@ CLEANFILES = \
|
||||
run-with-tmp-session-bus.conf
|
||||
|
||||
|
||||
-#create the /var/lib/data directory for dbus-uuidgen
|
||||
-localstatelibdir = $(localstatedir)/lib/dbus
|
||||
+#create the /var/db/dbus directory for dbus-uuidgen
|
||||
+localstatelibdir = $(localstatedir)/db/dbus
|
||||
localstatelib_DATA =
|
||||
all: all-am
|
||||
|
Loading…
Reference in a new issue