Make it build on DargonFly. Make it build on systems using non pax tar.

Bump PKGREVISION.
This commit is contained in:
hasso 2009-06-07 20:12:06 +00:00
parent 3e701dfef9
commit 9ed6613899
4 changed files with 160 additions and 10 deletions

View file

@ -1,7 +1,8 @@
# $NetBSD: Makefile,v 1.1.1.1 2009/06/05 02:57:53 minskim Exp $
# $NetBSD: Makefile,v 1.2 2009/06/07 20:12:06 hasso Exp $
DISTNAME= emacs-snapshot_20090604.orig
PKGNAME= ${DISTNAME:S/snapshot_/${EMACS_VERSION}./:S/.orig//}
PKGREVISION= 1
CATEGORIES= editors
MASTER_SITES= http://emacs.orebokech.com/pool/main/e/emacs-snapshot/
@ -14,7 +15,6 @@ PKG_DESTDIR_SUPPORT= user-destdir
CONFLICTS+= emacs-nox11-[0-9]*
FILESDIR= ${.CURDIR}/../../editors/emacs/files
GNU_CONFIGURE= yes
INFO_FILES= yes
USE_DIRS+= xdg-1.1
@ -51,7 +51,13 @@ CHECK_WRKREF_SKIP+= bin/emacs-${EMACS_VERSION}
.include "../../sysutils/desktop-file-utils/desktopdb.mk"
.include "../../mk/oss.buildlink3.mk"
.if (${OPSYS} == "DragonFly") && exists(/usr/lib/crtn.o)
CPPFLAGS+= -DDFLY_CRT_USRLIB
.endif
post-extract:
cp ${FILESDIR}/site-init.el ${WRKSRC}/lisp
cp ${.CURDIR}/../../editors/emacs/files/site-init.el ${WRKSRC}/lisp
cp ${FILESDIR}/dragonfly.h ${WRKSRC}/src/s
${CHMOD} -R go-w ${WRKSRC}
.include "../../mk/bsd.pkg.mk"

View file

@ -1,7 +1,7 @@
$NetBSD: distinfo,v 1.1.1.1 2009/06/05 02:57:57 minskim Exp $
$NetBSD: distinfo,v 1.2 2009/06/07 20:12:06 hasso Exp $
SHA1 (emacs-snapshot_20090604.orig.tar.gz) = 21ac8cfd45c791f507914b52b9605bc25b49035b
RMD160 (emacs-snapshot_20090604.orig.tar.gz) = d163cae20284a1c1df7628ce365430ea68797f92
Size (emacs-snapshot_20090604.orig.tar.gz) = 28804599 bytes
SHA1 (patch-ab) = f56a53c0e0ebf23505500b851a1766ea8b9c18f6
SHA1 (patch-ab) = 53fd489995efae908827d7a3de4811daf156fd0a
SHA1 (patch-ac) = 727439e174f1febd7fba2174a70a4e781414028d

View file

@ -0,0 +1,128 @@
/* System description header for DragonFly systems.
This file describes the parameters that system description files
should define or not.
Copyright (C) 1994, 1995, 1996, 1997, 1998, 1999, 2000, 2001
Free Software Foundation, Inc.
This file is part of GNU Emacs.
GNU Emacs is free software; you can redistribute it and/or modify
it under the terms of the GNU General Public License as published by
the Free Software Foundation; either version 2, or (at your option)
any later version.
GNU Emacs is distributed in the hope that it will be useful,
but WITHOUT ANY WARRANTY; without even the implied warranty of
MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
GNU General Public License for more details.
You should have received a copy of the GNU General Public License
along with GNU Emacs; see the file COPYING. If not, write to
the Free Software Foundation, Inc., 59 Temple Place - Suite 330,
Boston, MA 02111-1307, USA. */
/* Get most of the stuff from bsd-common */
#include "bsd-common.h"
/* For mem-limits.h. */
#define BSD4_2
/* These aren't needed, since we have getloadavg. */
#undef KERNEL_FILE
#undef LDAV_SYMBOL
#define PENDING_OUTPUT_COUNT(FILE) __fpending(FILE)
#define LIBS_DEBUG
#define LIBS_SYSTEM -lutil
#define TERMINFO
#define LIBS_TERMCAP -lncurses
#define SYSV_SYSTEM_DIR
/* freebsd has POSIX-style pgrp behavior. */
#undef BSD_PGRPS
#define GETPGRP_NO_ARG
#ifdef DFLY_CRT_USRLIB
#define START_FILES pre-crt0.o /usr/lib/crt1.o /usr/lib/crti.o /usr/lib/gcc41/crtbegin.o
#define LIB_STANDARD -L/usr/lib/gcc41 -lgcc -lc -lgcc /usr/lib/gcc41/crtend.o /usr/lib/crtn.o
#else
#define START_FILES pre-crt0.o /usr/lib/gcc41/crt1.o /usr/lib/gcc41/crti.o /usr/lib/gcc41/crtbegin.o
#define LIB_STANDARD -L/usr/lib/gcc41 -lgcc -lc -lgcc /usr/lib/gcc41/crtend.o /usr/lib/gcc41/crtn.o
#endif
#define LD_SWITCH_SYSTEM_1
#define UNEXEC unexelf.o
#undef LIB_GCC
#define LIB_GCC
#define HAVE_WAIT_HEADER
#define HAVE_GETLOADAVG 1
#define HAVE_TERMIOS
#define NO_TERMIO
#define DECLARE_GETPWUID_WITH_UID_T
/* freebsd uses OXTABS instead of the expected TAB3. */
#define TABDLY OXTABS
#define TAB3 OXTABS
/* this silences a few compilation warnings */
#undef BSD_SYSTEM
#define BSD_SYSTEM 199506
/* Needed to avoid hanging when child process writes an error message
and exits -- enami tsugutomo <enami@ba2.so-net.or.jp>. */
#define vfork fork
/* Don't close pty in process.c to make it as controlling terminal.
It is already a controlling terminal of subprocess, because we did
ioctl TIOCSCTTY. */
#define DONT_REOPEN_PTY
/* If the system's imake configuration file defines `NeedWidePrototypes'
as `NO', we must define NARROWPROTO manually. Such a define is
generated in the Makefile generated by `xmkmf'. If we don't
define NARROWPROTO, we will see the wrong function prototypes
for X functions taking float or double parameters. */
#define NARROWPROTO 1
#define C_SWITCH_SYSTEM
#define LD_SWITCH_SYSTEM
/* Circumvent a bug in FreeBSD. In the following sequence of
writes/reads on a PTY, read(2) returns bogus data:
write(2) 1022 bytes
write(2) 954 bytes, get EAGAIN
read(2) 1024 bytes in process_read_output
read(2) 11 bytes in process_read_output
That is, read(2) returns more bytes than have ever been written
successfully. The 1033 bytes read are the 1022 bytes written
successfully after processing (for example with CRs added if the
terminal is set up that way which it is here). The same bytes will
be seen again in a later read(2), without the CRs. */
#define BROKEN_PTY_READ_AFTER_EAGAIN 1
/* Tell that garbage collector that setjmp is known to save all
registers relevant for conservative garbage collection in the
jmp_buf. */
#define GC_SETJMP_WORKS 1
/* Use the GC_MAKE_GCPROS_NOOPS (see lisp.h) method for marking the
stack. */
#define GC_MARK_STACK GC_MAKE_GCPROS_NOOPS
/* Define USE_MMAP_FOR_BUFFERS to let Emacs use mmap(2) to allocate
buffer text. This overrides REL_ALLOC. */
#define USE_MMAP_FOR_BUFFERS 1
/* Use sigprocmask(2) and friends instead of sigblock(2); the man page
of sigblock says it is obsolete. */
#define POSIX_SIGNALS 1

View file

@ -1,8 +1,8 @@
$NetBSD: patch-ab,v 1.1.1.1 2009/06/05 02:57:57 minskim Exp $
$NetBSD: patch-ab,v 1.2 2009/06/07 20:12:06 hasso Exp $
--- configure.orig 2009-04-28 02:45:09.000000000 +0000
+++ configure
@@ -1856,7 +1856,7 @@ archlibdir='${libexecdir}/emacs/${versio
--- configure.orig 2009-06-04 20:29:50 +0300
+++ configure 2009-06-07 21:41:16 +0300
@@ -1979,7 +1979,7 @@ archlibdir='${libexecdir}/emacs/${versio
docdir='${datadir}/emacs/${version}/etc'
gamedir='${localstatedir}/games/emacs'
@ -11,7 +11,23 @@ $NetBSD: patch-ab,v 1.1.1.1 2009/06/05 02:57:57 minskim Exp $
@@ -9405,9 +9405,9 @@ if test "${HAVE_NS}" = yes; then
@@ -2529,6 +2529,15 @@ case "${canonical}" in
esac
;;
+ ## DragonFly ports
+ *-*-dragonfly*)
+ opsys=dragonfly
+ case "${canonical}" in
+ i[3456]86-*-dragonfly*) machine=intel386 ;;
+ amd64-*-dragonfly*|x86_64-*-dragonfly*) machine=amdx86-64 ;;
+ esac
+ ;;
+
## FreeBSD kernel + glibc based userland
*-*-kfreebsd*gnu* )
opsys=gnu-kfreebsd
@@ -9605,9 +9614,9 @@ if test "${HAVE_NS}" = yes; then
window_system=nextstep
with_xft=no
# set up packaging dirs