Convert to use buildlink.mk files for ncurses dependency. Remove

check for __NetBSD__ and refer to ncurses header as <ncurses.h>.
This commit is contained in:
jlam 2001-06-20 04:44:59 +00:00
parent e26d6029b6
commit 9ef400c6e2
3 changed files with 12 additions and 18 deletions

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.6 2001/06/11 06:34:47 jlam Exp $
# $NetBSD: Makefile,v 1.7 2001/06/20 04:44:59 jlam Exp $
#
DISTNAME= tn5250-0.12.51
@ -10,13 +10,7 @@ HOMEPAGE= http://www.linux-sna.org/software/5250/
COMMENT= Implementation of the IBM 5250 telnet protocol
GNU_CONFIGURE= YES
USE_CURSES= YES
REPLACE_NCURSES= ${WRKSRC}/cursesterm.cc ${WRKSRC}/configure
.include "../../mk/bsd.prefs.mk"
.if ${NEED_NCURSES} == "YES"
CPPFLAGS+= -I${LOCALBASE}/include
.endif
USE_BUILDLINK_ONLY= YES
.include "../../devel/ncurses/buildlink.mk"
.include "../../mk/bsd.pkg.mk"

View file

@ -1,6 +1,6 @@
$NetBSD: distinfo,v 1.2 2001/04/21 11:23:36 wiz Exp $
$NetBSD: distinfo,v 1.3 2001/06/20 04:44:59 jlam Exp $
SHA1 (tn5250-0.12.51.tar.gz) = c4394dd699afa3e38989015100f5837f266a80d9
Size (tn5250-0.12.51.tar.gz) = 101747 bytes
SHA1 (patch-aa) = b4826fc9983066f5616881c5fed00e5b9698770a
SHA1 (patch-aa) = eded51dff90cdab29069b281c991e5d53f393c88
SHA1 (patch-ab) = 32a611ae4ac1ad19a4063bebf17959bcfa5f5776

View file

@ -1,17 +1,17 @@
$NetBSD: patch-aa,v 1.3 2001/02/08 13:46:04 wiz Exp $
$NetBSD: patch-aa,v 1.4 2001/06/20 04:45:00 jlam Exp $
--- cursesterm.cc.orig Mon Apr 5 18:25:45 1999
--- cursesterm.cc.orig Mon Apr 5 12:25:45 1999
+++ cursesterm.cc
@@ -19,13 +19,23 @@
@@ -19,13 +19,22 @@
#include "config.h"
#include <assert.h>
#include <sys/time.h>
+#ifdef __NetBSD__
+#include <ncurses.h>
-#include <curses.h>
+#include <sys/param.h>
+#if (defined(BSD) && BSD >= 199306)
+#include <unistd.h>
+#else
#include <curses.h>
+#endif
+#include <ncurses.h>
#include <string.h>
#include <ctype.h>
#include "utility.h"