cloog: remove

previously used by gcc, nothing uses it in pkgsrc, upstream stopped
development, doesn't build in bulk builds
This commit is contained in:
wiz 2022-04-03 07:54:53 +00:00
parent 1b3acaab20
commit 9f23ef2107
8 changed files with 3 additions and 94 deletions

View file

@ -1,4 +1,4 @@
$NetBSD: CHANGES-2022,v 1.1665 2022/04/03 07:50:04 ast Exp $
$NetBSD: CHANGES-2022,v 1.1666 2022/04/03 07:54:53 wiz Exp $
Changes to the packages collection and infrastructure in 2022:
@ -2176,3 +2176,4 @@ Changes to the packages collection and infrastructure in 2022:
Updated databases/ruby-sequel to 5.55.0 [taca 2022-04-03]
Updated security/p5-Net-DNS-SEC to 1.19 [ast 2022-04-03]
Updated net/p5-Net-DNS to 1.33 [ast 2022-04-03]
Removed math/cloog [wiz 2022-04-03]

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.537 2022/02/24 00:58:00 pho Exp $
# $NetBSD: Makefile,v 1.538 2022/04/03 07:54:53 wiz Exp $
COMMENT= Mathematics
@ -152,7 +152,6 @@ SUBDIR+= cgal
SUBDIR+= classias
SUBDIR+= clisp-pari
SUBDIR+= cln
SUBDIR+= cloog
SUBDIR+= coinmp
SUBDIR+= congen
SUBDIR+= crfsuite

View file

@ -1,2 +0,0 @@
CLooG is a code generator for scanning Z-polyhedra and is used by
gcc >= 4.4 for loop optimization.

View file

@ -1,23 +0,0 @@
# $NetBSD: Makefile,v 1.10 2020/03/21 11:50:10 rillig Exp $
DISTNAME= cloog-0.18.4
CATEGORIES= math
MASTER_SITES= http://www.bastoul.net/cloog/pages/download/
MAINTAINER= kuehro@gmx.de
HOMEPAGE= https://www.cloog.org/
COMMENT= Code generator for loop optimization (used by gcc)
LICENSE= gnu-lgpl-v2.1
GNU_CONFIGURE= yes
USE_LANGUAGES= c
USE_LIBTOOL= yes
TEST_TARGET= check
CONFIGURE_ARGS+= --with-isl=system
BUILDLINK_API_DEPENDS.gmp+= gmp>=6.0
.include "../../devel/gmp/buildlink3.mk"
.include "../../math/isl/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

View file

@ -1,30 +0,0 @@
@comment $NetBSD: PLIST,v 1.6 2016/10/09 19:46:52 wiz Exp $
bin/cloog
include/cloog/block.h
include/cloog/clast.h
include/cloog/cloog.h
include/cloog/constraints.h
include/cloog/domain.h
include/cloog/input.h
include/cloog/int.h
include/cloog/isl/backend.h
include/cloog/isl/cloog.h
include/cloog/isl/constraintset.h
include/cloog/isl/domain.h
include/cloog/loop.h
include/cloog/matrix.h
include/cloog/matrix/constraintset.h
include/cloog/names.h
include/cloog/options.h
include/cloog/pprint.h
include/cloog/program.h
include/cloog/state.h
include/cloog/statement.h
include/cloog/stride.h
include/cloog/union_domain.h
include/cloog/util.h
include/cloog/version.h
lib/cloog-isl/cloog-isl-config.cmake
lib/isl/isl-config.cmake
lib/libcloog-isl.la
lib/pkgconfig/cloog-isl.pc

View file

@ -1,15 +0,0 @@
# $NetBSD: buildlink3.mk,v 1.3 2013/02/17 22:20:44 wiz Exp $
BUILDLINK_TREE+= cloog
.if !defined(CLOOG_BUILDLINK3_MK)
CLOOG_BUILDLINK3_MK:=
BUILDLINK_API_DEPENDS.cloog+= cloog>=0.18.0nb1
BUILDLINK_PKGSRCDIR.cloog?= ../../math/cloog
.include "../../devel/gmp/buildlink3.mk"
.include "../../math/isl/buildlink3.mk"
.endif # CLOOG_BUILDLINK3_MK
BUILDLINK_TREE+= -cloog

View file

@ -1,6 +0,0 @@
$NetBSD: distinfo,v 1.9 2021/10/26 10:55:37 nia Exp $
BLAKE2s (cloog-0.18.4.tar.gz) = e0ec8e9a874cb72aa2da4c3343f756bab25748229648818982ceffad4b6925bc
SHA512 (cloog-0.18.4.tar.gz) = d35d67b08ffe13c1a010b65bfe4dd02b0ae013d5b489e330dc950bd3514defca8f734bd37781856dcedf0491ff6122c34eecb4b0fe32a22d7e6bdadea98c8c23
Size (cloog-0.18.4.tar.gz) = 4796456 bytes
SHA1 (patch-test_checker.sh) = a62a4fba0f433e6c6685f2d7a92f0cb039a1d1f0

View file

@ -1,15 +0,0 @@
$NetBSD: patch-test_checker.sh,v 1.1 2013/02/20 21:37:13 wiz Exp $
Remove Linuxism in cut(1) call.
--- test/checker.sh.orig 2012-12-20 17:22:01.000000000 +0000
+++ test/checker.sh
@@ -67,7 +67,7 @@ echo " * Testing CLoo
echo " *-----------------------------------------------*/"
for x in $TEST_FILES; do
name=`echo $x | sed 's/%/ /g' | cut -d\ -f1`;
- individual_options=`echo $x | sed 's/%/ /g' | cut -s -d\ -f2-`;
+ individual_options=`echo $x | sed 's/%/ /g' | cut -s -d\ -f2`;
input="$srcdir/$name.$TEST_INPUT_EXTENSION";
output="$srcdir/$name.$TEST_OUTPUT_EXTENSION";
options="$individual_options $TEST_GLOBAL_OPTIONS";