py-uwsgi: update to 2.0.20.
Changes Switch default python for build to python3 (Riccardo Magliocchetti) Add support for PHP 8 (Riccardo Magliocchetti) Drop support for PHP < 7 as it is EOL since end of 2018 (Riccardo Magliocchetti) Fix segfaults when using –wsgi-env-behavior=holy (Antonio Cuni) Replace uwsgi.h system includes in core and proto dirs for Bazel (Serge Bazanski) gevent: fix compilation with clang11 (László Károlyi) Fix Python 3.9 deprecations warnings (Riccardo Magliocchetti) Add trove classifier for Python 3.9 (Adrian) Fix message in Log SIGINT/SIGTERM triggered kill_them_all (Delena Malan) Support 7 in weekedays as an alias for sunday to match crontab behaviour (Riccardo Magliocchetti) Document http-timeout default of 60 seconds (Etienne H) Add option to override python sys.executable using py-executable config Allow specifying an iteration to uwsgi::add_rb_timer (Luciano Rocha) Allow to compile with Python versions with minor version with 2+ digits (Cyrille Pontvieux) Take into account new naming for LIBPL since python 3.6 (ilrico) Added missing HTTP status codes messages (James Brown) Official support for Python 3.10
This commit is contained in:
parent
ae978750ca
commit
9fe5982d1a
5 changed files with 17 additions and 35 deletions
|
@ -1,2 +1 @@
|
|||
bin/uwsgi @PREFIX@/bin/uwsgi-@PYVERSSUFFIX@
|
||||
share/examples/py-uwsgi share/examples/@PYPKGPREFIX@-uwsgi/
|
||||
|
|
|
@ -1,18 +1,15 @@
|
|||
# $NetBSD: Makefile,v 1.51 2022/01/04 20:55:37 wiz Exp $
|
||||
# $NetBSD: Makefile,v 1.52 2022/01/25 10:30:50 wiz Exp $
|
||||
|
||||
DISTNAME= uWSGI-2.0.19.1
|
||||
PKGNAME= ${PYPKGPREFIX}-${DISTNAME:tl}
|
||||
PKGREVISION= 2
|
||||
DISTNAME= uwsgi-2.0.20
|
||||
PKGNAME= ${PYPKGPREFIX}-${DISTNAME}
|
||||
CATEGORIES= www python
|
||||
MASTER_SITES= ${MASTER_SITE_PYPI:=u/uWSGI/}
|
||||
MASTER_SITES= ${MASTER_SITE_PYPI:=u/uwsgi/}
|
||||
|
||||
MAINTAINER= pkgsrc-users@NetBSD.org
|
||||
HOMEPAGE= https://uwsgi-docs.readthedocs.io/
|
||||
COMMENT= Feature-rich WSGI server
|
||||
LICENSE= gnu-gpl-v2 # with linking exception
|
||||
|
||||
EXTRACT_DIR= ${WRKSRC}
|
||||
|
||||
USE_TOOLS+= pkg-config
|
||||
|
||||
PLIST_SUBST+= PYPKGPREFIX=${PYPKGPREFIX}
|
||||
|
|
|
@ -1,9 +1,9 @@
|
|||
$NetBSD: distinfo,v 1.39 2021/10/26 11:30:50 nia Exp $
|
||||
$NetBSD: distinfo,v 1.40 2022/01/25 10:30:50 wiz Exp $
|
||||
|
||||
BLAKE2s (uWSGI-2.0.19.1.tar.gz) = 806c03c1da3f85b02b91f957976d8ae8d2e368e01206ab9db7260a807dda5736
|
||||
SHA512 (uWSGI-2.0.19.1.tar.gz) = 5e249f65ed1d39515d1264e76d4de9fe42fc28ea3157a2ea724f36e2ae058380545d834b39dde40554f4ad0f19bb57ef7842d5d1b991884df986c665f4c59149
|
||||
Size (uWSGI-2.0.19.1.tar.gz) = 803862 bytes
|
||||
BLAKE2s (uwsgi-2.0.20.tar.gz) = 55c23900a2b728f9f4159326646b8278d07e4be84a070391cbef0734e3ce2f1f
|
||||
SHA512 (uwsgi-2.0.20.tar.gz) = 22677a8ad1ea886e1a3a153f486474ce064a55e5b12515322345116980f699f4e2e73267f991c300d904284e06f265ea821e71ba3c97832b6f25705475b498ff
|
||||
Size (uwsgi-2.0.20.tar.gz) = 804906 bytes
|
||||
SHA1 (patch-base.ini) = 1c5d7693e6c8011e6cc34f5f5d203584c985eb30
|
||||
SHA1 (patch-core_logging.c) = caa986238142d24725df119cbecda1b9e3223d7e
|
||||
SHA1 (patch-uwsgi.h) = d563a2193643ff25952b57e01bf190b9b43e7f1e
|
||||
SHA1 (patch-core_logging.c) = 8372985f3bb007babbfe84529580139241e741a9
|
||||
SHA1 (patch-uwsgi.h) = a560e37aa35707d524db6205079be61c94b7b31a
|
||||
SHA1 (patch-uwsgiconfig.py) = aab47457f2fafb0206a53913ef3777700175d020
|
||||
|
|
|
@ -1,15 +1,13 @@
|
|||
$NetBSD: patch-core_logging.c,v 1.3 2017/06/23 15:56:45 joerg Exp $
|
||||
$NetBSD: patch-core_logging.c,v 1.4 2022/01/25 10:30:51 wiz Exp $
|
||||
|
||||
Fix build for Bitrig.
|
||||
Fix build for NetBSD.
|
||||
|
||||
--- core/logging.c.orig 2017-03-30 22:11:36.000000000 +0000
|
||||
--- core/logging.c.orig 2021-10-06 05:22:45.000000000 +0000
|
||||
+++ core/logging.c
|
||||
@@ -1,8 +1,10 @@
|
||||
#ifndef __DragonFly__
|
||||
#include <uwsgi.h>
|
||||
@@ -2,7 +2,9 @@
|
||||
#include "uwsgi.h"
|
||||
#endif
|
||||
-#if defined(__FreeBSD__) || defined(__NetBSD__) || defined(__DragonFly__) || defined(__OpenBSD__)
|
||||
+#if defined(__FreeBSD__) || defined(__NetBSD__) || defined(__DragonFly__) || defined(__OpenBSD__) || defined(__Bitrig__)
|
||||
#if defined(__FreeBSD__) || defined(__NetBSD__) || defined(__DragonFly__) || defined(__OpenBSD__)
|
||||
+# if !defined(__NetBSD__)
|
||||
#include <sys/user.h>
|
||||
+# endif
|
||||
|
|
|
@ -1,21 +1,9 @@
|
|||
$NetBSD: patch-uwsgi.h,v 1.8 2021/08/05 13:22:30 adam Exp $
|
||||
$NetBSD: patch-uwsgi.h,v 1.9 2022/01/25 10:30:51 wiz Exp $
|
||||
|
||||
Avoid clash with sys/user.h inclusion in logging.c on DragonFly BSD.
|
||||
Avoid using "sun" which breaks on SunOS
|
||||
|
||||
--- uwsgi.h.orig 2020-06-17 09:03:34.000000000 +0000
|
||||
+++ uwsgi.h
|
||||
@@ -322,6 +322,10 @@ extern int pivot_root(const char *new_ro
|
||||
#elif defined(__CYGWIN__)
|
||||
#elif defined(__HURD__)
|
||||
#else
|
||||
+#if defined(__DragonFly__)
|
||||
+/* avoid clash with sys/user.h inclusion in logging.c */
|
||||
+#define _KERNEL_STRUCTURES
|
||||
+#endif /* __DragonFly__ */
|
||||
#include <sys/event.h>
|
||||
#endif
|
||||
|
||||
@@ -1631,7 +1635,7 @@ struct wsgi_request {
|
||||
union address {
|
||||
struct sockaddr_in sin;
|
||||
|
|
Loading…
Reference in a new issue