mail/roundcube: restore patches
Restore patches accidently removed by me. Noted by tnn@ and thanks much. Bump PKGREVISION.
This commit is contained in:
parent
7fd240a3cf
commit
a0151aebe6
5 changed files with 66 additions and 5 deletions
|
@ -1,7 +1,8 @@
|
|||
# $NetBSD: Makefile,v 1.95 2021/11/20 15:13:32 taca Exp $
|
||||
# $NetBSD: Makefile,v 1.96 2022/08/19 13:09:38 taca Exp $
|
||||
|
||||
DISTNAME= roundcubemail-${RC_VERS}
|
||||
PKGNAME= ${PHP_PKG_PREFIX}-${DISTNAME:S/mail-/-/:S/-complete//}
|
||||
PKGREVISION= 1
|
||||
|
||||
MAINTAINER= taca@NetBSD.org
|
||||
COMMENT= Browser-based multilingual IMAP client
|
||||
|
|
|
@ -1,5 +1,8 @@
|
|||
$NetBSD: distinfo,v 1.81 2022/08/17 15:41:43 taca Exp $
|
||||
$NetBSD: distinfo,v 1.82 2022/08/19 13:09:38 taca Exp $
|
||||
|
||||
BLAKE2s (classic-1.6.0.tar.gz) = 5b0ecdf30b398b2bb0f8e12b6c661d7cb7832c6b513efc51f841ffaeaa12a51d
|
||||
SHA512 (classic-1.6.0.tar.gz) = cbf6271800bcafb8d7205d4761e1a3a91b200c8ee5e2afb8e7c3a728de5fb020a7f73ee8991f4705bd496e5d19acdf61d69f8cc610fec41d3dbc4689813b12c1
|
||||
Size (classic-1.6.0.tar.gz) = 3858784 bytes
|
||||
BLAKE2s (roundcubemail-1.6.0-complete.tar.gz) = 938e0473405e052a6d6d0ada492ebcce842125c0ef1055d7b59bf50bf5382387
|
||||
SHA512 (roundcubemail-1.6.0-complete.tar.gz) = 821733778085c670caeed6bed515e542841920dccc21e2ca97088e1f77a302b6961234d6ee5bcfbda797470889747a3be2c6d13cc5016615c8919c7ea064108c
|
||||
Size (roundcubemail-1.6.0-complete.tar.gz) = 5970153 bytes
|
||||
SHA1 (patch-config_config.inc.php.sample) = 92a48a97b16fe3f5f4b9441fce762a559d8daca7
|
||||
SHA1 (patch-program_include_iniset.php) = 8a6c13c0c87d583ed60e43c01a4173d9d802a6a1
|
||||
SHA1 (patch-program_lib_Roundcube_rcube__mime.php) = b1e9479d575b7fd61c413e2b76ee36c06ece7a5c
|
||||
|
|
17
mail/roundcube/patches/patch-config_config.inc.php.sample
Normal file
17
mail/roundcube/patches/patch-config_config.inc.php.sample
Normal file
|
@ -0,0 +1,17 @@
|
|||
$NetBSD: patch-config_config.inc.php.sample,v 1.4 2022/08/19 13:09:38 taca Exp $
|
||||
|
||||
Add default paths for log, tmp and MIME types.
|
||||
|
||||
--- config/config.inc.php.sample.orig 2020-01-01 19:58:53.000000000 +0000
|
||||
+++ config/config.inc.php.sample
|
||||
@@ -84,3 +84,10 @@ $config['plugins'] = array(
|
||||
|
||||
// skin name: folder from skins/
|
||||
$config['skin'] = 'elastic';
|
||||
+
|
||||
+// use this folder to store log files (must be writeable for apache user)
|
||||
+// This is used by the 'file' log driver.
|
||||
+$config['log_dir'] = '@VARBASE@/log/roundcube/';
|
||||
+
|
||||
+// use this folder to store temp files (must be writeable for apache user)
|
||||
+$config['temp_dir'] = '@VARBASE@/tmp/roundcube/';
|
15
mail/roundcube/patches/patch-program_include_iniset.php
Normal file
15
mail/roundcube/patches/patch-program_include_iniset.php
Normal file
|
@ -0,0 +1,15 @@
|
|||
$NetBSD: patch-program_include_iniset.php,v 1.1 2022/08/19 13:09:38 taca Exp $
|
||||
|
||||
Honor PKG_SYSCONFDIR.
|
||||
|
||||
--- program/include/iniset.php.orig 2022-07-23 20:17:14.000000000 +0000
|
||||
+++ program/include/iniset.php
|
||||
@@ -32,7 +32,7 @@ if (!defined('INSTALL_PATH')) {
|
||||
}
|
||||
|
||||
if (!defined('RCMAIL_CONFIG_DIR')) {
|
||||
- define('RCMAIL_CONFIG_DIR', getenv('ROUNDCUBE_CONFIG_DIR') ?: (INSTALL_PATH . 'config'));
|
||||
+ define('RCMAIL_CONFIG_DIR', getenv('ROUNDCUBE_CONFIG_DIR') ?: '@PKG_SYSCONFDIR@');
|
||||
}
|
||||
|
||||
if (!defined('RCUBE_LOCALIZATION_DIR')) {
|
|
@ -0,0 +1,25 @@
|
|||
$NetBSD: patch-program_lib_Roundcube_rcube__mime.php,v 1.5 2022/08/19 13:09:38 taca Exp $
|
||||
|
||||
Fix path to /etc/.
|
||||
|
||||
--- program/lib/Roundcube/rcube_mime.php.orig 2018-04-11 11:06:18.000000000 +0000
|
||||
+++ program/lib/Roundcube/rcube_mime.php
|
||||
@@ -790,12 +790,12 @@ class rcube_mime
|
||||
$file_paths[] = 'C:/xampp/apache/conf/mime.types.';
|
||||
}
|
||||
else {
|
||||
- $file_paths[] = '/etc/mime.types';
|
||||
- $file_paths[] = '/etc/httpd/mime.types';
|
||||
- $file_paths[] = '/etc/httpd2/mime.types';
|
||||
- $file_paths[] = '/etc/apache/mime.types';
|
||||
- $file_paths[] = '/etc/apache2/mime.types';
|
||||
- $file_paths[] = '/etc/nginx/mime.types';
|
||||
+ $file_paths[] = '@PKG_SYSCONFBASE@/mime.types';
|
||||
+ $file_paths[] = '@PKG_SYSCONFBASE@/httpd/mime.types';
|
||||
+ $file_paths[] = '@PKG_SYSCONFBASE@/httpd2/mime.types';
|
||||
+ $file_paths[] = '@PKG_SYSCONFBASE@/apache/mime.types';
|
||||
+ $file_paths[] = '@PKG_SYSCONFBASE@/apache2/mime.types';
|
||||
+ $file_paths[] = '@PKG_SYSCONFBASE@/nginx/mime.types';
|
||||
$file_paths[] = '/usr/local/etc/httpd/conf/mime.types';
|
||||
$file_paths[] = '/usr/local/etc/apache/conf/mime.types';
|
||||
$file_paths[] = '/usr/local/etc/apache24/mime.types';
|
Loading…
Reference in a new issue