devel/ruby-ffi-compiler: update to 1.3.2

1.2.0 (2023-03-03)

* Correctly format compile arguments for shell
* Respect user's environment FLAGS

1.2.1 (2023-06-08)

* Stay backwards compatible

1.2.2 (2024-02-11)

* Implement some escaping for Windows shells
* Escape all arguments for shell commands

1.3.0 (2024-03-13)

* Reuse shellescape for Windows
* Reuse prebuilt binaries

1.3.1 (2024-03-13)

* Bump ffi version requirement to 1.15.5
* Add version file

1.3.2 (2024-03-14)

* Provide namespace-free task name even when using namespaces
This commit is contained in:
taca 2024-03-24 14:04:18 +00:00
parent 201827cb32
commit a019305556
4 changed files with 15 additions and 13 deletions

View File

@ -1,7 +1,6 @@
# $NetBSD: Makefile,v 1.3 2020/11/02 15:13:27 taca Exp $
# $NetBSD: Makefile,v 1.4 2024/03/24 14:04:18 taca Exp $
DISTNAME= ffi-compiler-1.0.1
PKGREVISION= 1
DISTNAME= ffi-compiler-1.3.2
CATEGORIES= devel
MAINTAINER= pkgsrc-users@NetBSD.org

View File

@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.1 2020/01/16 14:36:15 taca Exp $
@comment $NetBSD: PLIST,v 1.2 2024/03/24 14:04:18 taca Exp $
${GEM_HOME}/cache/${GEM_NAME}.gem
${GEM_LIBDIR}/Gemfile
${GEM_LIBDIR}/LICENSE
@ -11,6 +11,9 @@ ${GEM_LIBDIR}/lib/ffi-compiler/exporter.rb
${GEM_LIBDIR}/lib/ffi-compiler/fake_ffi/ffi-compiler/loader.rb
${GEM_LIBDIR}/lib/ffi-compiler/fake_ffi/ffi.rb
${GEM_LIBDIR}/lib/ffi-compiler/loader.rb
${GEM_LIBDIR}/lib/ffi-compiler/multi_file_task.rb
${GEM_LIBDIR}/lib/ffi-compiler/platform.rb
${GEM_LIBDIR}/lib/ffi-compiler/shell.rb
${GEM_LIBDIR}/lib/ffi-compiler/task.rb
${GEM_LIBDIR}/lib/ffi-compiler/version.rb
${GEM_HOME}/specifications/${GEM_NAME}.gemspec

View File

@ -1,6 +1,6 @@
$NetBSD: distinfo,v 1.4 2021/10/26 10:19:31 nia Exp $
$NetBSD: distinfo,v 1.5 2024/03/24 14:04:18 taca Exp $
BLAKE2s (ffi-compiler-1.0.1.gem) = 4ace17c6826651b76c0cb6a4d98871f9ccf9ca59297eab831d878449ba767e4a
SHA512 (ffi-compiler-1.0.1.gem) = 7a13625ab1c5748d05ec93d68708dd9435ec92dcd0c823109c44173fdaf8710aec5f5b4fb11966475f10ae91401c7ca3c620f9d36bb9ca665114e1ed70f4edd0
Size (ffi-compiler-1.0.1.gem) = 18432 bytes
SHA1 (patch-lib_ffi-compiler_compile__task.rb) = a29a3bbb2d3d4f622374ae90b957ad2839caf7ea
BLAKE2s (ffi-compiler-1.3.2.gem) = 48d697b23b3ecac5d8dccb968bf69386b9604803954158dcd1547ed3c9e22c6c
SHA512 (ffi-compiler-1.3.2.gem) = 2e7233c066228caa0684e02a9a9beaab4a5ab8fc16ad444d029bfaed45e3191b2b388e386e869002301a2956c93968c2c979178b2ca9ad295841036f96db4f93
Size (ffi-compiler-1.3.2.gem) = 14848 bytes
SHA1 (patch-lib_ffi-compiler_compile__task.rb) = 0af0245027ebcb5aa78c7cef1402d71434fd44b7

View File

@ -1,13 +1,13 @@
$NetBSD: patch-lib_ffi-compiler_compile__task.rb,v 1.1 2020/11/02 15:13:27 taca Exp $
$NetBSD: patch-lib_ffi-compiler_compile__task.rb,v 1.2 2024/03/24 14:04:18 taca Exp $
Do not use FFI::Compiler::Platform own definition and use
RbConfig::CONFIG['arch'] instead.
--- lib/ffi-compiler/compile_task.rb.orig 2020-11-02 14:39:47.900421091 +0000
--- lib/ffi-compiler/compile_task.rb.orig 2024-03-23 12:59:05.934181248 +0000
+++ lib/ffi-compiler/compile_task.rb
@@ -95,7 +95,7 @@ module FFI
@@ -122,7 +122,7 @@ module FFI
end
so_flags = so_flags.join(' ')
so_flags = shelljoin(so_flags)
- out_dir = "#{@platform.arch}-#{@platform.os}"
+ out_dir = RbConfig::CONFIG['arch']