Fix build against C++11 STL implementation.

This commit is contained in:
joerg 2014-08-19 13:32:46 +00:00
parent 6edff139a2
commit a07159a5b8
2 changed files with 24 additions and 1 deletions

View file

@ -1,10 +1,11 @@
$NetBSD: distinfo,v 1.4 2012/09/30 10:04:33 dholland Exp $
$NetBSD: distinfo,v 1.5 2014/08/19 13:32:46 joerg Exp $
SHA1 (flightgear-2.8.0.tar.bz2) = fee4b2f1f6aca8e163ea018ae9897b99971c20bd
RMD160 (flightgear-2.8.0.tar.bz2) = 97d8f572aeb186bfed27eb5b06803a0fa5213a61
Size (flightgear-2.8.0.tar.bz2) = 2311023 bytes
SHA1 (patch-CMakeModules_FindPLIB_cmake) = c5761d425743761f5f0c711ef2ca384a06f6d524
SHA1 (patch-src_Canvas_ShivaVG_src_shConfig_h) = bd70a1e41a59196e31789e38ec67e65cef546edf
SHA1 (patch-src_FDM_JSBSim_models_propulsion_FGEngine.cpp) = 9c066364096452868194f84d8c853131aec83f80
SHA1 (patch-src_Main_locale_cxx) = 327f4103ff3aea60f2394a2ed192c5f6af36f60b
SHA1 (patch-src_Network_ATC-Inputs_cxx) = 08644c682ddddcefea48aa84fa538b8fd20289c0
SHA1 (patch-src_Network_ATC-Outputs_cxx) = d5367f8536988b2705b2ba4f8d86e28576b04648

View file

@ -0,0 +1,22 @@
$NetBSD: patch-src_FDM_JSBSim_models_propulsion_FGEngine.cpp,v 1.1 2014/08/19 13:32:46 joerg Exp $
--- src/FDM/JSBSim/models/propulsion/FGEngine.cpp.orig 2014-08-19 13:11:25.000000000 +0000
+++ src/FDM/JSBSim/models/propulsion/FGEngine.cpp
@@ -83,7 +83,7 @@ FGEngine::FGEngine(FGFDMExec* exec, Elem
Name = engine_element->GetAttributeValue("name");
- Load(engine_element, PropertyManager, to_string(EngineNumber)); // Call ModelFunctions loader
+ Load(engine_element, PropertyManager, ::to_string(EngineNumber)); // Call ModelFunctions loader
// Find and set engine location
@@ -132,7 +132,7 @@ FGEngine::FGEngine(FGFDMExec* exec, Elem
property_name = base_property_name + "/fuel-used-lbs";
PropertyManager->Tie( property_name.c_str(), this, &FGEngine::GetFuelUsedLbs);
- PostLoad(engine_element, PropertyManager, to_string(EngineNumber));
+ PostLoad(engine_element, PropertyManager, ::to_string(EngineNumber));
Debug(0);
}