Update to 1.2.6nb1: include a patch from Christopher Richards, sent in

PR 20496, which fixes broken key caching (mkdir /path/with/slash/ problem
again).
This commit is contained in:
wiz 2003-03-21 23:25:00 +00:00
parent 4a5bde4e76
commit a083a3285d
3 changed files with 25 additions and 2 deletions

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.6 2003/03/14 11:40:55 wiz Exp $
# $NetBSD: Makefile,v 1.7 2003/03/21 23:25:00 wiz Exp $
#
# Unfortunately, some reading of the United States law (DMCA) means
# that we are not able to provide pointers to the source or homepage
@ -8,6 +8,7 @@
# or MASTER_SITES definitions in this Makefile.
DISTNAME= libdvdcss-1.2.6
PKGREVISION= 1
CATEGORIES= misc
MASTER_SITES= ${LIBDVDCSS_MASTER_SITES}
EXTRACT_SUFX= .tar.bz2

View file

@ -1,4 +1,5 @@
$NetBSD: distinfo,v 1.4 2003/03/14 11:40:55 wiz Exp $
$NetBSD: distinfo,v 1.5 2003/03/21 23:25:01 wiz Exp $
SHA1 (libdvdcss-1.2.6.tar.bz2) = 82f50b22b544bdbb41bd5365087b91f9a612b3fe
Size (libdvdcss-1.2.6.tar.bz2) = 209352 bytes
SHA1 (patch-aa) = 4d50a8cd7b0aeb61b2da7944657f05cebb5dccfc

View file

@ -0,0 +1,21 @@
$NetBSD: patch-aa,v 1.1 2003/03/21 23:25:02 wiz Exp $
--- src/libdvdcss.c.orig Sat Feb 1 16:24:49 2003
+++ src/libdvdcss.c
@@ -398,7 +398,7 @@ extern dvdcss_t dvdcss_open ( char *psz_
goto nocache;
}
- i += sprintf( dvdcss->psz_cachefile + i, "/%s/", psz_data );
+ i += sprintf( dvdcss->psz_cachefile + i, "/%s", psz_data );
#if !defined( WIN32 ) || defined( SYS_CYGWIN )
i_ret = mkdir( dvdcss->psz_cachefile, 0755 );
#else
@@ -410,6 +410,7 @@ extern dvdcss_t dvdcss_open ( char *psz_
dvdcss->psz_cachefile[0] = '\0';
goto nocache;
}
+ i += sprintf( dvdcss->psz_cachefile + i, "/");
/* Pointer to the filename we will use. */
dvdcss->psz_block = dvdcss->psz_cachefile + i;