qimageblitz: SunOS/clang fixes.
This commit is contained in:
parent
a0e8de0055
commit
a0a95bd094
3 changed files with 36 additions and 1 deletions
|
@ -1,6 +1,8 @@
|
|||
$NetBSD: distinfo,v 1.3 2015/11/03 21:34:18 agc Exp $
|
||||
$NetBSD: distinfo,v 1.4 2018/01/29 17:35:30 jperkin Exp $
|
||||
|
||||
SHA1 (qimageblitz-0.0.6.tar.bz2) = 32bcda9adb262ef49c62e3a7adbfcdeec98f72e4
|
||||
RMD160 (qimageblitz-0.0.6.tar.bz2) = 5720d4e18dd7fdcd532e6dc9a2d2fe06116e7fef
|
||||
SHA512 (qimageblitz-0.0.6.tar.bz2) = dbd506c01622824efdec69640eb95e737d7848fa15d33351084a6499ca2321d7bc08e080d1e443f8ab9015cd2967c10d9b5aa2f3c6eaa7558153821c46133af9
|
||||
Size (qimageblitz-0.0.6.tar.bz2) = 57617 bytes
|
||||
SHA1 (patch-blitz_CMakeLists.txt) = 031a5a4cb70fd8a5d600444ce95ebc653a66d050
|
||||
SHA1 (patch-blitz_convolve.cpp) = 300f7da93b1704a6bc7f481161c59ba110a2ebf5
|
||||
|
|
18
graphics/qimageblitz/patches/patch-blitz_CMakeLists.txt
Normal file
18
graphics/qimageblitz/patches/patch-blitz_CMakeLists.txt
Normal file
|
@ -0,0 +1,18 @@
|
|||
$NetBSD: patch-blitz_CMakeLists.txt,v 1.1 2018/01/29 17:35:31 jperkin Exp $
|
||||
|
||||
Fix SunPro detection.
|
||||
|
||||
--- blitz/CMakeLists.txt.orig 2010-07-28 18:06:14.000000000 +0000
|
||||
+++ blitz/CMakeLists.txt
|
||||
@@ -49,9 +49,9 @@ endif(COMMAND cmake_policy)
|
||||
add_library(qimageblitz SHARED ${blitz_LIB_SRCS} ${blitz_LIB_EXTRA_SRCS})
|
||||
|
||||
target_link_libraries(qimageblitz ${QT_QTCORE_LIBRARY} ${QT_QTGUI_LIBRARY})
|
||||
-if (NOT CMAKE_COMPILER_IS_GNUCXX AND CMAKE_SYSTEM_NAME MATCHES SunOS)
|
||||
+if (CMAKE_COMPILER_IS_SUNPRO AND CMAKE_SYSTEM_NAME MATCHES SunOS)
|
||||
target_link_libraries(qimageblitz -lm -lsunmath)
|
||||
-endif (NOT CMAKE_COMPILER_IS_GNUCXX AND CMAKE_SYSTEM_NAME MATCHES SunOS)
|
||||
+endif (CMAKE_COMPILER_IS_SUNPRO AND CMAKE_SYSTEM_NAME MATCHES SunOS)
|
||||
|
||||
set_target_properties(qimageblitz PROPERTIES
|
||||
VERSION ${BLITZ_LIB_MAJOR_VERSION}.${BLITZ_LIB_MINOR_VERSION}.${BLITZ_LIB_PATCH_VERSION}
|
15
graphics/qimageblitz/patches/patch-blitz_convolve.cpp
Normal file
15
graphics/qimageblitz/patches/patch-blitz_convolve.cpp
Normal file
|
@ -0,0 +1,15 @@
|
|||
$NetBSD: patch-blitz_convolve.cpp,v 1.1 2018/01/29 17:35:31 jperkin Exp $
|
||||
|
||||
Fix float* return type.
|
||||
|
||||
--- blitz/convolve.cpp.orig 2010-07-28 18:06:14.000000000 +0000
|
||||
+++ blitz/convolve.cpp
|
||||
@@ -940,7 +940,7 @@ float* BlitzPrivate::getBlurKernel(int &
|
||||
long i;
|
||||
|
||||
if(sigma == 0.0)
|
||||
- return(false);
|
||||
+ return(NULL);
|
||||
if(kernel_width == 0)
|
||||
kernel_width = 3;
|
||||
|
Loading…
Reference in a new issue