update to 2.10.7

changes:
* GtkNotebook
 - Tab reordering is a less intrusive
 - Rendering fixes on win32

* GtkTreeView
  - Column resizing works correctly in right-to-left languages
  - Many scrolling bugs have been fixed

* GtkTextView:
  - Improved scrolling during DND.

* GtkRecentManager is more robust against bad URIs

* Print support:
 - The cups backend works with 'BrowseShortNames Off'
   in the cups configuration
 - Multi-valued options are properly passed to cups
 - Fix build with cups 1.3
 - A few IPP compliance issues have been fixed
 - Make the lpr backend work on BSD

* Input methods:
 - GtkEntryCompletion works with input methods
 - The Thai input method has been replace by a functional
   Thai and Lao input method based on libthai

* Accessibility support:
 - GtkMessageDialog sets accessible name role explicitly

* Theme support:
 - The semantics of the gtk-color-scheme setting has been
   slightly changed. Values from rc files are still merged
   together, but the X setting just overrides the prior table.

* GdkPixbuf:
 - gdk_pixbuf_loader_write() now closes the loader when
   returning FALSE, as documented
 - The BMP loader supports more BMP variants, including
   transparency and 10-bit channels.

-bugfixes
-translation updates
This commit is contained in:
drochner 2007-01-08 16:41:31 +00:00
parent 3ebd7e81ef
commit a125e2fdd7
4 changed files with 12 additions and 25 deletions

View file

@ -1,6 +1,6 @@
# $NetBSD: Makefile,v 1.133 2006/12/05 21:26:58 minskim Exp $
# $NetBSD: Makefile,v 1.134 2007/01/08 16:41:31 drochner Exp $
DISTNAME= gtk+-2.10.6
DISTNAME= gtk+-2.10.7
PKGNAME= ${DISTNAME:S/gtk/gtk2/}
CATEGORIES= x11
MASTER_SITES= ftp://ftp.gtk.org/pub/gtk/v2.10/ \

View file

@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.51 2007/01/06 15:13:15 wiz Exp $
@comment $NetBSD: PLIST,v 1.52 2007/01/08 16:41:31 drochner Exp $
bin/gdk-pixbuf-csource
bin/gdk-pixbuf-query-loaders
bin/gtk-demo
@ -254,7 +254,7 @@ lib/gtk-2.0/2.10.0/immodules/im-cedilla.la
lib/gtk-2.0/2.10.0/immodules/im-cyrillic-translit.la
lib/gtk-2.0/2.10.0/immodules/im-inuktitut.la
lib/gtk-2.0/2.10.0/immodules/im-ipa.la
lib/gtk-2.0/2.10.0/immodules/im-thai-broken.la
lib/gtk-2.0/2.10.0/immodules/im-thai.la
lib/gtk-2.0/2.10.0/immodules/im-ti-er.la
lib/gtk-2.0/2.10.0/immodules/im-ti-et.la
lib/gtk-2.0/2.10.0/immodules/im-viqr.la
@ -937,6 +937,8 @@ share/locale/ang/LC_MESSAGES/gtk20-properties.mo
share/locale/ang/LC_MESSAGES/gtk20.mo
share/locale/ar/LC_MESSAGES/gtk20-properties.mo
share/locale/ar/LC_MESSAGES/gtk20.mo
share/locale/as/LC_MESSAGES/gtk20-properties.mo
share/locale/as/LC_MESSAGES/gtk20.mo
share/locale/az/LC_MESSAGES/gtk20-properties.mo
share/locale/az/LC_MESSAGES/gtk20.mo
share/locale/az_IR/LC_MESSAGES/gtk20-properties.mo
@ -1059,6 +1061,8 @@ share/locale/ru/LC_MESSAGES/gtk20-properties.mo
share/locale/ru/LC_MESSAGES/gtk20.mo
share/locale/rw/LC_MESSAGES/gtk20-properties.mo
share/locale/rw/LC_MESSAGES/gtk20.mo
share/locale/si/LC_MESSAGES/gtk20-properties.mo
share/locale/si/LC_MESSAGES/gtk20.mo
share/locale/sk/LC_MESSAGES/gtk20-properties.mo
share/locale/sk/LC_MESSAGES/gtk20.mo
share/locale/sl/LC_MESSAGES/gtk20-properties.mo

View file

@ -1,11 +1,10 @@
$NetBSD: distinfo,v 1.77 2007/01/06 15:13:15 wiz Exp $
$NetBSD: distinfo,v 1.78 2007/01/08 16:41:31 drochner Exp $
SHA1 (gtk+-2.10.6.tar.bz2) = aad6e1ef964d8acb8a04942b8dd2e00a9db56450
RMD160 (gtk+-2.10.6.tar.bz2) = 929386610a634e82b7ddb10f43930b27194fa67b
Size (gtk+-2.10.6.tar.bz2) = 14561124 bytes
SHA1 (gtk+-2.10.7.tar.bz2) = 784a7ecc75767306efe1f200a1251968f944143e
RMD160 (gtk+-2.10.7.tar.bz2) = 130af39787b146166846f44b104ea0c3683d0578
Size (gtk+-2.10.7.tar.bz2) = 14955229 bytes
SHA1 (patch-aa) = 7efcbf733e3459fd3853c0d49842136b434ca983
SHA1 (patch-ab) = 1762c9e3361c071c632cd7eb2af7b17ca3078e5b
SHA1 (patch-ac) = d9a47653b8db5ffae28dc233aea0dc15399eea79
SHA1 (patch-ad) = f38270c343961be2892d8f2b2f89a67d21f0dc15
SHA1 (patch-ae) = f64113f824efced935f2c464c340cf0ab1c0b460
SHA1 (patch-af) = 36734d064fc2b103755cf86bea85a0dc33154f90

View file

@ -1,16 +0,0 @@
$NetBSD: patch-ac,v 1.12 2005/04/15 13:47:25 wiz Exp $
--- gdk/x11/gdkspawn-x11.c.orig 2005-03-16 04:25:09.000000000 +0100
+++ gdk/x11/gdkspawn-x11.c
@@ -28,6 +28,11 @@
#include <gdk/gdk.h>
#include "gdkalias.h"
+#if defined(__APPLE__)
+#include <crt_externs.h>
+#define environ (*_NSGetEnviron())
+#endif
+
extern char **environ;
/**