Update devel/cmph to 1.1 and add a support for the "test" target.

News for version 1.1

  Fixed a bug in the chd_pc algorithm and reorganized tests.
This commit is contained in:
alnsn 2011-05-22 11:33:31 +00:00
parent 7381b98d43
commit a1348b752f
3 changed files with 22 additions and 6 deletions

View file

@ -1,6 +1,6 @@
# $NetBSD: Makefile,v 1.1 2011/04/28 20:45:48 alnsn Exp $
# $NetBSD: Makefile,v 1.2 2011/05/22 11:33:31 alnsn Exp $
DISTNAME= cmph-1.0
DISTNAME= cmph-1.1
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=cmph/}
@ -14,4 +14,7 @@ PKG_DESTDIR_SUPPORT= user-destdir
USE_LIBTOOL= yes
GNU_CONFIGURE= yes
TEST_DIRS= tests
TEST_TARGET= check
.include "../../mk/bsd.pkg.mk"

View file

@ -1,5 +1,6 @@
$NetBSD: distinfo,v 1.1 2011/04/28 20:45:48 alnsn Exp $
$NetBSD: distinfo,v 1.2 2011/05/22 11:33:31 alnsn Exp $
SHA1 (cmph-1.0.tar.gz) = d92755f95dae90c5bcc5251f4b926693a8d6c9f1
RMD160 (cmph-1.0.tar.gz) = d8e4a8ef43b889c161ee99f42182021ef6098ca8
Size (cmph-1.0.tar.gz) = 382668 bytes
SHA1 (cmph-1.1.tar.gz) = 005b17395451284cfbc9d4b3d65c7f64a2a97997
RMD160 (cmph-1.1.tar.gz) = 55392941671d7aa5ade26e8d2f62ea05cc47e543
Size (cmph-1.1.tar.gz) = 425150 bytes
SHA1 (patch-src_brz.c) = 771589ac40e11240a0746f19cb63490d828c61db

View file

@ -0,0 +1,12 @@
$NetBSD: patch-src_brz.c,v 1.1 2011/05/22 11:33:32 alnsn Exp $
https://sourceforge.net/tracker/?func=detail&aid=3303005&group_id=126608&atid=706186
--- src/brz.c.orig 2011-05-15 15:31:05.000000000 +0000
+++ src/brz.c
@@ -981,5 +981,6 @@ cmph_uint32 brz_search_packed(void *pack
return brz_bmz8_search_packed(ptr, key, keylen, fingerprint);
default: assert(0);
}
+ return 0;
}