update to 0.12.0
this is a major update, no changelog available pkgsrc note: restored Python plugin support (got lost in a previous update)
This commit is contained in:
parent
201874a501
commit
a148abf221
6 changed files with 224 additions and 88 deletions
|
@ -1,10 +1,9 @@
|
|||
# $NetBSD: Makefile,v 1.61 2009/03/08 15:56:43 wiz Exp $
|
||||
# $NetBSD: Makefile,v 1.62 2009/04/17 17:51:00 drochner Exp $
|
||||
#
|
||||
|
||||
DISTNAME= rhythmbox-0.11.6
|
||||
PKGREVISION= 1
|
||||
DISTNAME= rhythmbox-0.12.0
|
||||
CATEGORIES= audio gnome
|
||||
MASTER_SITES= ${MASTER_SITE_GNOME:=sources/rhythmbox/0.11/}
|
||||
MASTER_SITES= ${MASTER_SITE_GNOME:=sources/rhythmbox/0.12/}
|
||||
EXTRACT_SUFX= .tar.bz2
|
||||
|
||||
MAINTAINER= pkgsrc-users@NetBSD.org
|
||||
|
@ -26,7 +25,7 @@ USE_TOOLS+= gmake intltool msgfmt pkg-config
|
|||
USE_LIBTOOL= YES
|
||||
USE_PKGLOCALEDIR= YES
|
||||
|
||||
CONFIGURE_ARGS+= --disable-python
|
||||
CONFIGURE_ARGS+= --disable-browser-plugin
|
||||
CONFIGURE_ARGS+= --with-html-dir=${PREFIX}/share/doc
|
||||
.if !empty(PKG_OPTIONS:Mhal)
|
||||
CONFIGURE_ARGS+= --with-ipod
|
||||
|
@ -41,12 +40,18 @@ PLIST.hal= yes
|
|||
CONFIGURE_ARGS+= --without-hal
|
||||
.endif
|
||||
|
||||
# for DAAP
|
||||
.include "../../net/avahi/buildlink3.mk"
|
||||
|
||||
GCONF_SCHEMAS= rhythmbox.schemas
|
||||
|
||||
BUILDLINK_API_DEPENDS.gtk2+= gtk2+>=2.6.0
|
||||
BUILDLINK_API_DEPENDS.musicbrainz+= musicbrainz>=2.1.0
|
||||
BUILDLINK_API_DEPENDS.totem+= {totem,totem-xine}>=1.1.5
|
||||
|
||||
.include "../../lang/python/application.mk"
|
||||
.include "../../x11/py-gtk2/buildlink3.mk"
|
||||
.include "../../multimedia/py-gstreamer0.10/buildlink3.mk"
|
||||
.include "../../audio/musicbrainz/buildlink3.mk"
|
||||
.include "../../devel/GConf/schemas.mk"
|
||||
.include "../../devel/gettext-lib/buildlink3.mk"
|
||||
|
@ -59,7 +64,6 @@ BUILDLINK_API_DEPENDS.totem+= {totem,totem-xine}>=1.1.5
|
|||
.include "../../multimedia/gstreamer0.10/buildlink3.mk"
|
||||
.include "../../multimedia/gst-plugins0.10-base/buildlink3.mk"
|
||||
.include "../../multimedia/totem-pl-parser/buildlink3.mk"
|
||||
.include "../../net/howl/buildlink3.mk"
|
||||
.include "../../net/libsoup24/buildlink3.mk"
|
||||
.include "../../sysutils/dbus-glib/buildlink3.mk"
|
||||
.include "../../sysutils/desktop-file-utils/desktopdb.mk"
|
||||
|
|
|
@ -1,7 +1,27 @@
|
|||
@comment $NetBSD: PLIST,v 1.18 2008/12/26 15:35:51 jmcneill Exp $
|
||||
@comment $NetBSD: PLIST,v 1.19 2009/04/17 17:51:00 drochner Exp $
|
||||
bin/rhythmbox
|
||||
bin/rhythmbox-client
|
||||
lib/librhythmbox-core.la
|
||||
lib/rhythmbox/plugins/artdisplay/AmazonCoverArtSearch.py
|
||||
lib/rhythmbox/plugins/artdisplay/AmazonCoverArtSearch.pyc
|
||||
lib/rhythmbox/plugins/artdisplay/AmazonCoverArtSearch.pyo
|
||||
lib/rhythmbox/plugins/artdisplay/CoverArtDatabase.py
|
||||
lib/rhythmbox/plugins/artdisplay/CoverArtDatabase.pyc
|
||||
lib/rhythmbox/plugins/artdisplay/CoverArtDatabase.pyo
|
||||
lib/rhythmbox/plugins/artdisplay/LocalCoverArtSearch.py
|
||||
lib/rhythmbox/plugins/artdisplay/LocalCoverArtSearch.pyc
|
||||
lib/rhythmbox/plugins/artdisplay/LocalCoverArtSearch.pyo
|
||||
lib/rhythmbox/plugins/artdisplay/LocalCoverArtSearchGIO.py
|
||||
lib/rhythmbox/plugins/artdisplay/LocalCoverArtSearchGIO.pyc
|
||||
lib/rhythmbox/plugins/artdisplay/LocalCoverArtSearchGIO.pyo
|
||||
lib/rhythmbox/plugins/artdisplay/PodcastCoverArtSearch.py
|
||||
lib/rhythmbox/plugins/artdisplay/PodcastCoverArtSearch.pyc
|
||||
lib/rhythmbox/plugins/artdisplay/PodcastCoverArtSearch.pyo
|
||||
lib/rhythmbox/plugins/artdisplay/__init__.py
|
||||
lib/rhythmbox/plugins/artdisplay/__init__.pyc
|
||||
lib/rhythmbox/plugins/artdisplay/__init__.pyo
|
||||
lib/rhythmbox/plugins/artdisplay/artdisplay.rb-plugin
|
||||
lib/rhythmbox/plugins/artdisplay/rhythmbox-missing-artwork.svg
|
||||
lib/rhythmbox/plugins/audiocd/audiocd-ui.xml
|
||||
lib/rhythmbox/plugins/audiocd/audiocd.rb-plugin
|
||||
lib/rhythmbox/plugins/audiocd/libaudiocd.la
|
||||
|
@ -18,9 +38,16 @@ lib/rhythmbox/plugins/daap/daap-prefs.glade
|
|||
lib/rhythmbox/plugins/daap/daap-ui.xml
|
||||
lib/rhythmbox/plugins/daap/daap.rb-plugin
|
||||
lib/rhythmbox/plugins/daap/libdaap.la
|
||||
lib/rhythmbox/plugins/daap/rb-daap-glue.h
|
||||
lib/rhythmbox/plugins/dontreallyclose/dontreallyclose.py
|
||||
lib/rhythmbox/plugins/dontreallyclose/dontreallyclose.pyc
|
||||
lib/rhythmbox/plugins/dontreallyclose/dontreallyclose.pyo
|
||||
lib/rhythmbox/plugins/dontreallyclose/dontreallyclose.rb-plugin
|
||||
lib/rhythmbox/plugins/generic-player/generic-player-ui.xml
|
||||
lib/rhythmbox/plugins/generic-player/generic-player.rb-plugin
|
||||
lib/rhythmbox/plugins/generic-player/libgeneric-player.la
|
||||
${PLIST.hal}lib/rhythmbox/plugins/ipod/ipod-info.glade
|
||||
${PLIST.hal}lib/rhythmbox/plugins/ipod/ipod-init.glade
|
||||
${PLIST.hal}lib/rhythmbox/plugins/ipod/ipod-ui.xml
|
||||
${PLIST.hal}lib/rhythmbox/plugins/ipod/ipod.rb-plugin
|
||||
${PLIST.hal}lib/rhythmbox/plugins/ipod/libipod.la
|
||||
|
@ -29,10 +56,97 @@ lib/rhythmbox/plugins/iradio/iradio-ui.xml
|
|||
lib/rhythmbox/plugins/iradio/iradio.rb-plugin
|
||||
lib/rhythmbox/plugins/iradio/libiradio.la
|
||||
lib/rhythmbox/plugins/iradio/station-properties.glade
|
||||
lib/rhythmbox/plugins/jamendo/JamendoConfigureDialog.py
|
||||
lib/rhythmbox/plugins/jamendo/JamendoConfigureDialog.pyc
|
||||
lib/rhythmbox/plugins/jamendo/JamendoConfigureDialog.pyo
|
||||
lib/rhythmbox/plugins/jamendo/JamendoSaxHandler.py
|
||||
lib/rhythmbox/plugins/jamendo/JamendoSaxHandler.pyc
|
||||
lib/rhythmbox/plugins/jamendo/JamendoSaxHandler.pyo
|
||||
lib/rhythmbox/plugins/jamendo/JamendoSource.py
|
||||
lib/rhythmbox/plugins/jamendo/JamendoSource.pyc
|
||||
lib/rhythmbox/plugins/jamendo/JamendoSource.pyo
|
||||
lib/rhythmbox/plugins/jamendo/__init__.py
|
||||
lib/rhythmbox/plugins/jamendo/__init__.pyc
|
||||
lib/rhythmbox/plugins/jamendo/__init__.pyo
|
||||
lib/rhythmbox/plugins/jamendo/jamendo-loading.glade
|
||||
lib/rhythmbox/plugins/jamendo/jamendo-prefs.glade
|
||||
lib/rhythmbox/plugins/jamendo/jamendo.rb-plugin
|
||||
lib/rhythmbox/plugins/jamendo/jamendo_logo.png
|
||||
lib/rhythmbox/plugins/jamendo/jamendo_logo_medium.png
|
||||
lib/rhythmbox/plugins/lyrics/AstrawebParser.py
|
||||
lib/rhythmbox/plugins/lyrics/AstrawebParser.pyc
|
||||
lib/rhythmbox/plugins/lyrics/AstrawebParser.pyo
|
||||
lib/rhythmbox/plugins/lyrics/LeoslyricsParser.py
|
||||
lib/rhythmbox/plugins/lyrics/LeoslyricsParser.pyc
|
||||
lib/rhythmbox/plugins/lyrics/LeoslyricsParser.pyo
|
||||
lib/rhythmbox/plugins/lyrics/LyrcParser.py
|
||||
lib/rhythmbox/plugins/lyrics/LyrcParser.pyc
|
||||
lib/rhythmbox/plugins/lyrics/LyrcParser.pyo
|
||||
lib/rhythmbox/plugins/lyrics/LyricWikiParser.py
|
||||
lib/rhythmbox/plugins/lyrics/LyricWikiParser.pyc
|
||||
lib/rhythmbox/plugins/lyrics/LyricWikiParser.pyo
|
||||
lib/rhythmbox/plugins/lyrics/LyricsConfigureDialog.py
|
||||
lib/rhythmbox/plugins/lyrics/LyricsConfigureDialog.pyc
|
||||
lib/rhythmbox/plugins/lyrics/LyricsConfigureDialog.pyo
|
||||
lib/rhythmbox/plugins/lyrics/LyricsParse.py
|
||||
lib/rhythmbox/plugins/lyrics/LyricsParse.pyc
|
||||
lib/rhythmbox/plugins/lyrics/LyricsParse.pyo
|
||||
lib/rhythmbox/plugins/lyrics/WinampcnParser.py
|
||||
lib/rhythmbox/plugins/lyrics/WinampcnParser.pyc
|
||||
lib/rhythmbox/plugins/lyrics/WinampcnParser.pyo
|
||||
lib/rhythmbox/plugins/lyrics/__init__.py
|
||||
lib/rhythmbox/plugins/lyrics/__init__.pyc
|
||||
lib/rhythmbox/plugins/lyrics/__init__.pyo
|
||||
lib/rhythmbox/plugins/lyrics/lyrics-prefs.glade
|
||||
lib/rhythmbox/plugins/lyrics/lyrics.rb-plugin
|
||||
lib/rhythmbox/plugins/magnatune/BuyAlbumHandler.py
|
||||
lib/rhythmbox/plugins/magnatune/BuyAlbumHandler.pyc
|
||||
lib/rhythmbox/plugins/magnatune/BuyAlbumHandler.pyo
|
||||
lib/rhythmbox/plugins/magnatune/MagnatuneSource.py
|
||||
lib/rhythmbox/plugins/magnatune/MagnatuneSource.pyc
|
||||
lib/rhythmbox/plugins/magnatune/MagnatuneSource.pyo
|
||||
lib/rhythmbox/plugins/magnatune/TrackListHandler.py
|
||||
lib/rhythmbox/plugins/magnatune/TrackListHandler.pyc
|
||||
lib/rhythmbox/plugins/magnatune/TrackListHandler.pyo
|
||||
lib/rhythmbox/plugins/magnatune/__init__.py
|
||||
lib/rhythmbox/plugins/magnatune/__init__.pyc
|
||||
lib/rhythmbox/plugins/magnatune/__init__.pyo
|
||||
lib/rhythmbox/plugins/magnatune/magnatune-loading.glade
|
||||
lib/rhythmbox/plugins/magnatune/magnatune-prefs.glade
|
||||
lib/rhythmbox/plugins/magnatune/magnatune-purchase.glade
|
||||
lib/rhythmbox/plugins/magnatune/magnatune.rb-plugin
|
||||
lib/rhythmbox/plugins/magnatune/magnatune_logo_color_small.png
|
||||
lib/rhythmbox/plugins/magnatune/magnatune_logo_color_tiny.png
|
||||
lib/rhythmbox/plugins/mmkeys/libmmkeys.la
|
||||
lib/rhythmbox/plugins/mmkeys/mmkeys.rb-plugin
|
||||
lib/rhythmbox/plugins/power-manager/libpower-manager.la
|
||||
lib/rhythmbox/plugins/power-manager/power-manager.rb-plugin
|
||||
lib/rhythmbox/plugins/python-console/pythonconsole.py
|
||||
lib/rhythmbox/plugins/python-console/pythonconsole.pyc
|
||||
lib/rhythmbox/plugins/python-console/pythonconsole.pyo
|
||||
lib/rhythmbox/plugins/python-console/pythonconsole.rb-plugin
|
||||
lib/rhythmbox/plugins/rb/Coroutine.py
|
||||
lib/rhythmbox/plugins/rb/Coroutine.pyc
|
||||
lib/rhythmbox/plugins/rb/Coroutine.pyo
|
||||
lib/rhythmbox/plugins/rb/Loader.py
|
||||
lib/rhythmbox/plugins/rb/Loader.pyc
|
||||
lib/rhythmbox/plugins/rb/Loader.pyo
|
||||
lib/rhythmbox/plugins/rb/__init__.py
|
||||
lib/rhythmbox/plugins/rb/__init__.pyc
|
||||
lib/rhythmbox/plugins/rb/__init__.pyo
|
||||
lib/rhythmbox/plugins/upnp_coherence/MediaPlayer.py
|
||||
lib/rhythmbox/plugins/upnp_coherence/MediaPlayer.pyc
|
||||
lib/rhythmbox/plugins/upnp_coherence/MediaPlayer.pyo
|
||||
lib/rhythmbox/plugins/upnp_coherence/MediaStore.py
|
||||
lib/rhythmbox/plugins/upnp_coherence/MediaStore.pyc
|
||||
lib/rhythmbox/plugins/upnp_coherence/MediaStore.pyo
|
||||
lib/rhythmbox/plugins/upnp_coherence/UpnpSource.py
|
||||
lib/rhythmbox/plugins/upnp_coherence/UpnpSource.pyc
|
||||
lib/rhythmbox/plugins/upnp_coherence/UpnpSource.pyo
|
||||
lib/rhythmbox/plugins/upnp_coherence/__init__.py
|
||||
lib/rhythmbox/plugins/upnp_coherence/__init__.pyc
|
||||
lib/rhythmbox/plugins/upnp_coherence/__init__.pyo
|
||||
lib/rhythmbox/plugins/upnp_coherence/coherence.rb-plugin
|
||||
lib/rhythmbox/plugins/visualizer/libvisualizer.la
|
||||
lib/rhythmbox/plugins/visualizer/rb-visualizer-glue.h
|
||||
lib/rhythmbox/plugins/visualizer/visualizer-controls.glade
|
||||
|
@ -66,6 +180,7 @@ share/doc/rhythmbox/RBProxyConfig.html
|
|||
share/doc/rhythmbox/RBQueryCreator.html
|
||||
share/doc/rhythmbox/RBRandomPlayOrder.html
|
||||
share/doc/rhythmbox/RBRating.html
|
||||
share/doc/rhythmbox/RBRemovableMediaManager.html
|
||||
share/doc/rhythmbox/RBSearchEntry.html
|
||||
share/doc/rhythmbox/RBShellClipboard.html
|
||||
share/doc/rhythmbox/RBShellPlayer.html
|
||||
|
@ -75,7 +190,9 @@ share/doc/rhythmbox/RBSource.html
|
|||
share/doc/rhythmbox/RBSourceHeader.html
|
||||
share/doc/rhythmbox/RBSourceList.html
|
||||
share/doc/rhythmbox/RBSourceListModel.html
|
||||
share/doc/rhythmbox/RBStatusbar.html
|
||||
share/doc/rhythmbox/RBStringValueMap.html
|
||||
share/doc/rhythmbox/RBTrayIcon.html
|
||||
share/doc/rhythmbox/RBURIDialog.html
|
||||
share/doc/rhythmbox/RhythmDB.html
|
||||
share/doc/rhythmbox/RhythmDBImportJob.html
|
||||
|
@ -92,6 +209,7 @@ share/doc/rhythmbox/home.png
|
|||
share/doc/rhythmbox/index.html
|
||||
share/doc/rhythmbox/index.sgml
|
||||
share/doc/rhythmbox/left.png
|
||||
share/doc/rhythmbox/rhythmbox-RBPodcastSource.html
|
||||
share/doc/rhythmbox/rhythmbox-RBSourceGroup.html
|
||||
share/doc/rhythmbox/rhythmbox-eel-gconf-extensions.html
|
||||
share/doc/rhythmbox/rhythmbox-rb-async-queue-watch.html
|
||||
|
@ -100,15 +218,11 @@ share/doc/rhythmbox/rhythmbox-rb-dialog.html
|
|||
share/doc/rhythmbox/rhythmbox-rb-file-helpers.html
|
||||
share/doc/rhythmbox/rhythmbox-rb-glade-helpers.html
|
||||
share/doc/rhythmbox/rhythmbox-rb-header.html
|
||||
share/doc/rhythmbox/rhythmbox-rb-podcast-source.html
|
||||
share/doc/rhythmbox/rhythmbox-rb-rating-helper.html
|
||||
share/doc/rhythmbox/rhythmbox-rb-removable-media-manager.html
|
||||
share/doc/rhythmbox/rhythmbox-rb-removable-media-source.html
|
||||
share/doc/rhythmbox/rhythmbox-rb-shell.html
|
||||
share/doc/rhythmbox/rhythmbox-rb-static-playlist-source.html
|
||||
share/doc/rhythmbox/rhythmbox-rb-statusbar.html
|
||||
share/doc/rhythmbox/rhythmbox-rb-streaming-source.html
|
||||
share/doc/rhythmbox/rhythmbox-rb-tray-icon.html
|
||||
share/doc/rhythmbox/rhythmbox-rb-tree-dnd.html
|
||||
share/doc/rhythmbox/rhythmbox-rb-util.html
|
||||
share/doc/rhythmbox/rhythmbox-rhythmdb-query-model.html
|
||||
|
@ -135,6 +249,20 @@ share/gnome/help/rhythmbox/C/figures/rb-window-small.png
|
|||
share/gnome/help/rhythmbox/C/figures/rb-window.png
|
||||
share/gnome/help/rhythmbox/C/legal.xml
|
||||
share/gnome/help/rhythmbox/C/rhythmbox.xml
|
||||
share/gnome/help/rhythmbox/cs/figures/rb-iradio-main.png
|
||||
share/gnome/help/rhythmbox/cs/figures/rb-notification-area-menu.png
|
||||
share/gnome/help/rhythmbox/cs/figures/rb-notification-window.png
|
||||
share/gnome/help/rhythmbox/cs/figures/rb-notification-zone.png
|
||||
share/gnome/help/rhythmbox/cs/figures/rb-podcast-main.png
|
||||
share/gnome/help/rhythmbox/cs/figures/rb-statusbar.png
|
||||
share/gnome/help/rhythmbox/cs/figures/rb-toolbar-prevplaynext.png
|
||||
share/gnome/help/rhythmbox/cs/figures/rb-toolbar-repeat.png
|
||||
share/gnome/help/rhythmbox/cs/figures/rb-toolbar-shuffle.png
|
||||
share/gnome/help/rhythmbox/cs/figures/rb-toolbar.png
|
||||
share/gnome/help/rhythmbox/cs/figures/rb-volume-changer.png
|
||||
share/gnome/help/rhythmbox/cs/figures/rb-window-small.png
|
||||
share/gnome/help/rhythmbox/cs/figures/rb-window.png
|
||||
share/gnome/help/rhythmbox/cs/rhythmbox.xml
|
||||
share/gnome/help/rhythmbox/da/figures/rb-iradio-main.png
|
||||
share/gnome/help/rhythmbox/da/figures/rb-notification-area-menu.png
|
||||
share/gnome/help/rhythmbox/da/figures/rb-notification-window.png
|
||||
|
@ -277,6 +405,7 @@ share/gnome/help/rhythmbox/zh_CN/figures/rb-window.png
|
|||
share/gnome/help/rhythmbox/zh_CN/rhythmbox.xml
|
||||
share/icons/hicolor/16x16/apps/rhythmbox.png
|
||||
share/icons/hicolor/22x22/apps/rhythmbox.png
|
||||
share/icons/hicolor/24x24/apps/rhythmbox.png
|
||||
share/icons/hicolor/32x32/apps/rhythmbox.png
|
||||
share/icons/hicolor/48x48/apps/rhythmbox.png
|
||||
share/icons/hicolor/scalable/apps/rhythmbox.svg
|
||||
|
@ -331,7 +460,7 @@ share/locale/ru/LC_MESSAGES/rhythmbox.mo
|
|||
share/locale/rw/LC_MESSAGES/rhythmbox.mo
|
||||
share/locale/sk/LC_MESSAGES/rhythmbox.mo
|
||||
share/locale/sr/LC_MESSAGES/rhythmbox.mo
|
||||
share/locale/sr@Latn/LC_MESSAGES/rhythmbox.mo
|
||||
share/locale/sr@latin/LC_MESSAGES/rhythmbox.mo
|
||||
share/locale/sv/LC_MESSAGES/rhythmbox.mo
|
||||
share/locale/th/LC_MESSAGES/rhythmbox.mo
|
||||
share/locale/tr/LC_MESSAGES/rhythmbox.mo
|
||||
|
@ -341,6 +470,7 @@ share/locale/zh_CN/LC_MESSAGES/rhythmbox.mo
|
|||
share/locale/zh_HK/LC_MESSAGES/rhythmbox.mo
|
||||
share/locale/zh_TW/LC_MESSAGES/rhythmbox.mo
|
||||
share/omf/rhythmbox/rhythmbox-C.omf
|
||||
share/omf/rhythmbox/rhythmbox-cs.omf
|
||||
share/omf/rhythmbox/rhythmbox-da.omf
|
||||
share/omf/rhythmbox/rhythmbox-de.omf
|
||||
share/omf/rhythmbox/rhythmbox-el.omf
|
||||
|
@ -364,6 +494,10 @@ share/rhythmbox/glade/song-info-multiple.glade
|
|||
share/rhythmbox/glade/song-info.glade
|
||||
share/rhythmbox/glade/uri-new.glade
|
||||
share/rhythmbox/glade/uri.glade
|
||||
share/rhythmbox/icons/hicolor/16x16/actions/audio-cd-duplicate.png
|
||||
share/rhythmbox/icons/hicolor/16x16/actions/audio-cd-duplicate.svg
|
||||
share/rhythmbox/icons/hicolor/16x16/actions/audio-cd-new.png
|
||||
share/rhythmbox/icons/hicolor/16x16/actions/audio-cd-new.svg
|
||||
share/rhythmbox/icons/hicolor/16x16/actions/internet-radio-new.png
|
||||
share/rhythmbox/icons/hicolor/16x16/actions/media-eject.png
|
||||
share/rhythmbox/icons/hicolor/16x16/actions/playlist-automatic-new.png
|
||||
|
@ -377,6 +511,10 @@ share/rhythmbox/icons/hicolor/16x16/status/rhythmbox-no-star.png
|
|||
share/rhythmbox/icons/hicolor/16x16/status/rhythmbox-notplaying.png
|
||||
share/rhythmbox/icons/hicolor/16x16/status/rhythmbox-set-star.png
|
||||
share/rhythmbox/icons/hicolor/16x16/status/rhythmbox-unset-star.png
|
||||
share/rhythmbox/icons/hicolor/22x22/actions/audio-cd-duplicate.png
|
||||
share/rhythmbox/icons/hicolor/22x22/actions/audio-cd-duplicate.svg
|
||||
share/rhythmbox/icons/hicolor/22x22/actions/audio-cd-new.png
|
||||
share/rhythmbox/icons/hicolor/22x22/actions/audio-cd-new.svg
|
||||
share/rhythmbox/icons/hicolor/22x22/actions/internet-radio-new.png
|
||||
share/rhythmbox/icons/hicolor/22x22/actions/playlist-automatic-new.png
|
||||
share/rhythmbox/icons/hicolor/22x22/actions/playlist-new.png
|
||||
|
@ -387,6 +525,12 @@ share/rhythmbox/icons/hicolor/22x22/places/library-podcast.png
|
|||
share/rhythmbox/icons/hicolor/22x22/places/playlist-automatic.png
|
||||
share/rhythmbox/icons/hicolor/22x22/places/playlist.png
|
||||
share/rhythmbox/icons/hicolor/22x22/status/rhythmbox-notplaying.png
|
||||
share/rhythmbox/icons/hicolor/24x24/places/jamendo.png
|
||||
share/rhythmbox/icons/hicolor/24x24/places/magnatune.png
|
||||
share/rhythmbox/icons/hicolor/32x32/actions/audio-cd-duplicate.png
|
||||
share/rhythmbox/icons/hicolor/32x32/actions/audio-cd-duplicate.svg
|
||||
share/rhythmbox/icons/hicolor/32x32/actions/audio-cd-new.png
|
||||
share/rhythmbox/icons/hicolor/32x32/actions/audio-cd-new.svg
|
||||
share/rhythmbox/icons/hicolor/32x32/actions/internet-radio-new.png
|
||||
share/rhythmbox/icons/hicolor/32x32/actions/playlist-automatic-new.png
|
||||
share/rhythmbox/icons/hicolor/32x32/actions/playlist-new.png
|
||||
|
@ -394,6 +538,8 @@ share/rhythmbox/icons/hicolor/32x32/places/library-internet-radio.png
|
|||
share/rhythmbox/icons/hicolor/32x32/places/playlist-automatic.png
|
||||
share/rhythmbox/icons/hicolor/32x32/places/playlist.png
|
||||
share/rhythmbox/icons/hicolor/32x32/status/rhythmbox-notplaying.png
|
||||
share/rhythmbox/icons/hicolor/scalable/actions/audio-cd-duplicate.svg
|
||||
share/rhythmbox/icons/hicolor/scalable/actions/audio-cd-new.svg
|
||||
share/rhythmbox/icons/hicolor/scalable/actions/internet-radio-new.svg
|
||||
share/rhythmbox/icons/hicolor/scalable/actions/playlist-automatic-new.svg
|
||||
share/rhythmbox/icons/hicolor/scalable/actions/playlist-new.svg
|
||||
|
@ -411,6 +557,8 @@ share/rhythmbox/rhythmbox-ui.xml
|
|||
@dirrm share/rhythmbox/icons/hicolor/32x32/places
|
||||
@dirrm share/rhythmbox/icons/hicolor/32x32/actions
|
||||
@dirrm share/rhythmbox/icons/hicolor/32x32
|
||||
@dirrm share/rhythmbox/icons/hicolor/24x24/places
|
||||
@dirrm share/rhythmbox/icons/hicolor/24x24
|
||||
@dirrm share/rhythmbox/icons/hicolor/22x22/status
|
||||
@dirrm share/rhythmbox/icons/hicolor/22x22/places
|
||||
@dirrm share/rhythmbox/icons/hicolor/22x22/actions
|
||||
|
@ -428,6 +576,7 @@ share/rhythmbox/rhythmbox-ui.xml
|
|||
@comment in hicolor-icon-theme: @dirrm share/icons/hicolor/scalable/apps
|
||||
@comment in hicolor-icon-theme: @dirrm share/icons/hicolor/48x48/apps
|
||||
@comment in hicolor-icon-theme: @dirrm share/icons/hicolor/32x32/apps
|
||||
@comment in hicolor-icon-theme: @dirrm share/icons/hicolor/24x24/apps
|
||||
@comment in hicolor-icon-theme: @dirrm share/icons/hicolor/22x22/apps
|
||||
@comment in hicolor-icon-theme: @dirrm share/icons/hicolor/16x16/apps
|
||||
@comment in hicolor-icon-theme: @dirrm share/icons/hicolor
|
||||
|
@ -451,6 +600,8 @@ share/rhythmbox/rhythmbox-ui.xml
|
|||
@dirrm share/gnome/help/rhythmbox/de
|
||||
@dirrm share/gnome/help/rhythmbox/da/figures
|
||||
@dirrm share/gnome/help/rhythmbox/da
|
||||
@dirrm share/gnome/help/rhythmbox/cs/figures
|
||||
@dirrm share/gnome/help/rhythmbox/cs
|
||||
@dirrm share/gnome/help/rhythmbox/C/figures
|
||||
@dirrm share/gnome/help/rhythmbox/C
|
||||
@dirrm share/gnome/help/rhythmbox
|
||||
|
@ -460,14 +611,21 @@ share/rhythmbox/rhythmbox-ui.xml
|
|||
@comment in dbus: @dirrm share/dbus-1/services
|
||||
@comment in xdg-dirs: @dirrm share/applications
|
||||
@dirrm lib/rhythmbox/plugins/visualizer
|
||||
@dirrm lib/rhythmbox/plugins/upnp_coherence
|
||||
@dirrm lib/rhythmbox/plugins/rb
|
||||
@dirrm lib/rhythmbox/plugins/python-console
|
||||
@dirrm lib/rhythmbox/plugins/power-manager
|
||||
@dirrm lib/rhythmbox/plugins/mmkeys
|
||||
@dirrm lib/rhythmbox/plugins/magnatune
|
||||
@dirrm lib/rhythmbox/plugins/lyrics
|
||||
@dirrm lib/rhythmbox/plugins/jamendo
|
||||
@dirrm lib/rhythmbox/plugins/iradio
|
||||
${PLIST.hal}@dirrm lib/rhythmbox/plugins/ipod
|
||||
@dirrm lib/rhythmbox/plugins/generic-player
|
||||
@dirrm lib/rhythmbox/plugins/dontreallyclose
|
||||
@dirrm lib/rhythmbox/plugins/daap
|
||||
@dirrm lib/rhythmbox/plugins/cd-recorder
|
||||
@dirrm lib/rhythmbox/plugins/audioscrobbler
|
||||
@dirrm lib/rhythmbox/plugins/audiocd
|
||||
@dirrm lib/rhythmbox/plugins/artdisplay
|
||||
@dirrm lib/rhythmbox/plugins
|
||||
@dirrm lib/rhythmbox
|
||||
|
|
|
@ -1,9 +1,9 @@
|
|||
$NetBSD: distinfo,v 1.24 2008/12/26 20:42:26 jmcneill Exp $
|
||||
$NetBSD: distinfo,v 1.25 2009/04/17 17:51:00 drochner Exp $
|
||||
|
||||
SHA1 (rhythmbox-0.11.6.tar.bz2) = 4364447bd4f6fb0e969039213cea37d6d3e4fb58
|
||||
RMD160 (rhythmbox-0.11.6.tar.bz2) = 3fd6b8595705a91c779c458a26333575ba5e2233
|
||||
Size (rhythmbox-0.11.6.tar.bz2) = 4683400 bytes
|
||||
SHA1 (rhythmbox-0.12.0.tar.bz2) = b9c478099d9a1dc3a201d5d217d0b08b111f81b9
|
||||
RMD160 (rhythmbox-0.12.0.tar.bz2) = d7bbf03b44d6b2ac22e4fb466122471e6368762e
|
||||
Size (rhythmbox-0.12.0.tar.bz2) = 4925468 bytes
|
||||
SHA1 (patch-aa) = fa82e1d8176f4ee0b82e8fc307d506444ae22600
|
||||
SHA1 (patch-ac) = c2cad1c4b074910797a21117f6809d8e00d12f30
|
||||
SHA1 (patch-ad) = 64139d56a250543b82d5d5586f58f38912a2cdc4
|
||||
SHA1 (patch-ae) = 216c726428342448eee4b8ce4fea884d43cdd600
|
||||
SHA1 (patch-ad) = db302f38ca3d4455b4088d80bda80f5653b5d8da
|
||||
SHA1 (patch-af) = 03129bac59d0a2cd40a2d342907afb48be39c8f6
|
||||
|
|
|
@ -1,17 +1,8 @@
|
|||
$NetBSD: patch-ad,v 1.3 2008/10/29 01:39:57 wiz Exp $
|
||||
$NetBSD: patch-ad,v 1.4 2009/04/17 17:51:01 drochner Exp $
|
||||
|
||||
--- configure.orig 2008-10-29 00:42:46.000000000 +0000
|
||||
--- configure.orig 2009-03-19 10:02:53.000000000 +0100
|
||||
+++ configure
|
||||
@@ -14258,7 +14258,7 @@ else
|
||||
echo "${ECHO_T}yes" >&6; }
|
||||
have_gio=yes
|
||||
fi
|
||||
-if test x$have_gio == "xyes"; then
|
||||
+if test x$have_gio = "xyes"; then
|
||||
|
||||
cat >>confdefs.h <<\_ACEOF
|
||||
#define HAVE_GIO 1
|
||||
@@ -14350,7 +14350,7 @@ echo "$as_me: error: HAL support explici
|
||||
@@ -14206,7 +14206,7 @@ $as_echo "$as_me: error: HAL support exp
|
||||
{ (exit 1); exit 1; }; }
|
||||
fi
|
||||
|
||||
|
@ -20,3 +11,20 @@ $NetBSD: patch-ad,v 1.3 2008/10/29 01:39:57 wiz Exp $
|
|||
|
||||
cat >>confdefs.h <<\_ACEOF
|
||||
#define HAVE_HAL 1
|
||||
@@ -20058,6 +20058,7 @@ if test "x$have_python" != "xno"; then
|
||||
|
||||
|
||||
|
||||
+if false; then
|
||||
|
||||
{ $as_echo "$as_me:$LINENO: checking whether we can build a shared library depending on libpython" >&5
|
||||
$as_echo_n "checking whether we can build a shared library depending on libpython... " >&6; }
|
||||
@@ -20095,6 +20096,8 @@ $as_echo "$as_me: WARNING: Disabling pyt
|
||||
$as_echo "$result" >&6; }
|
||||
fi
|
||||
|
||||
+fi
|
||||
+
|
||||
if test "x$have_python" != "xno"; then
|
||||
PYGTK_REQUIRED=2.8.0
|
||||
GST_PYTHON_REQUIRED=0.10.1
|
||||
|
|
|
@ -1,57 +0,0 @@
|
|||
$NetBSD: patch-ae,v 1.6 2008/12/26 20:42:26 jmcneill Exp $
|
||||
|
||||
From http://svn.gnome.org/viewvc/rhythmbox?view=revision&revision=5992
|
||||
|
||||
--- plugins/generic-player/rb-generic-player-source.c.orig 2008-12-26 15:40:52.000000000 -0500
|
||||
+++ plugins/generic-player/rb-generic-player-source.c 2008-12-26 15:41:31.000000000 -0500
|
||||
@@ -774,21 +774,43 @@
|
||||
gchar *udi = get_hal_udi_for_player (ctx, volume);
|
||||
if (udi != NULL) {
|
||||
DBusError error;
|
||||
+ char **proplist;
|
||||
char *prop;
|
||||
|
||||
rb_debug ("Checking udi %s", udi);
|
||||
/* check that it can be accessed as mass-storage */
|
||||
dbus_error_init (&error);
|
||||
- prop = libhal_device_get_property_string (ctx, udi, "portable_audio_player.access_method", &error);
|
||||
- if (prop != NULL && strcmp (prop, "storage") == 0 && !dbus_error_is_set (&error)) {
|
||||
- /* the device has passed all tests, so it should be a usable player */
|
||||
- result = TRUE;
|
||||
- } else {
|
||||
+ proplist = libhal_device_get_property_strlist (ctx, udi, "portable_audio_player.access_method.protocols", &error);
|
||||
+ if (proplist != NULL && !dbus_error_is_set (&error)) {
|
||||
+ int i;
|
||||
+ for (i = 0; proplist[i] != NULL; i++) {
|
||||
+ rb_debug ("device access method: %s", proplist[i]);
|
||||
+ if (strcmp (proplist[i], "storage") == 0) {
|
||||
+ result = TRUE;
|
||||
+ break;
|
||||
+ }
|
||||
+ }
|
||||
+
|
||||
+ libhal_free_string_array (proplist);
|
||||
+ }
|
||||
+ free_dbus_error ("checking device access method", &error);
|
||||
+
|
||||
+ if (result == FALSE) {
|
||||
+ dbus_error_init (&error);
|
||||
+ prop = libhal_device_get_property_string (ctx, udi, "portable_audio_player.access_method", &error);
|
||||
+ if (prop != NULL && strcmp (prop, "storage") == 0 && !dbus_error_is_set (&error)) {
|
||||
+ /* the device has passed all tests, so it should be a usable player */
|
||||
+ result = TRUE;
|
||||
+ }
|
||||
+
|
||||
+ libhal_free_string (prop);
|
||||
+ free_dbus_error ("checking device access method", &error);
|
||||
+ }
|
||||
+
|
||||
+ if (result == FALSE) {
|
||||
rb_debug ("device cannot be accessed via storage");
|
||||
}
|
||||
- libhal_free_string (prop);
|
||||
|
||||
- free_dbus_error ("checking device access method", &error);
|
||||
} else {
|
||||
rb_debug ("device is not an audio player");
|
||||
}
|
23
audio/rhythmbox/patches/patch-af
Normal file
23
audio/rhythmbox/patches/patch-af
Normal file
|
@ -0,0 +1,23 @@
|
|||
$NetBSD: patch-af,v 1.5 2009/04/17 17:51:01 drochner Exp $
|
||||
|
||||
--- rhythmdb/rhythmdb.c.orig 2009-03-28 19:22:05.000000000 +0100
|
||||
+++ rhythmdb/rhythmdb.c
|
||||
@@ -2997,8 +2997,9 @@ rhythmdb_add_to_stat_list (RhythmDB *db,
|
||||
/* do we really need to check for duplicate requests here? .. nah. */
|
||||
result->uri = rb_refstring_new (uri);
|
||||
db->priv->stat_list = g_list_prepend (db->priv->stat_list, result);
|
||||
-
|
||||
+#if 0
|
||||
g_mutex_unlock (db->priv->stat_mutex);
|
||||
+#endif
|
||||
}
|
||||
|
||||
|
||||
@@ -3052,6 +3053,7 @@ rhythmdb_add_uri_with_types (RhythmDB *d
|
||||
|
||||
entry = rhythmdb_entry_lookup_by_location (db, uri);
|
||||
rhythmdb_add_to_stat_list (db, uri, entry, type, ignore_type, error_type);
|
||||
+ g_mutex_unlock (db->priv->stat_mutex);
|
||||
}
|
||||
}
|
||||
|
Loading…
Reference in a new issue