devel/librelp: Update to 1.2.16.
Version 1.2.15 - 2018-03-21 - made build on Solaris again - made build on AIX - bugfix: invalid handling of snprintf() return code - bugfix: invalid assert predicate - some code cleanup - bugfix: error message on open error was truncated
This commit is contained in:
parent
636299e138
commit
a173a1b2d3
5 changed files with 75 additions and 15 deletions
|
@ -1,6 +1,6 @@
|
|||
# $NetBSD: Makefile,v 1.3 2017/07/04 13:19:23 fhajny Exp $
|
||||
# $NetBSD: Makefile,v 1.4 2018/03/23 12:24:32 fhajny Exp $
|
||||
|
||||
DISTNAME= librelp-1.2.14
|
||||
DISTNAME= librelp-1.2.15
|
||||
CATEGORIES= devel
|
||||
MASTER_SITES= http://download.rsyslog.com/librelp/
|
||||
|
||||
|
@ -16,6 +16,8 @@ USE_TOOLS+= pkg-config
|
|||
CONFIGURE_ARGS.SunOS+= ac_cv_func_epoll_create1=no
|
||||
CONFIGURE_ARGS.SunOS+= ac_cv_func_epoll_create=no
|
||||
CONFIGURE_ARGS.SunOS+= ac_cv_header_sys_epoll_h=no
|
||||
# Needed for obsolete NI_MAXHOST
|
||||
CPPFLAGS.SunOS+= -D__EXTENSIONS__
|
||||
|
||||
PKGCONFIG_OVERRIDE+= relp.pc.in
|
||||
|
||||
|
|
|
@ -1,7 +1,9 @@
|
|||
$NetBSD: distinfo,v 1.3 2017/07/04 13:19:23 fhajny Exp $
|
||||
$NetBSD: distinfo,v 1.4 2018/03/23 12:24:32 fhajny Exp $
|
||||
|
||||
SHA1 (librelp-1.2.14.tar.gz) = 13cb590d0cb36b415534339a1855e91cc771edc7
|
||||
RMD160 (librelp-1.2.14.tar.gz) = c76b261a6365b6bf1bb2a7113fb556353f7a22fc
|
||||
SHA512 (librelp-1.2.14.tar.gz) = b9a947edb7f23ba533f358d3271a61e80fcca7db8be0c20b39ec61ce4d913efed25173330a0604faebfbbdf33a051ed43234b2b41be2480dc3459c35b91acaae
|
||||
Size (librelp-1.2.14.tar.gz) = 437975 bytes
|
||||
SHA1 (patch-src_tcp.c) = 088973b11f649f6815ccf9c734f89763d520c25b
|
||||
SHA1 (librelp-1.2.15.tar.gz) = 648e773970f114ea78cbe21d94b264585a750d61
|
||||
RMD160 (librelp-1.2.15.tar.gz) = 14d7bcc135385f572bba88e0dd87ad57ba33e829
|
||||
SHA512 (librelp-1.2.15.tar.gz) = 9cf52c82c8e61f6970a83ead60da4bc64ab56a2bda42fedf184a1ae60c28f66d565a0c3a8720b55b9a2e5e3ffb7ec35601158f634c8f2965f8c0d3b4f1c15568
|
||||
Size (librelp-1.2.15.tar.gz) = 440273 bytes
|
||||
SHA1 (patch-configure) = 9c90263bddaa91d8b6adcc70591169ac6f7d78d4
|
||||
SHA1 (patch-src_Makefile.in) = f59ca692ac59af2f96638ac3eb5597610c1e0a97
|
||||
SHA1 (patch-src_tcp.c) = b8670856a958b92520162c5f86eeebad34a5c095
|
||||
|
|
42
devel/librelp/patches/patch-configure
Normal file
42
devel/librelp/patches/patch-configure
Normal file
|
@ -0,0 +1,42 @@
|
|||
$NetBSD: patch-configure,v 1.1 2018/03/23 12:24:32 fhajny Exp $
|
||||
|
||||
Portability.
|
||||
|
||||
--- configure.orig 2018-03-21 08:43:29.000000000 +0000
|
||||
+++ configure
|
||||
@@ -3234,7 +3234,7 @@ $as_echo "#define OS_AIX 1" >>confdefs.h
|
||||
LDFLAGS="$LDFLAGS -brtl"
|
||||
;;
|
||||
esac
|
||||
- if test x$os_type == xapple; then
|
||||
+ if test x$os_type = xapple; then
|
||||
OS_APPLE_TRUE=
|
||||
OS_APPLE_FALSE='#'
|
||||
else
|
||||
@@ -3242,7 +3242,7 @@ else
|
||||
OS_APPLE_FALSE=
|
||||
fi
|
||||
|
||||
- if test x$os_type == xlinux; then
|
||||
+ if test x$os_type = xlinux; then
|
||||
xOS_LINUX_TRUE=
|
||||
xOS_LINUX_FALSE='#'
|
||||
else
|
||||
@@ -3250,7 +3250,7 @@ else
|
||||
xOS_LINUX_FALSE=
|
||||
fi
|
||||
|
||||
- if test x$os_type == xlinux; then
|
||||
+ if test x$os_type = xlinux; then
|
||||
OS_LINUX_TRUE=
|
||||
OS_LINUX_FALSE='#'
|
||||
else
|
||||
@@ -3258,7 +3258,7 @@ else
|
||||
OS_LINUX_FALSE=
|
||||
fi
|
||||
|
||||
- if test x$os_type == xsolaris; then
|
||||
+ if test x$os_type = xsolaris; then
|
||||
OS_SOLARIS_TRUE=
|
||||
OS_SOLARIS_FALSE='#'
|
||||
else
|
14
devel/librelp/patches/patch-src_Makefile.in
Normal file
14
devel/librelp/patches/patch-src_Makefile.in
Normal file
|
@ -0,0 +1,14 @@
|
|||
$NetBSD: patch-src_Makefile.in,v 1.1 2018/03/23 12:24:32 fhajny Exp $
|
||||
|
||||
Fix M4 syntax error.
|
||||
|
||||
--- src/Makefile.in.orig 2018-03-21 08:43:29.000000000 +0000
|
||||
+++ src/Makefile.in
|
||||
@@ -821,7 +821,6 @@ uninstall-am: uninstall-includeHEADERS u
|
||||
|
||||
.PRECIOUS: Makefile
|
||||
|
||||
-@OS_SOLARIS_TRUE@then
|
||||
@OS_SOLARIS_TRUE@ PTHREADS_CFLAGS = -pthread
|
||||
@OS_AIX_TRUE@@OS_SOLARIS_FALSE@ PTHREADS_CFLAGS = -qthreaded
|
||||
@OS_AIX_FALSE@@OS_SOLARIS_FALSE@ PTHREADS_CFLAGS = -mt
|
|
@ -1,10 +1,10 @@
|
|||
$NetBSD: patch-src_tcp.c,v 1.1 2017/02/13 18:33:24 fhajny Exp $
|
||||
$NetBSD: patch-src_tcp.c,v 1.2 2018/03/23 12:24:32 fhajny Exp $
|
||||
|
||||
Improve portability, fix build on SunOS and BSD.
|
||||
|
||||
--- src/tcp.c.orig 2016-07-07 11:24:53.000000000 +0000
|
||||
--- src/tcp.c.orig 2018-03-21 08:40:38.000000000 +0000
|
||||
+++ src/tcp.c
|
||||
@@ -653,7 +653,7 @@ EnableKeepAlive(const relpTcp_t *__restr
|
||||
@@ -668,7 +668,7 @@ EnableKeepAlive(const relpTcp_t *__restr
|
||||
if(pSrv->iKeepAliveProbes > 0) {
|
||||
optval = pSrv->iKeepAliveProbes;
|
||||
optlen = sizeof(optval);
|
||||
|
@ -13,7 +13,7 @@ Improve portability, fix build on SunOS and BSD.
|
|||
} else {
|
||||
ret = 0;
|
||||
}
|
||||
@@ -669,7 +669,7 @@ EnableKeepAlive(const relpTcp_t *__restr
|
||||
@@ -684,7 +684,7 @@ EnableKeepAlive(const relpTcp_t *__restr
|
||||
if(pSrv->iKeepAliveTime > 0) {
|
||||
optval = pSrv->iKeepAliveTime;
|
||||
optlen = sizeof(optval);
|
||||
|
@ -22,7 +22,7 @@ Improve portability, fix build on SunOS and BSD.
|
|||
} else {
|
||||
ret = 0;
|
||||
}
|
||||
@@ -685,7 +685,7 @@ EnableKeepAlive(const relpTcp_t *__restr
|
||||
@@ -700,7 +700,7 @@ EnableKeepAlive(const relpTcp_t *__restr
|
||||
if(pSrv->iKeepAliveIntvl > 0) {
|
||||
optval = pSrv->iKeepAliveIntvl;
|
||||
optlen = sizeof(optval);
|
||||
|
@ -31,8 +31,8 @@ Improve portability, fix build on SunOS and BSD.
|
|||
} else {
|
||||
ret = 0;
|
||||
}
|
||||
@@ -1548,7 +1548,7 @@ static inline void
|
||||
setCORKopt(int sock, int onOff)
|
||||
@@ -1592,7 +1592,7 @@ static inline void
|
||||
setCORKopt(int sock, const int onOff)
|
||||
{
|
||||
#if defined(TCP_CORK)
|
||||
- setsockopt(sock, SOL_TCP, TCP_CORK, &onOff, sizeof (onOff));
|
||||
|
|
Loading…
Reference in a new issue