Update to 0.8.8. Fix based on pkg/23560, but not all parts were be

used and others were added where needed.

Main NetBSD changes:
- switched from glib1 to glib2.
- added IRSSI_USE_SSL, defaulting to YES, for ssl server support
- make it possible to disable IPv6

v0.8.8 2003-11-23  Timo Sirainen <tss@iki.fi>

	- Just a few fixes to converting old settings automatically

v0.8.7 2003-11-23  Timo Sirainen <tss@iki.fi>

	* Settings changes - we have now "time", "size" and "level" setting
	  types.
	    - Level settings should work the same as before.
	    - Time settings can have units: days, hours, mins, secs,
	      milliseconds (or msecs). The units can be combined and written
	      in shorter form as well, for example "5d 30m 10ms"
	    - Size settings can have units: gbytes, mbytes, kbytes, bytes.
	      They can be written in shorter form as well, eg. "gb" or "g".

	  Your existing settings should be converted automatically.

	+ Pasting detection. All keys except CR and LF are pasted as-is into
	  prompt in pasting mode.

	  /SET paste_detect_time controls how closely each others characters
	  must occur for it to be considered pasting. Paste mode goes on when
	  first pasted CR/LF is found.

	  The first line may also contain some command characters. They are
	  executed, but their action in entry line is reverted once pasting
	  is detected.

	  What this means in practise is that even if you have TABs (assuming
	  TAB is completion key) in the first pasted line, they get pasted as
	  TABs.

	  This detection isn't perfect, so if it annoys you it can be disabled
	  with /SET paste_detect_time 0
	+ If pasting more lines than /SET paste_verify_line_count, irssi asks
	  if you actually want to do that. This should be useful to prevent
	  accidental copy&paste mistakes. Setting it to 0 disables this
	  entirely.
	+ Support for sending SSL certificate to server and optionally verify
	  server's certificate. See the -ssl_* options for /SERVER and
	  /SERVER ADD. Patch by Joel Eriksson.
	+ DCC SERVER support by Mark Trumbull
	+ Support for DCC sending larger files than 2GB if supported by
	  operating system (ie. 64bit file support). Receiving has always
	  been possible, but the statistics were wrong with >4GB files
	  if 64bit support isn't enabled.
	+ Better displaying of DCC file transfer statistics.
	- Several other minor fixes and enhancements, see ChangeLog
This commit is contained in:
veego 2003-12-04 10:43:10 +00:00
parent 98cddaf433
commit a20a57940a
7 changed files with 25 additions and 106 deletions

View file

@ -1,7 +1,6 @@
# $NetBSD: Makefile,v 1.19 2003/05/02 11:54:03 wiz Exp $
# $NetBSD: Makefile,v 1.20 2003/12/04 10:43:10 veego Exp $
DISTNAME= ${IRSSI_DISTNAME}
PKGREVISION= 2
CATEGORIES= chat
MASTER_SITES= http://real.irssi.org/files/
EXTRACT_SUFX= ${IRSSI_EXTRACT_SUFX}
@ -13,14 +12,13 @@ COMMENT= Secure and modular IRC client with text mode user interf
.include "${.CURDIR}/Makefile.common"
# list it into IPv6-ready packages
BUILD_DEFS+= USE_INET6
BUILD_DEFS+= USE_INET6 IRSSI_USE_SSL
GNU_CONFIGURE= yes
USE_BUILDLINK2= yes
USE_PKGINSTALL= yes
CONFIGURE_ARGS+= --with-terminfo \
--enable-ipv6 \
--without-ncurses \
--sysconfdir=${PKG_SYSCONFDIR}
@ -43,9 +41,22 @@ CONFIGURE_ARGS+= --with-perl-lib=site
CONFIGURE_ARGS+= --with-perl=no
.endif
# IPv6 support
.if defined(USE_INET6) && !empty(USE_INET6:M[Yy][Ee][Ss])
CONFIGURE_ARGS+= --enable-ipv6
.endif
# SSL support
.if defined(IRSSI_USE_SSL) && !empty(IRSSI_USE_SSL:M[Yy][Ee][Ss])
. include "../../security/openssl/buildlink2.mk"
.else
CONFIGURE_ARGS+= --disable-ssl
.endif
post-install:
${INSTALL_DATA} ${WRKSRC}/config.h ${IRSSI_CONFIG_H}
${INSTALL_DATA} ${WRKSRC}/irssi-config ${IRSSI_CONFIG}
.include "../../devel/glib/buildlink2.mk"
.include "../../devel/glib2/buildlink2.mk"
.include "../../mk/bsd.pkg.mk"

View file

@ -1,7 +1,7 @@
# $NetBSD: Makefile.common,v 1.1 2002/12/02 12:19:18 jmmv Exp $
# $NetBSD: Makefile.common,v 1.2 2003/12/04 10:43:10 veego Exp $
# Specific distribution information.
IRSSI_VERSION= 0.8.6
IRSSI_VERSION= 0.8.8
IRSSI_DISTNAME= irssi-${IRSSI_VERSION}
IRSSI_EXTRACT_SUFX= .tar.bz2
IRSSI_DISTFILE= ${IRSSI_DISTNAME}${IRSSI_EXTRACT_SUFX}

View file

@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.5 2002/12/02 12:19:19 jmmv Exp $
@comment $NetBSD: PLIST,v 1.6 2003/12/04 10:43:10 veego Exp $
bin/irssi
man/man1/irssi.1
share/doc/irssi/botnet.txt
@ -12,6 +12,7 @@ share/doc/irssi/signals.txt
share/doc/irssi/special_vars.txt
share/doc/irssi/startup-HOWTO.html
share/examples/irssi/irssi.conf
share/irssi/config.h
share/irssi/help/action
share/irssi/help/admin
share/irssi/help/alias
@ -37,6 +38,7 @@ share/irssi/help/disconnect
share/irssi/help/echo
share/irssi/help/eval
share/irssi/help/exec
share/irssi/help/flushbuffers
share/irssi/help/format
share/irssi/help/hash
share/irssi/help/help
@ -51,6 +53,7 @@ share/irssi/help/join
share/irssi/help/kick
share/irssi/help/kickban
share/irssi/help/kill
share/irssi/help/knock
share/irssi/help/knockout
share/irssi/help/lastlog
share/irssi/help/layout
@ -130,7 +133,6 @@ share/irssi/help/whowas
share/irssi/help/window
share/irssi/help/wjoin
share/irssi/help/wquery
share/irssi/config.h
share/irssi/irssi-config
share/irssi/scripts/autoop.pl
share/irssi/scripts/autorejoin.pl

View file

@ -1,9 +1,6 @@
$NetBSD: distinfo,v 1.14 2003/07/05 14:25:51 wiz Exp $
$NetBSD: distinfo,v 1.15 2003/12/04 10:43:10 veego Exp $
SHA1 (irssi-0.8.6.tar.bz2) = 1f7a5b409f71d7b99a30f980d2e7eaa7373a406c
Size (irssi-0.8.6.tar.bz2) = 746551 bytes
SHA1 (irssi-0.8.8.tar.bz2) = f799ae9d09d592725c31e06c14ac7a67ac90dae6
Size (irssi-0.8.8.tar.bz2) = 758641 bytes
SHA1 (patch-aa) = 45d8161733f58ab3733022c823933bb1cc93a8e2
SHA1 (patch-ab) = c395fbeeb2dd15490f04f2cb2c94daf6c5955e85
SHA1 (patch-ac) = 78134bb8e17b397e9de7e5ba3d7fbda76de16506
SHA1 (patch-ad) = 11180ed5f1ebea2f1aa806a001db4c9365f68194
SHA1 (patch-ae) = 43555cce2ed035d824310ce04706ce95b7838205

View file

@ -1,13 +0,0 @@
$NetBSD: patch-ac,v 1.4 2003/07/05 14:25:51 wiz Exp $
--- src/irc/dcc/dcc-send.c.orig Sun Nov 17 17:00:02 2002
+++ src/irc/dcc/dcc-send.c
@@ -400,7 +400,7 @@ static int dcc_send_one_file(int queue,
str = g_strdup_printf(dcc->file_quoted ?
"DCC SEND \"%s\" %s %d %lu" :
"DCC SEND %s %s %d %lu",
- fname, host, port, fsize);
+ dcc->arg, host, port, fsize);
dcc_ctcp_message(server, target, chat, FALSE, str);
g_free(str);

View file

@ -1,66 +0,0 @@
$NetBSD: patch-ad,v 1.4 2003/07/05 14:25:51 wiz Exp $
--- src/core/network.c.orig Mon Aug 26 21:10:02 2002
+++ src/core/network.c
@@ -201,10 +201,13 @@ GIOChannel *net_connect_ip(IPADDR *ip, i
/* set our own address */
if (my_ip != NULL) {
sin_set_ip(&so, my_ip);
- if (bind(handle, &so.sa, SIZEOF_SOCKADDR(so)) == -1) {
+ if (bind(handle, &so.sa, SIZEOF_SOCKADDR(so)) < 0) {
/* failed, set it back to INADDR_ANY */
- sin_set_ip(&so, NULL);
- bind(handle, &so.sa, SIZEOF_SOCKADDR(so));
+ int old_errno = errno;
+
+ close(handle);
+ errno = old_errno;
+ return NULL;
}
}
@@ -466,33 +469,31 @@ int net_gethostbyname(const char *addr,
int net_gethostbyaddr(IPADDR *ip, char **name)
{
#ifdef HAVE_IPV6
- struct addrinfo req, *ai;
+ union sockaddr_union so;
int host_error;
+ char hostname[NI_MAXHOST];
#else
struct hostent *hp;
#endif
- char ipname[MAX_IP_LEN];
g_return_val_if_fail(ip != NULL, -1);
g_return_val_if_fail(name != NULL, -1);
- net_ip2host(ip, ipname);
-
*name = NULL;
#ifdef HAVE_IPV6
- memset(&req, 0, sizeof(struct addrinfo));
- req.ai_socktype = SOCK_STREAM;
- req.ai_flags = AI_CANONNAME;
+ memset(&so, 0, sizeof(so));
+ sin_set_ip(&so, ip);
/* save error to host_error for later use */
- host_error = getaddrinfo(ipname, NULL, &req, &ai);
- if (host_error != 0)
- return host_error;
- *name = g_strdup(ai->ai_canonname);
+ host_error = getnameinfo((struct sockaddr *) &so, sizeof(so),
+ hostname, sizeof(hostname), NULL, 0, 0);
+ if (host_error != 0)
+ return host_error;
- freeaddrinfo(ai);
+ *name = g_strdup(hostname);
#else
- hp = gethostbyaddr(ipname, strlen(ipname), AF_INET);
+ if (ip->family != AF_INET) return -1;
+ hp = gethostbyaddr(&ip->ip, 4, AF_INET);
if (hp == NULL) return -1;
*name = g_strdup(hp->h_name);

View file

@ -1,12 +0,0 @@
$NetBSD: patch-ae,v 1.2 2003/07/05 14:25:52 wiz Exp $
--- src/irc/core/modes.c.orig Thu Oct 31 18:30:03 2002
+++ src/irc/core/modes.c
@@ -512,7 +512,6 @@ void channel_set_mode(IRC_SERVER_REC *se
curmode = cmd_get_param(&modestr);
if (*curmode == '\0')
break;
- continue;
}
if (*curmode == '+' || *curmode == '-') {