Update to 1.8.7. Too many changes to list here.
This update is quite delicate and I'm sure it'll break somewhere. So far I've only been able to test it in NetBSD/amd64 and Mac OS X Leopard. I'm bumping the dependency version in buildlink3.mk because the only package using this seems to be Monotone, and I'll updating it right away.
This commit is contained in:
parent
e5ac769645
commit
a2261658c3
16 changed files with 218 additions and 323 deletions
|
@ -1,31 +1,39 @@
|
|||
# $NetBSD: Makefile,v 1.13 2009/08/25 12:32:56 wiz Exp $
|
||||
# $NetBSD: Makefile,v 1.14 2009/09/23 16:03:25 jmmv Exp $
|
||||
|
||||
DISTNAME= Botan-1.4.11
|
||||
PKGNAME= botan-1.4.11
|
||||
PKGREVISION= 1
|
||||
DISTNAME= Botan-1.8.7
|
||||
PKGNAME= botan-1.8.7
|
||||
CATEGORIES= security
|
||||
MASTER_SITES= http://files.randombit.net/botan/archive/v1.4/
|
||||
MASTER_SITES= http://files.randombit.net/botan/archive/v1.8/
|
||||
EXTRACT_SUFX= .tgz
|
||||
|
||||
MAINTAINER= pkgsrc-users@NetBSD.org
|
||||
HOMEPAGE= http://botan.randombit.net/
|
||||
COMMENT= Portable, easy to use, and efficient C++ crypto library
|
||||
|
||||
USE_TOOLS+= perl
|
||||
PKG_DESTDIR_SUPPORT= user-destdir
|
||||
|
||||
USE_LANGUAGES= c++
|
||||
REPLACE_PERL+= ./configure.pl
|
||||
HAS_CONFIGURE= yes
|
||||
CONFIG_SHELL= perl
|
||||
CONFIGURE_SCRIPT= ./configure.pl
|
||||
HAS_CONFIGURE= yes
|
||||
REPLACE_PYTHON+= configure.pl
|
||||
USE_LANGUAGES= c++
|
||||
|
||||
PYTHON_FOR_BUILD_ONLY= yes
|
||||
|
||||
CONFIG_SHELL= ${PYTHONBIN}
|
||||
CONFIGURE_SCRIPT= ./configure.py
|
||||
CONFIGURE_ARGS+= --prefix=${PREFIX:Q}
|
||||
|
||||
MAKE_FLAGS+= INSTALL_CMD_EXEC=${INSTALL_PROGRAM:Q}
|
||||
MAKE_FLAGS+= INSTALL_CMD_DATA=${INSTALL_DATA:Q}
|
||||
MAKE_FLAGS+= LIB_OPT=${CXXFLAGS:Q}
|
||||
|
||||
CXXFLAGS.DragonFly+= -D_DRAGONFLY_SOURCE
|
||||
CXXFLAGS.NetBSD+= -D_NETBSD_SOURCE
|
||||
BUILDLINK_TRANSFORM+= rm:-mcpu=i686
|
||||
.if ${MACHINE_ARCH} == "amd64"
|
||||
PLIST_SUBST+= AMD64=
|
||||
PLIST_SUBST+= AMD64_OR_IA32=
|
||||
.elif ${MACHINE_ARCH} == "i386"
|
||||
PLIST_SUBST+= AMD64="@comment "
|
||||
PLIST_SUBST+= AMD64_OR_IA32=
|
||||
.else
|
||||
PLIST_SUBST+= AMD64="@comment "
|
||||
PLIST_SUBST+= AMD64_OR_IA32="@comment "
|
||||
.endif
|
||||
|
||||
.include "../../lang/python/application.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
||||
|
|
4
security/botan/PLIST.NetBSD
Normal file
4
security/botan/PLIST.NetBSD
Normal file
|
@ -0,0 +1,4 @@
|
|||
@comment $NetBSD: PLIST.NetBSD,v 1.1 2009/09/23 16:03:25 jmmv Exp $
|
||||
${AMD64_OR_IA32}include/botan/asm_macr.h
|
||||
${AMD64_OR_IA32}include/botan/eng_sse2.h
|
||||
${AMD64_OR_IA32}include/botan/sha1_sse2.h
|
|
@ -1,85 +1,139 @@
|
|||
@comment $NetBSD: PLIST.common,v 1.2 2006/07/21 16:22:36 wiz Exp $
|
||||
@comment $NetBSD: PLIST.common,v 1.3 2009/09/23 16:03:25 jmmv Exp $
|
||||
bin/botan-config
|
||||
include/botan/adler32.h
|
||||
include/botan/aes.h
|
||||
include/botan/algolist.h
|
||||
include/botan/alg_id.h
|
||||
include/botan/algo_cache.h
|
||||
include/botan/algo_factory.h
|
||||
include/botan/allocate.h
|
||||
include/botan/arc4.h
|
||||
include/botan/asn1.h
|
||||
include/botan/asn1_int.h
|
||||
include/botan/asn1_obj.h
|
||||
include/botan/asn1_oid.h
|
||||
include/botan/barrett.h
|
||||
include/botan/base.h
|
||||
include/botan/auto_rng.h
|
||||
include/botan/base64.h
|
||||
include/botan/basefilt.h
|
||||
include/botan/benchmark.h
|
||||
include/botan/ber_dec.h
|
||||
include/botan/bigint.h
|
||||
include/botan/bit_ops.h
|
||||
include/botan/blinding.h
|
||||
include/botan/block_cipher.h
|
||||
include/botan/blowfish.h
|
||||
include/botan/botan.h
|
||||
include/botan/botan.py
|
||||
include/botan/buf_es.h
|
||||
include/botan/bswap.h
|
||||
include/botan/buf_comp.h
|
||||
include/botan/buf_filt.h
|
||||
include/botan/build.h
|
||||
include/botan/cast128.h
|
||||
include/botan/cast256.h
|
||||
include/botan/cbc.h
|
||||
include/botan/cbc_mac.h
|
||||
include/botan/certstor.h
|
||||
include/botan/cfb.h
|
||||
include/botan/charset.h
|
||||
include/botan/cmac.h
|
||||
include/botan/conf.h
|
||||
include/botan/config.h
|
||||
include/botan/cms_dec.h
|
||||
include/botan/cms_enc.h
|
||||
include/botan/crc24.h
|
||||
include/botan/crc32.h
|
||||
include/botan/crl_ent.h
|
||||
include/botan/cryptobox.h
|
||||
include/botan/ctr.h
|
||||
include/botan/cts.h
|
||||
include/botan/curve_gfp.h
|
||||
include/botan/cvc_ado.h
|
||||
include/botan/cvc_ca.h
|
||||
include/botan/cvc_cert.h
|
||||
include/botan/cvc_gen_cert.h
|
||||
include/botan/cvc_key.h
|
||||
include/botan/cvc_req.h
|
||||
include/botan/cvc_self.h
|
||||
include/botan/data_snk.h
|
||||
include/botan/data_src.h
|
||||
include/botan/datastor.h
|
||||
include/botan/def_eng.h
|
||||
include/botan/def_powm.h
|
||||
include/botan/defalloc.h
|
||||
include/botan/der_enc.h
|
||||
include/botan/des.h
|
||||
include/botan/desx.h
|
||||
include/botan/dh.h
|
||||
include/botan/dh_core.h
|
||||
include/botan/dh_op.h
|
||||
include/botan/divide.h
|
||||
include/botan/dl_algo.h
|
||||
include/botan/dl_param.h
|
||||
include/botan/dl_group.h
|
||||
include/botan/dlies.h
|
||||
include/botan/dsa.h
|
||||
include/botan/dsa_core.h
|
||||
include/botan/dsa_op.h
|
||||
include/botan/eac_asn_obj.h
|
||||
include/botan/eac_obj.h
|
||||
include/botan/eax.h
|
||||
include/botan/ec_dompar.h
|
||||
include/botan/ecb.h
|
||||
include/botan/ecc_key.h
|
||||
include/botan/ecdsa.h
|
||||
include/botan/ecdsa_core.h
|
||||
include/botan/ecdsa_op.h
|
||||
include/botan/ecdsa_sig.h
|
||||
include/botan/eckaeg.h
|
||||
include/botan/eckaeg_core.h
|
||||
include/botan/eckaeg_op.h
|
||||
include/botan/elg_core.h
|
||||
include/botan/elg_op.h
|
||||
include/botan/elgamal.h
|
||||
include/botan/eme.h
|
||||
include/botan/eme1.h
|
||||
include/botan/eme_pkcs.h
|
||||
include/botan/emsa.h
|
||||
include/botan/emsa1.h
|
||||
include/botan/emsa1_bsi.h
|
||||
include/botan/emsa2.h
|
||||
include/botan/emsa3.h
|
||||
include/botan/emsa4.h
|
||||
include/botan/emsa_raw.h
|
||||
${AMD64}include/botan/eng_amd64.h
|
||||
include/botan/engine.h
|
||||
include/botan/enums.h
|
||||
include/botan/entropy_src.h
|
||||
include/botan/es_dev.h
|
||||
include/botan/es_egd.h
|
||||
include/botan/es_file.h
|
||||
include/botan/es_unix.h
|
||||
include/botan/exceptn.h
|
||||
include/botan/fd_unix.h
|
||||
include/botan/filter.h
|
||||
include/botan/filters.h
|
||||
include/botan/fips140.h
|
||||
include/botan/fork256.h
|
||||
include/botan/gost.h
|
||||
include/botan/freestore.h
|
||||
include/botan/get_pbe.h
|
||||
include/botan/gfp_element.h
|
||||
include/botan/gfp_modulus.h
|
||||
include/botan/gost_28147.h
|
||||
include/botan/gost_3411.h
|
||||
include/botan/has160.h
|
||||
include/botan/hash.h
|
||||
include/botan/hash_id.h
|
||||
include/botan/haval.h
|
||||
include/botan/hex.h
|
||||
include/botan/hmac.h
|
||||
include/botan/hmac_rng.h
|
||||
include/botan/idea.h
|
||||
include/botan/if_algo.h
|
||||
include/botan/if_core.h
|
||||
include/botan/if_op.h
|
||||
include/botan/init.h
|
||||
include/botan/isaac.h
|
||||
include/botan/kasumi.h
|
||||
include/botan/kdf.h
|
||||
include/botan/kdf1.h
|
||||
include/botan/kdf2.h
|
||||
include/botan/keypair.h
|
||||
include/botan/libstate.h
|
||||
include/botan/lion.h
|
||||
include/botan/look_add.h
|
||||
include/botan/loadstor.h
|
||||
include/botan/look_pk.h
|
||||
include/botan/lookup.h
|
||||
include/botan/lubyrack.h
|
||||
include/botan/mac.h
|
||||
include/botan/mars.h
|
||||
include/botan/md2.h
|
||||
include/botan/md4.h
|
||||
|
@ -90,15 +144,19 @@ include/botan/mem_pool.h
|
|||
include/botan/mgf1.h
|
||||
include/botan/misty1.h
|
||||
include/botan/mmap_mem.h
|
||||
include/botan/mod_exp.h
|
||||
include/botan/mode_pad.h
|
||||
include/botan/modebase.h
|
||||
include/botan/mp_asm.h
|
||||
include/botan/mp_asmi.h
|
||||
include/botan/mp_core.h
|
||||
include/botan/mp_madd.h
|
||||
include/botan/mp_types.h
|
||||
include/botan/mutex.h
|
||||
include/botan/mux_noop.h
|
||||
include/botan/mux_pthr.h
|
||||
include/botan/noekeon.h
|
||||
include/botan/nr.h
|
||||
include/botan/nr_core.h
|
||||
include/botan/nr_op.h
|
||||
include/botan/numthry.h
|
||||
include/botan/ofb.h
|
||||
include/botan/oids.h
|
||||
|
@ -107,20 +165,26 @@ include/botan/out_buf.h
|
|||
include/botan/par_hash.h
|
||||
include/botan/parsing.h
|
||||
include/botan/pbe.h
|
||||
include/botan/pbe_pkcs.h
|
||||
include/botan/pbes1.h
|
||||
include/botan/pbes2.h
|
||||
include/botan/pbkdf1.h
|
||||
include/botan/pbkdf2.h
|
||||
include/botan/pem.h
|
||||
include/botan/pgp_s2k.h
|
||||
include/botan/pipe.h
|
||||
include/botan/pk_algs.h
|
||||
include/botan/pk_core.h
|
||||
include/botan/pk_engine.h
|
||||
include/botan/pk_filts.h
|
||||
include/botan/pk_keys.h
|
||||
include/botan/pk_ops.h
|
||||
include/botan/pk_util.h
|
||||
include/botan/pkcs10.h
|
||||
include/botan/pkcs5.h
|
||||
include/botan/pkcs8.h
|
||||
include/botan/point_gfp.h
|
||||
include/botan/pow_mod.h
|
||||
include/botan/prf_ssl3.h
|
||||
include/botan/prf_tls.h
|
||||
include/botan/prf_x942.h
|
||||
include/botan/pubkey.h
|
||||
include/botan/pubkey_enums.h
|
||||
include/botan/randpool.h
|
||||
include/botan/rc2.h
|
||||
include/botan/rc5.h
|
||||
|
@ -129,24 +193,34 @@ include/botan/reducer.h
|
|||
include/botan/rmd128.h
|
||||
include/botan/rmd160.h
|
||||
include/botan/rng.h
|
||||
include/botan/rotate.h
|
||||
include/botan/rsa.h
|
||||
include/botan/rw.h
|
||||
include/botan/s2k.h
|
||||
include/botan/safer_sk.h
|
||||
include/botan/seal.h
|
||||
include/botan/salsa20.h
|
||||
include/botan/scan_name.h
|
||||
include/botan/secmem.h
|
||||
include/botan/secqueue.h
|
||||
include/botan/seed.h
|
||||
include/botan/selftest.h
|
||||
include/botan/serpent.h
|
||||
include/botan/sha160.h
|
||||
include/botan/sha256.h
|
||||
include/botan/sha_64.h
|
||||
${AMD64}include/botan/sha1_amd64.h
|
||||
include/botan/sha2_32.h
|
||||
include/botan/sha2_64.h
|
||||
include/botan/signed_obj.h
|
||||
include/botan/skein_512.h
|
||||
include/botan/skipjack.h
|
||||
include/botan/square.h
|
||||
include/botan/ssl3_mac.h
|
||||
include/botan/stl_util.h
|
||||
include/botan/stream_cipher.h
|
||||
include/botan/sym_algo.h
|
||||
include/botan/symkey.h
|
||||
include/botan/tea.h
|
||||
include/botan/tiger.h
|
||||
include/botan/timers.h
|
||||
include/botan/timer.h
|
||||
include/botan/tm_hard.h
|
||||
include/botan/tm_unix.h
|
||||
include/botan/turing.h
|
||||
|
@ -160,32 +234,30 @@ include/botan/whrlpool.h
|
|||
include/botan/wid_wake.h
|
||||
include/botan/x509_ca.h
|
||||
include/botan/x509_crl.h
|
||||
include/botan/x509_ext.h
|
||||
include/botan/x509_key.h
|
||||
include/botan/x509_obj.h
|
||||
include/botan/x509cert.h
|
||||
include/botan/x509find.h
|
||||
include/botan/x509self.h
|
||||
include/botan/x509stor.h
|
||||
include/botan/x919_mac.h
|
||||
include/botan/x931_rng.h
|
||||
include/botan/xor_buf.h
|
||||
include/botan/xtea.h
|
||||
lib/libbotan-1.4.11.so
|
||||
lib/libbotan-1.4.so
|
||||
lib/libbotan-1.so
|
||||
include/botan/xts.h
|
||||
lib/libbotan-1.8.2.so
|
||||
lib/libbotan.a
|
||||
lib/libbotan.so
|
||||
share/doc/Botan-1.4.11/api.pdf
|
||||
share/doc/Botan-1.4.11/api.tex
|
||||
share/doc/Botan-1.4.11/authors.txt
|
||||
share/doc/Botan-1.4.11/botan.rc
|
||||
share/doc/Botan-1.4.11/bugs.txt
|
||||
share/doc/Botan-1.4.11/deprecated.txt
|
||||
share/doc/Botan-1.4.11/fips140.pdf
|
||||
share/doc/Botan-1.4.11/fips140.tex
|
||||
share/doc/Botan-1.4.11/license.txt
|
||||
share/doc/Botan-1.4.11/log.txt
|
||||
share/doc/Botan-1.4.11/pgpkeys.asc
|
||||
share/doc/Botan-1.4.11/readme.txt
|
||||
share/doc/Botan-1.4.11/thanks.txt
|
||||
share/doc/Botan-1.4.11/todo.txt
|
||||
share/doc/Botan-1.4.11/tutorial.pdf
|
||||
share/doc/Botan-1.4.11/tutorial.tex
|
||||
lib/pkgconfig/botan-1.8.pc
|
||||
share/doc/Botan-${PKGVERSION}/api.pdf
|
||||
share/doc/Botan-${PKGVERSION}/api.tex
|
||||
share/doc/Botan-${PKGVERSION}/credits.txt
|
||||
share/doc/Botan-${PKGVERSION}/fips140.tex
|
||||
share/doc/Botan-${PKGVERSION}/license.txt
|
||||
share/doc/Botan-${PKGVERSION}/log.txt
|
||||
share/doc/Botan-${PKGVERSION}/pgpkeys.asc
|
||||
share/doc/Botan-${PKGVERSION}/readme.txt
|
||||
share/doc/Botan-${PKGVERSION}/thanks.txt
|
||||
share/doc/Botan-${PKGVERSION}/tutorial.pdf
|
||||
share/doc/Botan-${PKGVERSION}/tutorial.tex
|
||||
|
|
|
@ -1,11 +1,11 @@
|
|||
# $NetBSD: buildlink3.mk,v 1.6 2009/03/20 19:25:16 joerg Exp $
|
||||
# $NetBSD: buildlink3.mk,v 1.7 2009/09/23 16:03:25 jmmv Exp $
|
||||
|
||||
BUILDLINK_TREE+= botan
|
||||
|
||||
.if !defined(BOTAN_BUILDLINK3_MK)
|
||||
BOTAN_BUILDLINK3_MK:=
|
||||
|
||||
BUILDLINK_API_DEPENDS.botan+= botan>=1.4.11
|
||||
BUILDLINK_API_DEPENDS.botan+= botan>=1.8.7
|
||||
BUILDLINK_PKGSRCDIR.botan?= ../../security/botan
|
||||
.endif # BOTAN_BUILDLINK3_MK
|
||||
|
||||
|
|
|
@ -1,16 +1,8 @@
|
|||
$NetBSD: distinfo,v 1.6 2009/03/23 13:16:13 jmmv Exp $
|
||||
$NetBSD: distinfo,v 1.7 2009/09/23 16:03:25 jmmv Exp $
|
||||
|
||||
SHA1 (Botan-1.4.11.tgz) = 49b896fd90e7e80004f7596872238fb40e9748d9
|
||||
RMD160 (Botan-1.4.11.tgz) = c8aa827cf10151266b88e17c172999a6ccaab816
|
||||
Size (Botan-1.4.11.tgz) = 1802089 bytes
|
||||
SHA1 (patch-aa) = 3f5d8bf18c16d1d4dc7a81e821459ee2ee3379f1
|
||||
SHA1 (patch-ab) = 478d91bce78f484fb8ba2d23ceecb462728b29db
|
||||
SHA1 (patch-ac) = 0981448664141b3effaf3e88f5f2317d70ebc786
|
||||
SHA1 (patch-ad) = feff04fc7383bb86df12e187a5788a0b867c47d7
|
||||
SHA1 (patch-ae) = 658808ae00b2a35d649a62578e400e840ab9e0a8
|
||||
SHA1 (patch-af) = 5ed516dd5a746ed94447e880c2f07fc50d8230a8
|
||||
SHA1 (patch-ag) = 8e847a4159ef99d28ec57cf4643d7ecacb8ba353
|
||||
SHA1 (patch-ah) = ff07d2f7b921feb64430351192cc9315452d0687
|
||||
SHA1 (patch-ai) = f7f79ccf61ddbd868a317a63e1d8a377a13ce160
|
||||
SHA1 (patch-aj) = f842e4a39eddd517312a9f7ae57391e330c48a3f
|
||||
SHA1 (patch-ak) = 0944272902558985c4e7ca6f001090596a373b35
|
||||
SHA1 (Botan-1.8.7.tgz) = 69d985f66aa024f0d53c2d5597a4f1a0b9735959
|
||||
RMD160 (Botan-1.8.7.tgz) = 73a6417f1445282e4b2fbf45557f2644b2996563
|
||||
Size (Botan-1.8.7.tgz) = 3464535 bytes
|
||||
SHA1 (patch-ab) = a53a3e23722d8f478c5a6c5ecf1df08d74fd21c0
|
||||
SHA1 (patch-ac) = 4f98ff086983b27ed17d048486a8afced47e7970
|
||||
SHA1 (patch-ak) = 7bf66c1faa84971b490be96efefac0ef44f97b70
|
||||
|
|
|
@ -1,126 +0,0 @@
|
|||
$NetBSD: patch-aa,v 1.4 2009/03/23 13:16:13 jmmv Exp $
|
||||
|
||||
--- configure.pl.orig 2006-01-01 02:02:28.000000000 +0100
|
||||
+++ configure.pl
|
||||
@@ -1,4 +1,4 @@
|
||||
-#!/usr/bin/perl -w
|
||||
+#!/Users/jmmv/Applications/pkg/bin/perl -w
|
||||
|
||||
# Warning: This file is machine-generated; any changes will be lost. Instead,
|
||||
# change mkconfig.pl and the system description files. If you find a bug in
|
||||
@@ -74,7 +74,6 @@ my %DOCS = (
|
||||
'deprecated.txt' => $DOC_DIR,
|
||||
'license.txt' => $DOC_DIR,
|
||||
'log.txt' => $DOC_DIR,
|
||||
- 'rngs.txt' => $DOC_DIR,
|
||||
'thanks.txt' => $DOC_DIR,
|
||||
'todo.txt' => $DOC_DIR
|
||||
);
|
||||
@@ -278,6 +277,7 @@ my %OS_SUPPORTS_ARCH = (
|
||||
'darwin' => [ 'ia32', 'ppc', 'ppc64', ],
|
||||
'freebsd' => [ 'alpha', 'amd64', 'ia32', 'ia64', 'powerpc', 'sparc64',
|
||||
],
|
||||
+ 'dragonfly' => [ 'amd64', 'ia32', 'ia64' ],
|
||||
'hpux' => [ 'hppa', 'ia64', ],
|
||||
'irix' => [ 'mips32', 'mips64', ],
|
||||
'linux' => [ 'alpha', 'amd64', 'arm', 'hppa', 'ia32', 'ia64', 'm68k',
|
||||
@@ -298,6 +298,7 @@ my %OS_SUPPORTS_SHARED = (
|
||||
'beos' => [ 'all', ],
|
||||
'darwin' => [ 'all', ],
|
||||
'freebsd' => [ 'all', ],
|
||||
+ 'dragonfly' => [ 'all', ],
|
||||
'hpux' => [ 'all', ],
|
||||
'irix' => [ 'all', ],
|
||||
'linux' => [ 'all', ],
|
||||
@@ -314,6 +315,7 @@ my %OS_TYPE = (
|
||||
'cygwin' => 'unix',
|
||||
'darwin' => 'unix',
|
||||
'freebsd' => 'unix',
|
||||
+ 'dragonfly' => 'unix',
|
||||
'hpux' => 'unix',
|
||||
'irix' => 'unix',
|
||||
'linux' => 'unix',
|
||||
@@ -372,7 +374,6 @@ my %INSTALL_INFO = (
|
||||
'root' => 'c:\Botan',
|
||||
},
|
||||
'darwin' => {
|
||||
- 'docs' => 'doc',
|
||||
'group' => 'wheel',
|
||||
},
|
||||
'defaults' => {
|
||||
@@ -387,6 +388,9 @@ my %INSTALL_INFO = (
|
||||
'freebsd' => {
|
||||
'group' => 'wheel',
|
||||
},
|
||||
+ 'dragonfly' => {
|
||||
+ 'group' => 'wheel',
|
||||
+ },
|
||||
'netbsd' => {
|
||||
'group' => 'wheel',
|
||||
},
|
||||
@@ -406,7 +410,7 @@ my %CC_SUPPORTS_OS = (
|
||||
'bcc' => [ 'windows', ],
|
||||
'compaq' => [ 'linux', 'tru64', ],
|
||||
'ekopath' => [ 'linux', ],
|
||||
- 'gcc' => [ 'aix', 'beos', 'cygwin', 'darwin', 'freebsd', 'hpux', 'irix',
|
||||
+ 'gcc' => [ 'aix', 'beos', 'cygwin', 'dragonfly', 'darwin', 'freebsd', 'hpux', 'irix',
|
||||
'linux', 'netbsd', 'openbsd', 'qnx', 'solaris', 'tru64',
|
||||
'windows', ],
|
||||
'hpcc' => [ 'hpux', ],
|
||||
@@ -663,6 +667,7 @@ my %CC_ABI_FLAGS = (
|
||||
'gcc' => {
|
||||
'amd64' => '-m64',
|
||||
'freebsd' => '-pthread',
|
||||
+ 'dragonfly' => '-pthread',
|
||||
'mips32' => '-mabi=n32',
|
||||
'mips64' => '-mabi=64',
|
||||
'netbsd' => '-pthread',
|
||||
@@ -772,6 +777,7 @@ my %REALNAME = (
|
||||
'darwin' => 'Darwin / MacOS X',
|
||||
'ekopath' => 'PathScale EKOPath C++',
|
||||
'freebsd' => 'FreeBSD',
|
||||
+ 'dragonfly' => 'DragonFly',
|
||||
'gcc' => 'GNU C++',
|
||||
'hpcc' => 'HP-UX C++',
|
||||
'hppa' => 'HP-PA',
|
||||
@@ -1696,12 +1702,6 @@ sub guess_triple
|
||||
my @CCS = ('gcc', 'icc', 'compaq', 'kai'); # Skips several, oh well...
|
||||
|
||||
# First try the CC enviornmental variable, if it's set
|
||||
- if(defined($ENV{CC}))
|
||||
- {
|
||||
- my @new_CCS = ($ENV{CC});
|
||||
- foreach my $cc (@CCS) { push @new_CCS, $cc; }
|
||||
- @CCS = @new_CCS;
|
||||
- }
|
||||
|
||||
my $cc = '';
|
||||
foreach (@CCS)
|
||||
@@ -2040,8 +2040,12 @@ sub print_unix_makefile {
|
||||
my $link_to = "-lm";
|
||||
foreach my $lib (@{ $lib_list })
|
||||
{
|
||||
+ if ($lib =~ m/pthread/) {
|
||||
+ $link_to .= " -" . $lib;
|
||||
+ } else {
|
||||
$link_to .= " -l" . $lib;
|
||||
}
|
||||
+ }
|
||||
|
||||
##################################################
|
||||
# Generate a few variables #
|
||||
@@ -2279,12 +2283,12 @@ $__TAB__\@for i in \$(HEADERS); do \\
|
||||
$__TAB__ \$(INSTALL_CMD_DATA) \$\$i \$(HEADERDIR); \\
|
||||
$__TAB__ done
|
||||
$__TAB__\@\$(INSTALL_CMD_DATA) \$(STATIC_LIB) \$(LIBDIR)
|
||||
-$__TAB__\@\$(INSTALL_CMD_EXEC) \$(CONFIG_SCRIPT) \$(BINDIR)
|
||||
+$__TAB__\@\${BSD_INSTALL_SCRIPT} \$(CONFIG_SCRIPT) \$(BINDIR)
|
||||
END_OF_INSTALL_SCRIPTS
|
||||
|
||||
if($make_shared) {
|
||||
print $makefile <<END_OF_SYMLINKS;
|
||||
-$__TAB__\@\$(INSTALL_CMD_EXEC) \$(SHARED_LIB) \$(LIBDIR)
|
||||
+$__TAB__\@\${BSD_INSTALL_LIB} \$(SHARED_LIB) \$(LIBDIR)
|
||||
$__TAB__\$(CD) \$(LIBDIR); \$(LN) \$(SYMLINK0) \$(SYMLINK1)
|
||||
$__TAB__\$(CD) \$(LIBDIR); \$(LN) \$(SYMLINK1) \$(SYMLINK2)
|
||||
$__TAB__\$(CD) \$(LIBDIR); \$(LN) \$(SYMLINK2) \$(SYMLINK3)
|
|
@ -1,13 +1,31 @@
|
|||
$NetBSD: patch-ab,v 1.1.1.1 2006/02/05 01:25:12 rillig Exp $
|
||||
$NetBSD: patch-ab,v 1.2 2009/09/23 16:03:25 jmmv Exp $
|
||||
|
||||
--- modules/tm_posix/tm_posix.cpp.orig 2006-01-01 01:02:28.000000000 +0000
|
||||
+++ modules/tm_posix/tm_posix.cpp 2006-02-01 17:27:07.000000000 +0000
|
||||
@@ -9,7 +9,7 @@
|
||||
--- src/build-data/makefile/unix_shr.in.orig 2009-09-10 00:29:34.000000000 +0000
|
||||
+++ src/build-data/makefile/unix_shr.in
|
||||
@@ -20,12 +20,12 @@ SO_VERSION = %{so_version}
|
||||
##################################################
|
||||
# Installation Settings #
|
||||
##################################################
|
||||
-DESTDIR = %{prefix}
|
||||
+PREFIX = $(DESTDIR)%{prefix}
|
||||
|
||||
#include <botan/tm_posix.h>
|
||||
#include <botan/util.h>
|
||||
-#include <time.h>
|
||||
+#include <sys/time.h>
|
||||
-BINDIR = $(DESTDIR)/bin
|
||||
-LIBDIR = $(DESTDIR)/%{libdir}
|
||||
-HEADERDIR = $(DESTDIR)/%{includedir}/botan
|
||||
-DOCDIR = $(DESTDIR)/%{docdir}/Botan-$(VERSION)
|
||||
+BINDIR = $(PREFIX)/bin
|
||||
+LIBDIR = $(PREFIX)/lib
|
||||
+HEADERDIR = $(PREFIX)/include/botan
|
||||
+DOCDIR = $(PREFIX)/share/doc/Botan-$(VERSION)
|
||||
PKGCONF_DIR = $(LIBDIR)/pkgconfig
|
||||
|
||||
#ifndef CLOCK_REALTIME
|
||||
#define CLOCK_REALTIME 0
|
||||
CONFIG_SCRIPT = %{botan_config}
|
||||
@@ -118,7 +118,7 @@ distclean: clean
|
||||
$(RM) Makefile $(CONFIG_SCRIPT) $(PKGCONFIG)
|
||||
|
||||
install: $(LIBRARIES)
|
||||
- $(ECHO) "Installing Botan into $(DESTDIR)... "
|
||||
+ $(ECHO) "Installing Botan into $(PREFIX)... "
|
||||
$(MKDIR_INSTALL) $(DOCDIR)
|
||||
$(MKDIR_INSTALL) $(HEADERDIR)
|
||||
$(MKDIR_INSTALL) $(LIBDIR)
|
||||
|
|
|
@ -1,12 +1,31 @@
|
|||
$NetBSD: patch-ac,v 1.1 2006/03/01 00:33:30 joerg Exp $
|
||||
$NetBSD: patch-ac,v 1.2 2009/09/23 16:03:25 jmmv Exp $
|
||||
|
||||
--- modules/es_egd/es_egd.orig 2006-02-27 01:30:24.000000000 +0000
|
||||
+++ modules/es_egd/es_egd
|
||||
@@ -14,6 +14,7 @@ qnx -> socket
|
||||
aix
|
||||
cygwin
|
||||
darwin
|
||||
+dragonfly
|
||||
freebsd
|
||||
hpux
|
||||
irix
|
||||
--- src/build-data/makefile/unix.in.orig 2009-09-10 00:29:34.000000000 +0000
|
||||
+++ src/build-data/makefile/unix.in
|
||||
@@ -17,12 +17,12 @@ VERSION = %{version}
|
||||
##################################################
|
||||
# Installation Settings #
|
||||
##################################################
|
||||
-DESTDIR = %{prefix}
|
||||
+PREFIX = $(DESTDIR)%{prefix}
|
||||
|
||||
-BINDIR = $(DESTDIR)/bin
|
||||
-LIBDIR = $(DESTDIR)/%{libdir}
|
||||
-HEADERDIR = $(DESTDIR)/%{includedir}/botan
|
||||
-DOCDIR = $(DESTDIR)/%{docdir}/Botan-$(VERSION)
|
||||
+BINDIR = $(PREFIX)/bin
|
||||
+LIBDIR = $(PREFIX)/lib
|
||||
+HEADERDIR = $(PREFIX)/include/botan
|
||||
+DOCDIR = $(PREFIX)/share/doc/Botan-$(VERSION)
|
||||
PKGCONF_DIR = $(LIBDIR)/pkgconfig
|
||||
|
||||
CONFIG_SCRIPT = %{botan_config}
|
||||
@@ -104,7 +104,7 @@ distclean: clean
|
||||
$(RM) Makefile $(CONFIG_SCRIPT) $(PKGCONFIG)
|
||||
|
||||
install: $(LIBRARIES)
|
||||
- $(ECHO) "Installing Botan into $(DESTDIR)... "
|
||||
+ $(ECHO) "Installing Botan into $(PREFIX)... "
|
||||
$(MKDIR_INSTALL) $(DOCDIR)
|
||||
$(MKDIR_INSTALL) $(HEADERDIR)
|
||||
$(MKDIR_INSTALL) $(LIBDIR)
|
||||
|
|
|
@ -1,12 +0,0 @@
|
|||
$NetBSD: patch-ad,v 1.1 2006/03/01 00:33:30 joerg Exp $
|
||||
|
||||
--- modules/es_ftw/es_ftw.orig 2006-02-27 01:30:36.000000000 +0000
|
||||
+++ modules/es_ftw/es_ftw
|
||||
@@ -9,6 +9,7 @@ add_file es_ftw.cpp
|
||||
aix
|
||||
cygwin
|
||||
darwin
|
||||
+dragonfly
|
||||
freebsd
|
||||
hpux
|
||||
irix
|
|
@ -1,12 +0,0 @@
|
|||
$NetBSD: patch-ae,v 1.1 2006/03/01 00:33:30 joerg Exp $
|
||||
|
||||
--- modules/es_unix/es_unix.orig 2006-02-27 01:31:09.000000000 +0000
|
||||
+++ modules/es_unix/es_unix
|
||||
@@ -14,6 +14,7 @@ aix
|
||||
beos
|
||||
cygwin
|
||||
darwin
|
||||
+dragonfly
|
||||
freebsd
|
||||
hpux
|
||||
irix
|
|
@ -1,12 +0,0 @@
|
|||
$NetBSD: patch-af,v 1.1 2006/03/01 00:33:30 joerg Exp $
|
||||
|
||||
--- modules/fd_unix/fd_unix.orig 2006-02-27 01:31:16.000000000 +0000
|
||||
+++ modules/fd_unix/fd_unix
|
||||
@@ -10,6 +10,7 @@ aix
|
||||
beos
|
||||
cygwin
|
||||
darwin
|
||||
+dragonfly
|
||||
freebsd
|
||||
hpux
|
||||
irix
|
|
@ -1,12 +0,0 @@
|
|||
$NetBSD: patch-ag,v 1.1 2006/03/01 00:33:30 joerg Exp $
|
||||
|
||||
--- modules/ml_unix/ml_unix.orig 2006-02-27 01:31:51.000000000 +0000
|
||||
+++ modules/ml_unix/ml_unix
|
||||
@@ -5,6 +5,7 @@ replace_file mlock.cpp
|
||||
<os>
|
||||
aix
|
||||
darwin
|
||||
+dragonfly
|
||||
freebsd
|
||||
hpux
|
||||
irix
|
|
@ -1,20 +0,0 @@
|
|||
$NetBSD: patch-ah,v 1.1 2006/03/01 00:33:30 joerg Exp $
|
||||
|
||||
--- modules/mux_pthr/mux_pthr.orig 2006-02-27 01:32:23.000000000 +0000
|
||||
+++ modules/mux_pthr/mux_pthr
|
||||
@@ -6,13 +6,14 @@ add_file mux_pthr.cpp
|
||||
add_file mux_pthr.h
|
||||
|
||||
<libs>
|
||||
-all!qnx,freebsd,openbsd,netbsd -> pthread
|
||||
+all!qnx,freebsd,openbsd,netbsd,dragonfly -> pthread
|
||||
</libs>
|
||||
|
||||
<os>
|
||||
aix
|
||||
cygwin
|
||||
darwin
|
||||
+dragonfly
|
||||
freebsd
|
||||
hpux
|
||||
irix
|
|
@ -1,12 +0,0 @@
|
|||
$NetBSD: patch-ai,v 1.1 2006/03/01 00:33:30 joerg Exp $
|
||||
|
||||
--- modules/tm_unix/tm_unix.orig 2006-02-27 01:32:48.000000000 +0000
|
||||
+++ modules/tm_unix/tm_unix
|
||||
@@ -10,6 +10,7 @@ aix
|
||||
beos
|
||||
cygwin
|
||||
darwin
|
||||
+dragonfly
|
||||
freebsd
|
||||
hpux
|
||||
irix
|
|
@ -1,12 +0,0 @@
|
|||
$NetBSD: patch-aj,v 1.1 2006/03/01 00:33:30 joerg Exp $
|
||||
|
||||
--- modules/alloc_mmap/alloc_mmap.orig 2006-03-01 00:19:15.000000000 +0000
|
||||
+++ modules/alloc_mmap/alloc_mmap
|
||||
@@ -8,6 +8,7 @@ add_file mmap_mem.h
|
||||
<os>
|
||||
linux
|
||||
freebsd
|
||||
+dragonfly
|
||||
openbsd
|
||||
netbsd
|
||||
solaris
|
|
@ -1,8 +1,8 @@
|
|||
$NetBSD: patch-ak,v 1.1 2007/06/30 18:08:35 joerg Exp $
|
||||
$NetBSD: patch-ak,v 1.2 2009/09/23 16:03:26 jmmv Exp $
|
||||
|
||||
--- modules/tm_hard/tm_hard.orig 2007-06-30 17:42:27.000000000 +0000
|
||||
+++ modules/tm_hard/tm_hard
|
||||
@@ -13,6 +13,7 @@ gcc
|
||||
--- src/timer/cpu_counter/info.txt.orig 2009-09-10 00:29:35.000000000 +0000
|
||||
+++ src/timer/cpu_counter/info.txt
|
||||
@@ -15,6 +15,7 @@ gcc
|
||||
|
||||
<arch>
|
||||
# RDTSC: Pentium and up
|
||||
|
|
Loading…
Reference in a new issue