Update patch to more portable
a patch caused crashes, use suggestions by upstream that makes it more portable
This commit is contained in:
parent
af0af02dad
commit
a240d82112
2 changed files with 11 additions and 7 deletions
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: distinfo,v 1.17 2019/11/11 12:58:53 nros Exp $
|
||||
$NetBSD: distinfo,v 1.18 2019/12/16 18:01:10 nros Exp $
|
||||
|
||||
SHA1 (netsurf-all-3.9.tar.gz) = 392aa7cf94b303228a00e6887c74e5763a81f3a4
|
||||
RMD160 (netsurf-all-3.9.tar.gz) = 3f7aff04cfd253f2b18590830b0aa2fca0123b3c
|
||||
|
@ -6,5 +6,5 @@ SHA512 (netsurf-all-3.9.tar.gz) = 3223b0a3bc9721ea1a5a81bbabdda11e1d0f63850074a5
|
|||
Size (netsurf-all-3.9.tar.gz) = 8416458 bytes
|
||||
SHA1 (patch-netsurf_content_handlers_html_html__interaction.c) = 5dbfbaf26ba8ee32077af5aae0db2ee54cf59eb8
|
||||
SHA1 (patch-netsurf_frontends_gtk_download.c) = 8a449c0b46859be104f2eb87860960f84ebd38ad
|
||||
SHA1 (patch-netsurf_utils_config.h) = 761700b4fd92ea68d8644e3ec2ac270e0e0dd3fc
|
||||
SHA1 (patch-netsurf_utils_config.h) = 0617eb62219eb9d9a570a9857e910c584b68a18b
|
||||
SHA1 (patch-nsgenbind_src_Makefile) = 9024fe193c532fefec83b86a8cf85f1bcffb614e
|
||||
|
|
|
@ -1,22 +1,26 @@
|
|||
$NetBSD: patch-netsurf_utils_config.h,v 1.3 2019/11/11 12:31:16 nros Exp $
|
||||
$NetBSD: patch-netsurf_utils_config.h,v 1.4 2019/12/16 18:01:10 nros Exp $
|
||||
|
||||
NetBSD has strcasestr(3)
|
||||
NetBSD 8 and later has strchrnul(3).
|
||||
Fixed upstream: https://bugs.netsurf-browser.org/mantis/view.php?id=2718
|
||||
|
||||
--- netsurf/utils/config.h.orig 2019-07-17 15:37:00.000000000 +0000
|
||||
+++ netsurf/utils/config.h
|
||||
@@ -21,6 +21,10 @@
|
||||
@@ -21,6 +21,13 @@
|
||||
|
||||
#include <stddef.h>
|
||||
|
||||
+#if defined(__NetBSD__)
|
||||
+#include <sys/param.h>
|
||||
+#if (defined(__NetBSD_Version__) && __NetBSD_Prereq__(8,0,0))
|
||||
+#define NetBSD_v8
|
||||
+#endif
|
||||
+#endif
|
||||
+
|
||||
/* Try to detect which features the target OS supports */
|
||||
|
||||
#if (defined(_GNU_SOURCE) && !defined(__APPLE__) || defined(__amigaos4__) || defined(__HAIKU__) || (defined(_POSIX_C_SOURCE) && ((_POSIX_C_SOURCE - 0) >= 200809L)) && !defined(__riscos__))
|
||||
@@ -30,7 +34,7 @@
|
||||
@@ -30,7 +37,7 @@
|
||||
char *strndup(const char *s, size_t n);
|
||||
#endif
|
||||
|
||||
|
@ -25,12 +29,12 @@ NetBSD 8 and later has strchrnul(3).
|
|||
#define HAVE_STRCASESTR
|
||||
#else
|
||||
#undef HAVE_STRCASESTR
|
||||
@@ -51,7 +55,7 @@ char *strcasestr(const char *haystack, c
|
||||
@@ -51,7 +58,7 @@ char *strcasestr(const char *haystack, c
|
||||
/* For some reason, UnixLib defines this unconditionally. Assume we're using
|
||||
* UnixLib if building for RISC OS.
|
||||
*/
|
||||
-#if ((defined(_GNU_SOURCE) && !defined(__APPLE__)) || defined(__riscos__))
|
||||
+#if ((defined(_GNU_SOURCE) && !defined(__APPLE__)) || defined(__riscos__) || (defined(__NetBSD_Version__) && __NetBSD_Prereq__(8,0,0)))
|
||||
+#if ((defined(_GNU_SOURCE) && !defined(__APPLE__)) || defined(__riscos__) || defined(NetBSD_v8))
|
||||
#define HAVE_STRCHRNUL
|
||||
#else
|
||||
#undef HAVE_STRCHRNUL
|
||||
|
|
Loading…
Reference in a new issue