add libview-0.6.4, a collection of widgets from VMware
(checked for in the gtk-vnc build, but not useful there, so I only add it in the hope that it is of use somewhere else)
This commit is contained in:
parent
7a88d57cd8
commit
a257f97087
6 changed files with 98 additions and 0 deletions
6
devel/libview/DESCR
Normal file
6
devel/libview/DESCR
Normal file
|
@ -0,0 +1,6 @@
|
|||
libview is VMware's Incredibly Exciting Widgets, a useful collection of
|
||||
GTK+ widgets used within VMware products, free for everybody's use.
|
||||
This library consists of several widgets we use in Workstation and other
|
||||
products. We have benefitted so much from open source that we decided to
|
||||
give back. These widgets are under the MIT license and are largely
|
||||
written in C++ for GTKMM.
|
24
devel/libview/Makefile
Normal file
24
devel/libview/Makefile
Normal file
|
@ -0,0 +1,24 @@
|
|||
# $NetBSD: Makefile,v 1.1.1.1 2009/10/26 11:29:45 drochner Exp $
|
||||
#
|
||||
|
||||
DISTNAME= libview-0.6.4
|
||||
CATEGORIES= devel
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=view/}
|
||||
|
||||
MAINTAINER= pkgsrc-users@NetBSD.org
|
||||
HOMEPAGE= http://view.sourceforge.net/
|
||||
COMMENT= GTK+ widget collection
|
||||
LICENSE= modified-bsd
|
||||
|
||||
PKG_DESTDIR_SUPPORT= user-destdir
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
USE_LIBTOOL= yes
|
||||
USE_TOOLS+= pkg-config
|
||||
USE_LANGUAGES= c c++
|
||||
|
||||
PKGCONFIG_OVERRIDE+= libview.pc.in
|
||||
|
||||
.include "../../x11/gtk2/buildlink3.mk"
|
||||
.include "../../x11/gtkmm/buildlink3.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
28
devel/libview/PLIST
Normal file
28
devel/libview/PLIST
Normal file
|
@ -0,0 +1,28 @@
|
|||
@comment $NetBSD: PLIST,v 1.1.1.1 2009/10/26 11:29:45 drochner Exp $
|
||||
include/libview/actionGroup.hh
|
||||
include/libview/autoDrawer.h
|
||||
include/libview/baseBGBox.hh
|
||||
include/libview/contentBox.hh
|
||||
include/libview/deadEntry.hh
|
||||
include/libview/defines.h
|
||||
include/libview/drawer.h
|
||||
include/libview/fieldEntry.hh
|
||||
include/libview/header.hh
|
||||
include/libview/ipEntry.hh
|
||||
include/libview/menuToggleAction.hh
|
||||
include/libview/motionTracker.hh
|
||||
include/libview/ovBox.h
|
||||
include/libview/reparenter.hh
|
||||
include/libview/spinner.hh
|
||||
include/libview/spinnerAction.hh
|
||||
include/libview/toolTip.hh
|
||||
include/libview/uiGroup.hh
|
||||
include/libview/undoableTextView.hh
|
||||
include/libview/utils.hh
|
||||
include/libview/view.hh
|
||||
include/libview/viewport.hh
|
||||
include/libview/weakPtr.hh
|
||||
include/libview/widthHeight.hh
|
||||
include/libview/wrapLabel.hh
|
||||
lib/libview.la
|
||||
lib/pkgconfig/libview.pc
|
15
devel/libview/buildlink3.mk
Normal file
15
devel/libview/buildlink3.mk
Normal file
|
@ -0,0 +1,15 @@
|
|||
# $NetBSD: buildlink3.mk,v 1.1.1.1 2009/10/26 11:29:45 drochner Exp $
|
||||
|
||||
BUILDLINK_TREE+= libview
|
||||
|
||||
.if !defined(LIBVIEW_BUILDLINK3_MK)
|
||||
LIBVIEW_BUILDLINK3_MK:=
|
||||
|
||||
BUILDLINK_API_DEPENDS.libview+= libview>=0.6.4
|
||||
BUILDLINK_PKGSRCDIR.libview?= ../../devel/libview
|
||||
|
||||
.include "../../x11/gtk2/buildlink3.mk"
|
||||
.include "../../x11/gtkmm/buildlink3.mk"
|
||||
.endif # LIBVIEW_BUILDLINK3_MK
|
||||
|
||||
BUILDLINK_TREE+= -libview
|
6
devel/libview/distinfo
Normal file
6
devel/libview/distinfo
Normal file
|
@ -0,0 +1,6 @@
|
|||
$NetBSD: distinfo,v 1.1.1.1 2009/10/26 11:29:45 drochner Exp $
|
||||
|
||||
SHA1 (libview-0.6.4.tar.gz) = a664e5c86453d839d4540189215be94f4ced88d1
|
||||
RMD160 (libview-0.6.4.tar.gz) = d867272ca05d411c1c5c3dc4f2d76491670382f2
|
||||
Size (libview-0.6.4.tar.gz) = 382850 bytes
|
||||
SHA1 (patch-aa) = 65204cd9d27c8b73a3d0ace16ddd36d7f4ad1bc9
|
19
devel/libview/patches/patch-aa
Normal file
19
devel/libview/patches/patch-aa
Normal file
|
@ -0,0 +1,19 @@
|
|||
$NetBSD: patch-aa,v 1.1.1.1 2009/10/26 11:29:45 drochner Exp $
|
||||
|
||||
--- libview.pc.in.orig 2008-11-26 01:31:17.000000000 +0100
|
||||
+++ libview.pc.in
|
||||
@@ -1,9 +1,9 @@
|
||||
-prefix=${prefix}
|
||||
-libdir=${exec_prefix}/lib
|
||||
-includedir=${prefix}/include
|
||||
+prefix=@prefix@
|
||||
+libdir=@prefix@/lib
|
||||
+includedir=@prefix@/include
|
||||
|
||||
Name: libview
|
||||
Description: VMware's Incredibly Exciting Widgets for GTK+
|
||||
Version: @VERSION@
|
||||
-Libs: -L${libdir} -lview @PACKAGE_LIBS@
|
||||
-Cflags: -I${includedir} @PACKAGE_CFLAGS@
|
||||
+Libs: -Wl,-R${libdir} -L${libdir} -lview @VIEW_LIBS@
|
||||
+Cflags: -I${includedir} @VIEW_CFLAGS@
|
Loading…
Reference in a new issue