Provide NULL if it's missing; should fix or advance the dfly build.

This commit is contained in:
dholland 2012-12-24 06:28:16 +00:00
parent 8c9cec3439
commit a25bea462a
2 changed files with 19 additions and 1 deletions

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.2 2012/05/23 06:35:17 dholland Exp $
$NetBSD: distinfo,v 1.3 2012/12/24 06:28:16 dholland Exp $
SHA1 (xu4-1.0beta3.tar.gz) = baf1bbdc18088096ae11ea31aa497532b7e7124c
RMD160 (xu4-1.0beta3.tar.gz) = f758fea4bc3034b19122651cfb725a88e0684960
@ -18,6 +18,7 @@ SHA1 (patch-src_intro.cpp) = 5330d1bedb8e79750468d9463a016b041b7aa496
SHA1 (patch-src_item.cpp) = 667498d2c8fcf4c2c35da0d9189d68c9b6a9baf5
SHA1 (patch-src_lzw_u6decode.cpp) = 1dbf1cb0f24ad9d083f4a7fe666f1503c9647ab6
SHA1 (patch-src_menuitem_cpp) = 400943827ddd59a9cff547765e87b30590569cb2
SHA1 (patch-src_moongate.cpp) = b9edda01c2d405ac94082280a62e8169be66ba85
SHA1 (patch-src_person.cpp) = b93703514429257ae4665ab7242c5dc1ead18c3c
SHA1 (patch-src_savegame.cpp) = 6a0b43d29bd26fd2265953588ae82c950d14e6ba
SHA1 (patch-src_screen.cpp) = bffaf51b9ac63112733d89c0b5e30370a695d45d

View file

@ -0,0 +1,17 @@
$NetBSD: patch-src_moongate.cpp,v 1.1 2012/12/24 06:28:16 dholland Exp $
Provide NULL if it's missing. Apparently Required on Dragonfly.
--- src/moongate.cpp~ 2004-06-01 15:07:45.000000000 +0000
+++ src/moongate.cpp
@@ -11,6 +11,10 @@
#include "moongate.h"
#include "types.h"
+#ifndef NULL
+#define NULL 0
+#endif
+
typedef std::map<int, Coords> MoongateList; /* map moon phase to map coordinates */
MoongateList gates;