Import new "xp" package submitted by Julian Coleman in PR pkg/8197:
A fast X11 text file viewer using Athena widgets
This commit is contained in:
parent
d767e0b773
commit
a2a2e9d839
8 changed files with 97 additions and 0 deletions
11
x11/xp/Makefile
Normal file
11
x11/xp/Makefile
Normal file
|
@ -0,0 +1,11 @@
|
|||
# $NetBSD: Makefile,v 1.1.1.1 1999/08/13 19:35:45 tron Exp $
|
||||
|
||||
DISTNAME= xp-1.2b10
|
||||
CATEGORIES= x11
|
||||
MASTER_SITES= ftp://ftp.ncl.ac.uk/pub/users/ngmt/X11/
|
||||
|
||||
MAINTAINER= j.d.coleman@ncl.ac.uk
|
||||
|
||||
USE_IMAKE= yes
|
||||
|
||||
.include "../../mk/bsd.pkg.mk"
|
3
x11/xp/files/md5
Normal file
3
x11/xp/files/md5
Normal file
|
@ -0,0 +1,3 @@
|
|||
$NetBSD: md5,v 1.1.1.1 1999/08/13 19:35:45 tron Exp $
|
||||
|
||||
MD5 (xp-1.2b10.tar.gz) = 56e018e46e3896cb4cc8e99e1a8ae534
|
4
x11/xp/files/patch-sum
Normal file
4
x11/xp/files/patch-sum
Normal file
|
@ -0,0 +1,4 @@
|
|||
$NetBSD: patch-sum,v 1.1.1.1 1999/08/13 19:35:45 tron Exp $
|
||||
|
||||
MD5 (patch-aa) = 41c33f5f7208571e1856e49518ea9cd3
|
||||
MD5 (patch-ab) = 835aa5d8dbfcee9ec99d36b897cdfc63
|
32
x11/xp/patches/patch-aa
Normal file
32
x11/xp/patches/patch-aa
Normal file
|
@ -0,0 +1,32 @@
|
|||
$NetBSD: patch-aa,v 1.1.1.1 1999/08/13 19:35:45 tron Exp $
|
||||
|
||||
--- Imakefile.orig Thu Feb 11 15:55:09 1999
|
||||
+++ Imakefile Fri Aug 13 21:30:56 1999
|
||||
@@ -1,23 +1,12 @@
|
||||
-/* set MKDIRHIER in case you change BINDIR */
|
||||
-MKDIRHIER = mkdirhier
|
||||
-
|
||||
-XPTOP = /usr/local/xp/1.2b10
|
||||
-
|
||||
-/* where do you want the binary installed */
|
||||
-BINDIR = ${XPTOP}/bin
|
||||
-
|
||||
-/* where do you want the man page installed */
|
||||
-MANDIR = ${XPTOP}/man/man1
|
||||
-
|
||||
-/* where do you want the application defaults file installed */
|
||||
-XAPPLOADDIR = ${XPTOP}/lib/app-defaults
|
||||
-
|
||||
-
|
||||
#ifdef HasVFork
|
||||
VFORK_DEFINES = -DHASVFORK
|
||||
#endif
|
||||
|
||||
#XP_DEFINES= -DNOPUTENV
|
||||
+
|
||||
+#if !(defined(SunArchitecture) && OSMajorVersion == 4)
|
||||
+XP_DEFINES+= -DHAS_STRERROR
|
||||
+#endif
|
||||
|
||||
DEFINES= $(SIGNAL_DEFINES) $(VFORK_DEFINES) $(XP_DEFINES)
|
||||
|
23
x11/xp/patches/patch-ab
Normal file
23
x11/xp/patches/patch-ab
Normal file
|
@ -0,0 +1,23 @@
|
|||
$NetBSD: patch-ab,v 1.1.1.1 1999/08/13 19:35:45 tron Exp $
|
||||
|
||||
--- utils.c.orig Thu Feb 11 13:44:15 1999
|
||||
+++ utils.c Fri Aug 13 21:30:56 1999
|
||||
@@ -1,13 +1,18 @@
|
||||
#include <errno.h>
|
||||
+#include <string.h>
|
||||
#define NULL 0
|
||||
|
||||
|
||||
char *
|
||||
uerror() {
|
||||
+#ifdef HAS_STRERROR
|
||||
+ return strerror(errno);
|
||||
+#else
|
||||
extern int sys_nerr;
|
||||
extern char *sys_errlist[];
|
||||
if (errno > sys_nerr)
|
||||
return NULL;
|
||||
else
|
||||
return sys_errlist[errno];
|
||||
+#endif
|
||||
}
|
1
x11/xp/pkg/COMMENT
Normal file
1
x11/xp/pkg/COMMENT
Normal file
|
@ -0,0 +1 @@
|
|||
A fast X11 text file viewer using Athena widgets
|
18
x11/xp/pkg/DESCR
Normal file
18
x11/xp/pkg/DESCR
Normal file
|
@ -0,0 +1,18 @@
|
|||
Release 2.0 of xp
|
||||
|
||||
xp started as a filter to simply display stdin in an Athena text
|
||||
widget. It grew to be a more general file displayer with an emphasis
|
||||
on ease of browsing and searching, but I've tried to keep its interface
|
||||
(and implementation) simple and make it useful in shell scripts.
|
||||
|
||||
xp tries to be reasonably efficient in use of memory when displaying
|
||||
large files, given that the text widgets requires the whole file to be
|
||||
in memory, by using a read-only text widget and freeing memory when a
|
||||
file is no longer displayed (so if you go back to a previously
|
||||
displayed file it gets re-opened).
|
||||
|
||||
xp incorporates Henry Spencer's implementation of egrep style regular
|
||||
expression matching. The xp distribution includes that part of the
|
||||
regexp distribution which it requires.
|
||||
|
||||
gerry.tomlinson@ncl.ac.uk November 1995
|
5
x11/xp/pkg/PLIST
Normal file
5
x11/xp/pkg/PLIST
Normal file
|
@ -0,0 +1,5 @@
|
|||
@comment $NetBSD: PLIST,v 1.1.1.1 1999/08/13 19:35:45 tron Exp $
|
||||
bin/xp
|
||||
bin/xpman
|
||||
lib/X11/app-defaults/Xp
|
||||
man/cat1/xp.0
|
Loading…
Reference in a new issue