Consistently set PTHREAD_LIB, esp. for the nspr test it was not defined

at the time of use. Fixes SSL detection on DragonFly. Problem noted by
walt <wa1ter@myrealbox.com> on DragonFly's submit list.
This commit is contained in:
joerg 2006-09-11 09:33:33 +00:00
parent 269fc2a610
commit a2aec03d21
3 changed files with 35 additions and 8 deletions

View file

@ -1,7 +1,8 @@
# $NetBSD: Makefile,v 1.45 2006/08/05 17:42:10 wiz Exp $
# $NetBSD: Makefile,v 1.46 2006/09/11 09:33:33 joerg Exp $
#
DISTNAME= evolution-data-server-1.6.3
PKGREVISION= 1
CATEGORIES= mail gnome
MASTER_SITES= ${MASTER_SITE_GNOME:=sources/evolution-data-server/1.6/}
EXTRACT_SUFX= .tar.bz2
@ -25,6 +26,8 @@ PKG_SUPPORTED_OPTIONS= inet6
.include "../../mk/bsd.prefs.mk"
CONFIGURE_ENV+= PTHREAD_LIB="${PTHREAD_LDFLAGS} ${PTHREAD_LIBS}"
.if ${OPSYS} == "NetBSD" && !empty(OS_VERSION:M1.6.2)
.include "../../devel/pthread-sem/buildlink3.mk"
LIBS+= -lsemaphore

View file

@ -1,9 +1,9 @@
$NetBSD: distinfo,v 1.28 2006/08/05 17:42:10 wiz Exp $
$NetBSD: distinfo,v 1.29 2006/09/11 09:33:33 joerg Exp $
SHA1 (evolution-data-server-1.6.3.tar.bz2) = ae23b1d87375b92dddc9fd3ce02b4a28c5f3cf17
RMD160 (evolution-data-server-1.6.3.tar.bz2) = 4bb4296c04b14a3e2c326bf37b5afb065128be63
Size (evolution-data-server-1.6.3.tar.bz2) = 7047514 bytes
SHA1 (patch-af) = 1e458720684cfe3823b3b73665044336588c4620
SHA1 (patch-ak) = 1bacbcae9d35817c65ad1be478369c0a08f2e463
SHA1 (patch-ak) = f8ae411b9ea2536f5ccbb35a2e215d89997c3ea9
SHA1 (patch-al) = 97d5c7889b886535a7cc63c00b6193130f6fa320
SHA1 (patch-ao) = c98089bab9110eb29339e529fb88b01dbe454623

View file

@ -1,10 +1,8 @@
$NetBSD: patch-ak,v 1.4 2006/06/11 15:05:39 wiz Exp $
$NetBSD: patch-ak,v 1.5 2006/09/11 09:33:33 joerg Exp $
Needed to have a NULL macro in the program that follows these includes.
--- configure.orig 2006-05-29 13:25:13.000000000 +0000
--- configure.orig 2006-07-31 15:37:06.000000000 +0000
+++ configure
@@ -26341,6 +26341,7 @@ cat >>conftest.$ac_ext <<_ACEOF
@@ -26342,6 +26342,7 @@ cat >>conftest.$ac_ext <<_ACEOF
#include <sys/socket.h>
#include <netinet/in.h>
#include <netdb.h>
@ -12,3 +10,29 @@ Needed to have a NULL macro in the program that follows these includes.
int
@@ -28447,13 +28448,13 @@ EVO_MARSHAL_RULE=$srcdir/marshal.mk
PTHREAD_LIB=""
- echo "$as_me:$LINENO: checking for pthread_create in -lpthread" >&5
-echo $ECHO_N "checking for pthread_create in -lpthread... $ECHO_C" >&6
+ echo "$as_me:$LINENO: checking for pthread_create in ${PTHREAD_LIB}" >&5
+echo $ECHO_N "checking for pthread_create in ${PTHREAD_LIB}... $ECHO_C" >&6
if test "${ac_cv_lib_pthread_pthread_create+set}" = set; then
echo $ECHO_N "(cached) $ECHO_C" >&6
else
ac_check_lib_save_LIBS=$LIBS
-LIBS="-lpthread $LIBS"
+LIBS="${PTHREAD_LIB} $LIBS"
cat >conftest.$ac_ext <<_ACEOF
/* confdefs.h. */
_ACEOF
@@ -28512,7 +28513,7 @@ fi
echo "$as_me:$LINENO: result: $ac_cv_lib_pthread_pthread_create" >&5
echo "${ECHO_T}$ac_cv_lib_pthread_pthread_create" >&6
if test $ac_cv_lib_pthread_pthread_create = yes; then
- PTHREAD_LIB="-lpthread"
+ PTHREAD_LIB="${PTHREAD_LIB}"
else
echo "$as_me:$LINENO: checking for pthread_create in -lpthreads" >&5
echo $ECHO_N "checking for pthread_create in -lpthreads... $ECHO_C" >&6