gnuplot: updated to 5.4.5
Changes in 5.4.5 NEW "set key offset <dx>, <dy>" tweaks placement of the key NEW data-driven histogram colors (variable color from extra using column) CHANGE re-order drawing 3D labels to come after pm3d depthorder surfaces CHANGE hpgl: add terminal option "fontscale <value>" CHANGE for nonuniform matrix data, column(0) returns linear position in matrix CHANGE set pointintervalbox 0 disables drawing the background box Bug FIX svg: hypertext font handling FIX track columnheaders of multiple data blocks in a single file Bug FIX Clean up positioning of polar border, raxis, and theta tics Bug FIX Autoscaling of logscaled raxis FIX memory corruption if a small plot structure is recycled Bug FIX regression in 5.4.4 - promotion of string to integer should not assume that a leading 0 means octal Bug FIX Windows qt: "pause -1" should not block mousing Bug FIX invalid free of active datablock
This commit is contained in:
parent
2cf4551ced
commit
a31e9ee4a0
4 changed files with 17 additions and 87 deletions
|
@ -1,13 +1,12 @@
|
|||
# $NetBSD: Makefile,v 1.162 2022/09/11 12:51:51 wiz Exp $
|
||||
# $NetBSD: Makefile,v 1.163 2022/10/21 12:28:07 adam Exp $
|
||||
|
||||
DISTNAME= gnuplot-5.4.2
|
||||
DISTNAME= gnuplot-5.4.5
|
||||
CATEGORIES+= graphics
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=gnuplot/}
|
||||
|
||||
MAINTAINER= pkgsrc-users@NetBSD.org
|
||||
HOMEPAGE= http://gnuplot.info/
|
||||
COMMENT= Portable interactive, function plotting utility
|
||||
PKGREVISION= 5
|
||||
#LICENSE= gnuplot + BSD
|
||||
|
||||
API_VERSION= ${PKGVERSION_NOREV:C/([0-9])\.([0-9])\.([0-9])/\1.\2/}
|
||||
|
|
|
@ -1,9 +1,9 @@
|
|||
$NetBSD: distinfo,v 1.48 2021/12/15 17:16:43 adam Exp $
|
||||
$NetBSD: distinfo,v 1.49 2022/10/21 12:28:07 adam Exp $
|
||||
|
||||
BLAKE2s (gnuplot-5.4.2.tar.gz) = ced54ffcac9f9061ff760124b3e757f3d9dcdb4501693f6a2ad1e8c3eeb44cf5
|
||||
SHA512 (gnuplot-5.4.2.tar.gz) = e69ca74335cdd69c6013a254ac785dc67cc82713308460971cf6e0a66438716d8892a37344611d1841563efbc4b2b8c5692c13c7b06cff4f30f8d43e2ddfd7d4
|
||||
Size (gnuplot-5.4.2.tar.gz) = 5640202 bytes
|
||||
SHA1 (patch-configure) = 6d932d286804deaae03a167d1c080ee2b1628ee4
|
||||
BLAKE2s (gnuplot-5.4.5.tar.gz) = ee478eb51ac5e232979c21527ffd0f37c2b0ec844595400037601ebae5add9d5
|
||||
SHA512 (gnuplot-5.4.5.tar.gz) = dbd0b338c5662304566fc0d790c8f53db071d7c486e7422f6ba4b7a9e0d8e50db756ab37dade9bdc01ed1a1ca6fe4e63749038c0ceec95b78bf8b92a0ae2dd20
|
||||
Size (gnuplot-5.4.5.tar.gz) = 5643171 bytes
|
||||
SHA1 (patch-configure) = 51813d74dc2be0e6fcc2e55fcbcbcf2b4678b954
|
||||
SHA1 (patch-src_gp__hist.h) = b1549572ba1bacad5ae76e7a5a6b632e693b74a7
|
||||
SHA1 (patch-src_plot.c) = a91ef7ff92917c54e37f3cca765e92d9857a47a5
|
||||
SHA1 (patch-src_readline.h) = ae138bb783a5a5e68f89850cdd861cc545399aaf
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
# $NetBSD: options.mk,v 1.18 2020/11/20 17:25:02 prlw1 Exp $
|
||||
# $NetBSD: options.mk,v 1.19 2022/10/21 12:28:07 adam Exp $
|
||||
|
||||
PKG_OPTIONS_VAR= PKG_OPTIONS.gnuplot
|
||||
PKG_SUPPORTED_OPTIONS= cairo cerf gd gnuplot-pdf-doc lua qt5 wxwidgets x11
|
||||
|
@ -75,7 +75,7 @@ CONFIGURE_ARGS+= --with-qt=no
|
|||
.if !empty(PKG_OPTIONS:Mwxwidgets)
|
||||
USE_LANGUAGES+= c++
|
||||
CONFIGURE_ARGS+= --enable-wxwidgets
|
||||
.include "../../x11/wxGTK30/buildlink3.mk"
|
||||
.include "../../x11/wxGTK31/buildlink3.mk"
|
||||
.else
|
||||
CONFIGURE_ARGS+= --disable-wxwidgets
|
||||
.endif
|
||||
|
|
|
@ -1,84 +1,15 @@
|
|||
$NetBSD: patch-configure,v 1.3 2020/12/01 09:33:17 prlw1 Exp $
|
||||
$NetBSD: patch-configure,v 1.4 2022/10/21 12:28:07 adam Exp $
|
||||
|
||||
NetBSD editline keeps header files in "readline", not "editline".
|
||||
Same applies to DragonFly.
|
||||
Portability fix.
|
||||
|
||||
Also get rid of a non-portable "test ... ==" instances.
|
||||
|
||||
--- configure.orig 2020-11-27 00:12:02.000000000 +0000
|
||||
--- configure.orig 2022-10-21 08:14:12.000000000 +0000
|
||||
+++ configure
|
||||
@@ -8977,7 +8977,7 @@ $as_echo "yes" >&6; }
|
||||
|
||||
@@ -10144,7 +10144,7 @@ printf "%s\n" "yes" >&6; }
|
||||
# Check whether --with-aquaterm was given.
|
||||
if test "${with_aquaterm+set}" = set; then :
|
||||
if test ${with_aquaterm+y}
|
||||
then :
|
||||
- withval=$with_aquaterm; if test "$withval" == yes; then
|
||||
+ withval=$with_aquaterm; if test "$withval" = yes; then
|
||||
|
||||
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for AquaTerm framework presence" >&5
|
||||
$as_echo_n "checking for AquaTerm framework presence... " >&6; }
|
||||
@@ -10193,9 +10193,9 @@ fi
|
||||
|
||||
$as_echo "#define HAVE_LIBEDITLINE 1" >>confdefs.h
|
||||
|
||||
- for ac_header in editline/readline.h
|
||||
+ for ac_header in readline/readline.h
|
||||
do :
|
||||
- ac_fn_c_check_header_mongrel "$LINENO" "editline/readline.h" "ac_cv_header_editline_readline_h" "$ac_includes_default"
|
||||
+ ac_fn_c_check_header_mongrel "$LINENO" "readline/readline.h" "ac_cv_header_editline_readline_h" "$ac_includes_default"
|
||||
if test "x$ac_cv_header_editline_readline_h" = xyes; then :
|
||||
cat >>confdefs.h <<_ACEOF
|
||||
#define HAVE_EDITLINE_READLINE_H 1
|
||||
@@ -10979,7 +10979,7 @@ $as_echo "no" >&6; }
|
||||
fi
|
||||
|
||||
|
||||
- if test $pkg_failed == no && test -n "$GDLIB_CONFIG"; then
|
||||
+ if test $pkg_failed = no && test -n "$GDLIB_CONFIG"; then
|
||||
libgd_CPPFLAGS=`$GDLIB_CONFIG --cflags`
|
||||
libgd_LDFLAGS=`$GDLIB_CONFIG --ldflags`
|
||||
libgd_LIBS=`$GDLIB_CONFIG --libs`
|
||||
@@ -16584,7 +16586,7 @@ $as_echo " pict2e, pslatex, pstex, ps
|
||||
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: " >&5
|
||||
$as_echo "" >&6; }
|
||||
|
||||
-if test "$with_bitmap_terminals" == yes; then
|
||||
+if test "$with_bitmap_terminals" = yes; then
|
||||
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: dot-matrix terminals: yes ( --without-bitmap-terminals to disable)" >&5
|
||||
$as_echo " dot-matrix terminals: yes ( --without-bitmap-terminals to disable)" >&6; }
|
||||
else
|
||||
@@ -16598,7 +16600,7 @@ $as_echo " hp500c, hpdj, hpljii, hppj
|
||||
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: " >&5
|
||||
$as_echo "" >&6; }
|
||||
|
||||
-if test "$with_tektronix" == no; then
|
||||
+if test "$with_tektronix" = no; then
|
||||
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: tektronix terminal emulators: no ( --with-tektronix to enable)" >&5
|
||||
$as_echo " tektronix terminal emulators: no ( --with-tektronix to enable)" >&6; }
|
||||
else
|
||||
@@ -16628,7 +16630,7 @@ else
|
||||
$as_echo " ggi terminal: no (use --with-ggi to enable, requires libggi)" >&6; }
|
||||
fi
|
||||
|
||||
-if test "$with_gpic" == yes; then
|
||||
+if test "$with_gpic" = yes; then
|
||||
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: gpic terminal: yes" >&5
|
||||
$as_echo " gpic terminal: yes" >&6; }
|
||||
else
|
||||
@@ -16636,7 +16638,7 @@ else
|
||||
$as_echo " gpic terminal: no (use --with-gpic to enable)" >&6; }
|
||||
fi
|
||||
|
||||
-if test "$with_tgif" == yes; then
|
||||
+if test "$with_tgif" = yes; then
|
||||
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: tgif terminal: yes" >&5
|
||||
$as_echo " tgif terminal: yes" >&6; }
|
||||
else
|
||||
@@ -16644,7 +16646,7 @@ else
|
||||
$as_echo " tgif terminal: no (use --with-tgif to enable)" >&6; }
|
||||
fi
|
||||
|
||||
-if test "$with_mif" == yes; then
|
||||
+if test "$with_mif" = yes; then
|
||||
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: mif terminal (FrameMaker 3): yes" >&5
|
||||
$as_echo " mif terminal (FrameMaker 3): yes" >&6; }
|
||||
else
|
||||
{ printf "%s\n" "$as_me:${as_lineno-$LINENO}: checking for AquaTerm framework presence" >&5
|
||||
printf %s "checking for AquaTerm framework presence... " >&6; }
|
||||
|
|
Loading…
Reference in a new issue