pc-lisp: Fix build with Clang 7svn

Address invalid casts between types.
This commit is contained in:
kamil 2018-09-29 21:19:13 +00:00
parent 9872b5b5d0
commit a34c447463
2 changed files with 27 additions and 4 deletions

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.1 2018/02/03 20:26:31 kamil Exp $
$NetBSD: distinfo,v 1.2 2018/09/29 21:19:13 kamil Exp $
SHA1 (PC-LISP/master-2b50414e258a3916bf19d1b354f4c4e647eb7bb8.zip) = b5cda3214fbf41673d26f25defc0db3095d9e538
RMD160 (PC-LISP/master-2b50414e258a3916bf19d1b354f4c4e647eb7bb8.zip) = 9da45864097aa2d5de2f18630a267584bfba826a
@ -6,6 +6,6 @@ SHA512 (PC-LISP/master-2b50414e258a3916bf19d1b354f4c4e647eb7bb8.zip) = 4aec599bc
Size (PC-LISP/master-2b50414e258a3916bf19d1b354f4c4e647eb7bb8.zip) = 1011041 bytes
SHA1 (patch-src_Makefile) = 3f388dbff31fad82c9813fb7b3bb5888d118d480
SHA1 (patch-src_buselect.c) = eeae7661fd5a8d3b4f0a68f38dc50471902ae444
SHA1 (patch-src_busopen.c) = bf44bf31a9653c86b8616b6d6901dbbbe7c71298
SHA1 (patch-src_busopen.c) = 35894a8485ce34b5bb7d603d1575d364d0ea7162
SHA1 (patch-src_bustrfnd.c) = f2dc238e8d52d9731d685caa88b1218d1ec49706
SHA1 (patch-src_lisp.h) = 623ab2b3897aaa8f6a99843ff14574a6ede19297

View file

@ -1,4 +1,4 @@
$NetBSD: patch-src_busopen.c,v 1.1 2018/02/03 20:26:31 kamil Exp $
$NetBSD: patch-src_busopen.c,v 1.2 2018/09/29 21:19:13 kamil Exp $
Port to NetBSD.
@ -89,7 +89,16 @@ Port to NetBSD.
/*
| Must reset errno to see if I/O routines triggered an error.
@@ -311,9 +314,9 @@ int busopenP(op)
@@ -279,7 +282,7 @@ int busopenP(op)
fd_port = op;
if (fd_listen) { fclose(fd_listen); fd_listen = NULL; }
if (fd_talk) { fclose(fd_talk); fd_talk = NULL; }
- fd_listen = sopen(fd_addr, fd_port, -2, NULL); /* open but don't wait for accept, set SIGIO tell us */
+ fd_listen = sopen(fd_addr.s_addr, fd_port, -2, NULL); /* open but don't wait for accept, set SIGIO tell us */
Dprintf(("\n\n*** busopenP reopen fd_listen = %x errno = %d ***\n", fd_listen, errno));
return(fd_listen == NULL); /* return 0 for success -1 for failure */
}
@@ -311,13 +314,13 @@ int busopenP(op)
Dprintf(("\tbusopenP accepting fd_listen & opening fd_talk\n"));
if (fdwait(fdl, 0, 10) == 1) { /* if activity on socket try to accept */
struct sockaddr_in client;
@ -101,6 +110,20 @@ Port to NetBSD.
Dprintf(("\tbusopenP connection accepted\n"));
fclose(fd_listen); /* got accept don't need listner socket now so close it down */
fd_listen = NULL; /* and clear FILE * so we do not enter this code on next liio(-1) */
- if (addrok(client.sin_addr.s_addr, fd_addr)) { /* if client address matches mask */
+ if (addrok(client.sin_addr.s_addr, fd_addr.s_addr)) { /* if client address matches mask */
fdasync(fdt); /* set up so that on I/O event send signal SIGIO */
fd_talk = fdopen(fdt, "r+"); /* and open a FILE * equivalent to this talk file fd */
} else
@@ -423,7 +426,7 @@ int busopenP(op)
if ((fd_talk == NULL) && (fd_listen == NULL)) {
int i;
for(i = 0; i < 30; i++) {
- fd_listen = sopen(fd_addr, fd_port, -2, NULL); /* open but don't wait for accept, let SIGIO tell us */
+ fd_listen = sopen(fd_addr.s_addr, fd_port, -2, NULL); /* open but don't wait for accept, let SIGIO tell us */
Dprintf(("\n\n*** busopenP reopen fd_listen = %x errno = %d ***\n", fd_listen, errno));
if (fd_listen != NULL) break; /* if opened ok the break out of retry loop */
sleep(1); /* sleep for one second then retry */
@@ -446,7 +449,7 @@ struct conscell *buREPsopen(form)
struct conscell *form;
{