Update to version 1.47.01. Changes since 1.47d include:

- New program Iget to retrieve documents by docid
- Fixed spurious output from Isearch -t option
- Fixed score calculation for Boolean searches
- Added -l parameter to zpresent to accept docids from a file
- Fixed a bad return state that caused a segfault when no files were
  found to index.
- Added improved entity replacement code to STRING class (J. Tyler)
- Improved algorithm for generating URL from path in EOS_GUIDE doctype
- Added hook for VIDB KeyLookup method
- Initial release of zpresent
- Fixed bug in EOS_GUIDE doctype which caused searches to sometimes fail
- Modified zpresent.dtd to stick the source field in the individual
  result elements, rather than on the container results element.
- Added method Result::GetVKey for virtual databases so you can tell
  which constituent they came from.  It's an egregious hack which just
  stuffs the database number at the front of the key so it can be
  included in the output from zsearch and parsed by zpresent.
- Rearranged some of the XML presentation for the FGDC doctype Summary
  element set
- Added a path->URL translation to EOS_GUIDE doctype to facilitate links
  back to original (crawled) source documents
- Cleaned XML text of characters which should be entities
- Added zsearch program for XML search output
- Added initial version of NASA EOS/Guide doctype
- Removed some extraneous output from vidb.cxx
- Added CIPC doctype for NASA/CIP Collection metadata
- Added delimiter to Isearch output (J. Millard)
- Improved XML results presentation in FGDC doctype
This commit is contained in:
jtb 2002-05-03 22:36:08 +00:00
parent d9b8d85ce1
commit a34d49dfce
4 changed files with 37 additions and 21 deletions

View file

@ -1,7 +1,7 @@
# $NetBSD: Makefile,v 1.3 2001/05/03 22:23:56 jtb Exp $
# $NetBSD: Makefile,v 1.4 2002/05/03 22:36:08 jtb Exp $
DISTNAME= Isearch-1.47d
PKGNAME= isearch-1.47d
DISTNAME= Isearch-1.47.01
PKGNAME= isearch-1.47.01
CATEGORIES= textproc databases
MASTER_SITES= http://www.etymon.com/pub/Isearch/

View file

@ -1,7 +1,10 @@
@comment $NetBSD: PLIST,v 1.1 2001/10/31 22:56:57 zuntum Exp $
@comment $NetBSD: PLIST,v 1.2 2002/05/03 22:36:08 jtb Exp $
bin/Iindex
bin/Isearch
bin/Iutil
bin/Iget
bin/zsearch
bin/zpresent
share/doc/html/isearch/Isearch-cgi-tutorial.html
share/doc/html/isearch/IsearchFeatures.html
share/doc/html/isearch/IsearchTutorial.html

View file

@ -1,5 +1,5 @@
$NetBSD: distinfo,v 1.2 2001/04/20 15:04:58 skrll Exp $
$NetBSD: distinfo,v 1.3 2002/05/03 22:36:08 jtb Exp $
SHA1 (Isearch-1.47d.tar.gz) = eda30cd52bc0d125d0856ee89a13c55db1bacc00
Size (Isearch-1.47d.tar.gz) = 456600 bytes
SHA1 (patch-aa) = c28ec93dbefeae47299bda6a53d6fdbb3ddb2577
SHA1 (Isearch-1.47.01.tar.gz) = 86761d6055fdd7b954b7ac9d9fd3d0084d758e3f
Size (Isearch-1.47.01.tar.gz) = 484760 bytes
SHA1 (patch-aa) = 5c8291a92f84cc47131e45586879cf986e6a5c4d

View file

@ -1,8 +1,14 @@
$NetBSD: patch-aa,v 1.1.1.1 2001/02/06 22:09:27 jtb Exp $
$NetBSD: patch-aa,v 1.2 2002/05/03 22:36:09 jtb Exp $
--- Makefile.orig Mon Apr 29 11:36:52 2002
+++ Makefile Mon Apr 29 11:42:53 2002
@@ -18,14 +18,14 @@
# zsearch - XML command line searching utility
# zpresent - XML command line document retrieval utility
#
-SHELL=/bin/sh
+SHELL=$(SH)
--- Makefile.orig Tue Feb 6 20:52:49 2001
+++ Makefile
@@ -20,9 +20,9 @@
#
# Compiler
#
@ -14,13 +20,14 @@ $NetBSD: patch-aa,v 1.1.1.1 2001/02/06 22:09:27 jtb Exp $
#CC=/sw/CenterLine/bin/CC
#
@@ -36,13 +36,13 @@
@@ -39,13 +39,13 @@
#
# for Solaris, SunOS, Ultrix, OSF
#
-#CFLAGS=-O2 -DUNIX -DMULTI
-#CFLAGS=-O2 -DUNIX
+#CFLAGS= -O2 -DUNIX -DMULTI
+CFLAGS+= -DUNIX
#CFLAGS=-O2 -DUNIX
#
# for Linux
@ -30,36 +37,42 @@ $NetBSD: patch-aa,v 1.1.1.1 2001/02/06 22:09:27 jtb Exp $
#CFLAGS=-g -fwritable-strings -Wall -Wno-unused -DUNIX # -DVERBOSE -DDEBUG
#
@@ -73,8 +73,8 @@
@@ -76,8 +76,8 @@
#
# Where should I install executables (make install)?
#
-INSTALL=/usr/local/bin
-CGI_INSTALL=/home/httpd/cgi-bin
+INSTALL=${PREFIX}/bin
+CGI_INSTALL=${PREFIX}/libexec/cgi-bin
+INSTALL=$(PREFIX)/bin
+CGI_INSTALL=$(PREFIX)/libexec/cgi-bin
#
# Executables Directory
@@ -113,7 +113,7 @@
@@ -116,7 +116,7 @@
#
RM = rm -f
-LDFLAGS=
+#LDFLAGS=
VER=1.47d
VER=1.47.01
#DIST=Isearch-$(VER)
DIST=Isearch
@@ -186,9 +186,9 @@
@@ -189,12 +189,12 @@
install:
@echo "*** Copying Isearch executables to $(INSTALL) ***"
- cp $(BIN_DIR)/Iindex $(INSTALL)
- cp $(BIN_DIR)/Isearch $(INSTALL)
- cp $(BIN_DIR)/Iutil $(INSTALL)
- cp $(BIN_DIR)/Iget $(INSTALL)
- cp $(BIN_DIR)/zsearch $(INSTALL)
- cp $(BIN_DIR)/zpresent $(INSTALL)
+ $(BSD_INSTALL_PROGRAM) $(BIN_DIR)/Iindex $(INSTALL)
+ $(BSD_INSTALL_PROGRAM) $(BIN_DIR)/Isearch $(INSTALL)
+ $(BSD_INSTALL_PROGRAM) $(BIN_DIR)/Iutil $(INSTALL)
+ $(BSD_INSTALL_PROGRAM) $(BIN_DIR)/Iget $(INSTALL)
+ $(BSD_INSTALL_PROGRAM) $(BIN_DIR)/zsearch $(INSTALL)
+ $(BSD_INSTALL_PROGRAM) $(BIN_DIR)/zpresent $(INSTALL)
@echo ""
@echo "To install Isearch-cgi, cd into the Isearch-cgi directory"
@echo "Then run the configure script"