Changes 1.8.5:

* AI:
  * Fixed bug 16406: Fixed broken AI of SoF 1, and improved upgrade procedure
    for old-style AI config.
  * Fixed bug 16585: made AI move in targeting phase even if for some of the
    'best' units moves to targets are impossible
* Campaigns:
  * Descent into Darkness:
    * Made 'Alone at Last' easier.
  * Legend of Wesmere:
    * Added another keep in scenario 14.
* Editor:
  * Added a standard click sound for brush bar buttons (bug 15635)
* Graphics
  * Updated portraits for Drake Fighter and Burner
* Language and i18n:
  * Updates fonts: DejaVu 2.32
  * Updated translations: Chinese (Simplified), Chinese (Traditional), Czech,
    Dutch, Estonian, French, Galician, German, Hungarian, Indonesian, Japanese,
    Lithuanian, Polish, Russian, Serbian, Slovak, Vietnamese
* User interface:
  * Fixed bug 16653: Avoid markup when calculating the text length for
    ellipse text (Debian bug 547476).
  * Fix bug 15960 "again", making "Cancel" a separate action and not just
    a duplicate of "OK."
  * Fix crash when doing teleport+attack to a fogged village
This commit is contained in:
adam 2011-02-24 13:36:56 +00:00
parent e410c6e040
commit a390321e68
7 changed files with 74 additions and 127 deletions

View file

@ -1,7 +1,6 @@
# $NetBSD: Makefile,v 1.63 2011/01/13 13:37:53 wiz Exp $
# $NetBSD: Makefile,v 1.64 2011/02/24 13:36:56 adam Exp $
DISTNAME= wesnoth-1.8.4
PKGREVISION= 2
DISTNAME= wesnoth-1.8.5
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=wesnoth/}
EXTRACT_SUFX= .tar.bz2

View file

@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.32 2010/08/28 20:08:40 adam Exp $
@comment $NetBSD: PLIST,v 1.33 2011/02/24 13:36:56 adam Exp $
@pkgdir var/run/wesnothd
bin/wesnoth
bin/wesnothd
@ -20,6 +20,8 @@ man/gl/man6/wesnoth.6
man/gl/man6/wesnothd.6
man/hu/man6/wesnoth.6
man/hu/man6/wesnothd.6
man/id/man6/wesnoth.6
man/id/man6/wesnothd.6
man/it/man6/wesnoth.6
man/it/man6/wesnothd.6
man/ja/man6/wesnoth.6

View file

@ -1,10 +1,11 @@
$NetBSD: distinfo,v 1.41 2010/08/30 19:29:25 adam Exp $
$NetBSD: distinfo,v 1.42 2011/02/24 13:36:56 adam Exp $
SHA1 (wesnoth-1.8.4.tar.bz2) = 30b82e06523f9a82b770a6fc4e2d4251bd358eca
RMD160 (wesnoth-1.8.4.tar.bz2) = 86b6f6ca39cf87134d89e989ed20840836aeac28
Size (wesnoth-1.8.4.tar.bz2) = 300557790 bytes
SHA1 (patch-aa) = 363dead4e4a6974db5a2d71a460e60404cc1246a
SHA1 (wesnoth-1.8.5.tar.bz2) = 22c6cc10dc7172daf636158dba0acac35f538597
RMD160 (wesnoth-1.8.5.tar.bz2) = c2a6a9f094b862ef274838fd062c5d961f97c261
Size (wesnoth-1.8.5.tar.bz2) = 301024033 bytes
SHA1 (patch-aa) = 17ffae20b02ccdaed6f465c988d330e4890df76c
SHA1 (patch-ac) = 41d23e2103fd3c3e0f085b0164e9f29bcb8d024c
SHA1 (patch-ae) = 9e0ee531c33da80565791d81f716b313fa85af18
SHA1 (patch-af) = d3554b1c164ff95ee2b86c17990ed236f0e00c32
SHA1 (patch-ag) = 9a843d4fa2f011b69ee140dceaac3d56d1fe44f9
SHA1 (patch-ah) = ca06ab21724812290c4f4785cfbd42d3406202fb
SHA1 (patch-ag) = 624f54980f894af0ad98f4a83ada344bf51dbc77
SHA1 (patch-ah) = 6fd2cc1de4929704bb770dcabe1f32f9257529a1

View file

@ -1,8 +1,22 @@
$NetBSD: patch-aa,v 1.13 2010/08/28 20:08:40 adam Exp $
$NetBSD: patch-aa,v 1.14 2011/02/24 13:36:57 adam Exp $
--- configure.ac.orig 2010-08-28 17:03:00.000000000 +0000
Do not check compiler version. Clang impersonates GCC and might get caught.
Do not treat warnings as errors.
--- configure.ac.orig 2010-09-24 17:37:41.000000000 +0000
+++ configure.ac
@@ -111,7 +111,7 @@ then
@@ -64,10 +64,6 @@ parts=`echo $GCC_VERSION | tr '.' ' '`
set $parts
GCC_MAJOR_VERSION=$1
GCC_MINOR_VERSION=$2
-if test ${GCC_MAJOR_VERSION}${GCC_MINOR_VERSION} -lt 33
-then
- AC_MSG_ERROR([*** G++ major version $GCC_VERSION is too old.])
-fi
#######################################################################
# Configuration options #
@@ -111,7 +107,7 @@ then
# CFLAGS="-Werror -Wno-unused -Wno-sign-compare $CFLAGS"
# The current networking code breaks strict aliasing in g++ 4.5.

View file

@ -0,0 +1,14 @@
$NetBSD: patch-ac,v 1.14 2011/02/24 13:36:57 adam Exp $
Fix C++ error.
--- src/gui/auxiliary/event/dispatcher_private.hpp.orig 2011-02-24 12:38:36.000000000 +0000
+++ src/gui/auxiliary/event/dispatcher_private.hpp
@@ -319,7 +319,6 @@ struct find<false>
// MSVC 2008 doesn't like operator() here so changed the name.
return functor.template oper<item>(event);
} else {
- typedef typename boost::mpl::next<itor>::type itor;
return find<boost::is_same<itor, end>::value>
::execute((itor*)0, (end*)0, event, functor);
}

View file

@ -1,107 +1,15 @@
$NetBSD: patch-ag,v 1.7 2010/08/30 19:29:26 adam Exp $
$NetBSD: patch-ag,v 1.8 2011/02/24 13:36:57 adam Exp $
On MacOSX use Pasteboard Manager instead of deprecated Scrap Manager.
For details, see http://gna.org/bugs/?16576
Fix C++ error.
--- src/clipboard.cpp.orig 2010-02-06 10:50:29.000000000 +0000
+++ src/clipboard.cpp
@@ -26,6 +26,8 @@
--- src/ai/composite/aspect.hpp.orig 2011-02-24 12:25:20.000000000 +0000
+++ src/ai/composite/aspect.hpp
@@ -282,7 +282,7 @@ public:
boost::function2<void, typename aspect_type<T>::typesafe_ptr_vector&, const config&> factory_facets =
boost::bind(&ai::composite_aspect<T>::create_facet,*this,_1,_2);
#include "SDL_syswm.h"
- register_vector_property("facet",facets_, factory_facets);
+ this->register_vector_property("facet",facets_, factory_facets);
+#include <unistd.h>
+
/**
The following are two classes which wrap the SDL's interface to X,
including locking/unlocking, and which manage the atom internment.
@@ -483,7 +485,7 @@ void copy_to_clipboard(const std::string
{
std::string new_str;
new_str.reserve(text.size());
- for (int i = 0; i < text.size(); ++i)
+ for (unsigned int i = 0; i < text.size(); ++i)
{
if (text[i] == '\n')
{
@@ -493,33 +495,64 @@ void copy_to_clipboard(const std::string
}
}
OSStatus err = noErr;
- ScrapRef scrap = kScrapRefNone;
- err = ClearCurrentScrap();
+ PasteboardRef clipboard;
+ PasteboardSyncFlags syncFlags;
+ CFDataRef textData = NULL;
+ err = PasteboardCreate(kPasteboardClipboard, &clipboard);
if (err != noErr) return;
- err = GetCurrentScrap(&scrap);
+ err = PasteboardClear(clipboard);
if (err != noErr) return;
- PutScrapFlavor(scrap, kScrapFlavorTypeText, kScrapFlavorMaskNone, text.size(), new_str.c_str());
+ syncFlags = PasteboardSynchronize(clipboard);
+ if ((syncFlags&kPasteboardModified) && !(syncFlags&kPasteboardClientIsOwner)) return;
+ textData = CFDataCreate(kCFAllocatorDefault, (const UInt8 *)new_str.c_str(), text.size());
+ PasteboardPutItemFlavor(clipboard, (PasteboardItemID)1, CFSTR("public.utf8-plain-text"), textData, 0);
}
std::string copy_from_clipboard(const bool)
{
- ScrapRef curscrap = kScrapRefNone;
- Size scrapsize = 0;
OSStatus err = noErr;
- err = GetCurrentScrap(&curscrap);
- if (err != noErr) return "";
- err = GetScrapFlavorSize(curscrap, kScrapFlavorTypeText, &scrapsize);
+ PasteboardRef clipboard;
+ PasteboardSyncFlags syncFlags;
+ ItemCount count;
+ err = PasteboardCreate(kPasteboardClipboard, &clipboard);
if (err != noErr) return "";
- std::string str;
- str.reserve(scrapsize);
- str.resize(scrapsize);
- err = GetScrapFlavorData(curscrap, kScrapFlavorTypeText, &scrapsize, const_cast<char*>(str.data()));
+ syncFlags = PasteboardSynchronize(clipboard);
+ if (syncFlags&kPasteboardModified) return "";
+ err = PasteboardGetItemCount(clipboard, &count);
if (err != noErr) return "";
- for (int i = 0; i < str.size(); ++i)
- {
- if (str[i] == '\r') str[i] = '\n';
+ for (UInt32 k = 1; k <= count; k++) {
+ PasteboardItemID itemID;
+ CFArrayRef flavorTypeArray;
+ CFIndex flavorCount;
+ err = PasteboardGetItemIdentifier(clipboard, k, &itemID);
+ if (err != noErr) return "";
+ err = PasteboardCopyItemFlavors(clipboard, itemID, &flavorTypeArray);
+ if (err != noErr) return "";
+ flavorCount = CFArrayGetCount(flavorTypeArray);
+ for (CFIndex j = 0; j < flavorCount; j++) {
+ CFStringRef flavorType;
+ CFDataRef flavorData;
+ CFIndex flavorDataSize;
+ flavorType = (CFStringRef)CFArrayGetValueAtIndex(flavorTypeArray, j);
+ if (UTTypeConformsTo(flavorType, CFSTR("public.utf8-plain-text"))) {
+ err = PasteboardCopyItemFlavorData(clipboard, itemID, flavorType, &flavorData);
+ if (err != noErr) {
+ CFRelease(flavorTypeArray);
+ return "";
+ }
+ flavorDataSize = CFDataGetLength(flavorData);
+ std::string str;
+ str.reserve(flavorDataSize);
+ str.resize(flavorDataSize);
+ CFDataGetBytes(flavorData, CFRangeMake(0, flavorDataSize), (UInt8 *)str.data());
+ for (unsigned int i = 0; i < str.size(); ++i) {
+ if (str[i] == '\r') str[i] = '\n';
+ }
+ return str;
+ }
+ }
}
- return str;
+ return "";
}
void handle_system_event(const SDL_Event& event)

View file

@ -1,13 +1,22 @@
$NetBSD: patch-ah,v 1.1 2010/08/28 20:08:40 adam Exp $
$NetBSD: patch-ah,v 1.2 2011/02/24 13:36:57 adam Exp $
--- m4/boost.m4.orig 2010-05-27 07:42:52.000000000 +0000
+++ m4/boost.m4
@@ -463,7 +463,7 @@ AC_DEFUN([BOOST_GRAPH],
AC_DEFUN([BOOST_IOSTREAMS],
[BOOST_FIND_LIB([iostreams], [$1],
[boost/iostreams/device/file_descriptor.hpp],
- [boost::iostreams::file_descriptor fd(0); fd.close();])
+ [boost::iostreams::file_descriptor fd("/dev/null"); fd.close();])
])# BOOST_IOSTREAMS
Fix C++ error.
--- src/controller_base.cpp.orig 2011-02-24 12:28:03.000000000 +0000
+++ src/controller_base.cpp
@@ -54,6 +54,7 @@ void controller_base::handle_event(const
if(gui::in_dialog()) {
return;
}
+ SDL_Event new_event;
switch(event.type) {
case SDL_KEYDOWN:
@@ -71,7 +72,6 @@ void controller_base::handle_event(const
break;
case SDL_MOUSEMOTION:
// Ignore old mouse motion events in the event queue
- SDL_Event new_event;
if(SDL_PeepEvents(&new_event,1,SDL_GETEVENT,
SDL_EVENTMASK(SDL_MOUSEMOTION)) > 0) {
while(SDL_PeepEvents(&new_event,1,SDL_GETEVENT,