Update to version 1.1.1.
While here add PKGMANDIR support. Changes since last packaged version (1.0.1): Version 1.1.1 - 11 November 2005 -------------------------------- - Bug fix; minor memory leak. - Bug fix; on some systems, failure resulted while disconnecting from all the servers, during the shutdown phase just before exiting. Version 1.1 - 24 August 2005 ---------------------------- - Addition of the list() and lsub() commands, that make it possible to get a list of the available mailboxes or only of those that are subscribed. Implementation of the IMAP LIST/LSUB commands, with additional support for the IMAP CHILDREN (RFC 3348) and IMAP NAMESPACE (RFC 2342) extensions. - New program option to execute a string from the command line, without loading a configuration file. - New program option to enter interactive mode after executing the configuration file or the command line. - Servers that reply with multiple SEARCH responses are taken into consideration. - Bug fix; failure to parse the response to fetchfast() that some mail servers sent. - Bug fix; in some systems and when in debug mode, an empty namespace caused program fault.
This commit is contained in:
parent
93dbd27ee6
commit
a3b9424f92
3 changed files with 17 additions and 16 deletions
|
@ -1,7 +1,6 @@
|
|||
# $NetBSD: Makefile,v 1.19 2005/12/27 13:54:58 seb Exp $
|
||||
# $NetBSD: Makefile,v 1.20 2006/01/15 14:28:07 seb Exp $
|
||||
|
||||
DISTNAME= imapfilter-1.0.1
|
||||
PKGREVISION= 2
|
||||
DISTNAME= imapfilter-1.1.1
|
||||
CATEGORIES= mail
|
||||
MASTER_SITES= http://imapfilter.hellug.gr/source/
|
||||
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
$NetBSD: distinfo,v 1.11 2005/02/24 09:59:23 agc Exp $
|
||||
$NetBSD: distinfo,v 1.12 2006/01/15 14:28:07 seb Exp $
|
||||
|
||||
SHA1 (imapfilter-1.0.1.tar.gz) = 23e8eb11d574e9438c7c8260ad90005d9ebfd499
|
||||
RMD160 (imapfilter-1.0.1.tar.gz) = 9ae98fbece54b87aee11cfab2ddf116e1107a296
|
||||
Size (imapfilter-1.0.1.tar.gz) = 33139 bytes
|
||||
SHA1 (patch-aa) = b592fe42ede943dafda19b9ef2282b0804419e5b
|
||||
SHA1 (imapfilter-1.1.1.tar.gz) = f62aed8ed9aaf7018a3587e35d80557480fea73a
|
||||
RMD160 (imapfilter-1.1.1.tar.gz) = a0d09b42e5b81db7c38fe8d8e6fbc80c5bfe0933
|
||||
Size (imapfilter-1.1.1.tar.gz) = 36234 bytes
|
||||
SHA1 (patch-aa) = 6cf4fcd70cb115b0333659a39ffdea902a381c9f
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
$NetBSD: patch-aa,v 1.5 2004/05/23 20:52:09 seb Exp $
|
||||
$NetBSD: patch-aa,v 1.6 2006/01/15 14:28:07 seb Exp $
|
||||
|
||||
--- Makefile.orig 2004-05-22 23:31:09.000000000 +0000
|
||||
--- Makefile.orig 2005-11-10 23:21:55.000000000 +0000
|
||||
+++ Makefile
|
||||
@@ -1,18 +1,11 @@
|
||||
-DESTDIR = /usr/local
|
||||
|
@ -16,13 +16,13 @@ $NetBSD: patch-aa,v 1.5 2004/05/23 20:52:09 seb Exp $
|
|||
+DESTDIR = $(PREFIX)
|
||||
+BINDIR = $(PREFIX)/bin
|
||||
+SHAREDIR = $(PREFIX)/share/imapfilter
|
||||
+MANDIR = $(PREFIX)/man
|
||||
+MANDIR = $(PREFIX)/$(PKGMANDIR)
|
||||
|
||||
DEFS = -DMAKEFILE_SHAREDIR='"$(SHAREDIR)"'
|
||||
|
||||
-CFLAGS = $(MYCFLAGS) $(DEFS) $(INCDIRS)
|
||||
-LDFLAGS = $(MYLDFLAGS) $(LIBDIRS)
|
||||
+CFLAGS+= $(DEFS)
|
||||
+CFLAGS+= $(DEFS)
|
||||
|
||||
LIBS = -lm -llua -llualib -lssl -lcrypto
|
||||
|
||||
|
@ -34,8 +34,8 @@ $NetBSD: patch-aa,v 1.5 2004/05/23 20:52:09 seb Exp $
|
|||
+ $(CC) -o $(BIN) $(LDFLAGS) $(CFLAGS) $(OBJ) $(LIBS)
|
||||
|
||||
$(OBJ): imapfilter.h
|
||||
buffer.o imap.o imapfilter.o request.o response.o: buffer.h
|
||||
@@ -41,17 +34,15 @@ auth.o cert.o imap.o imapfilter.o log.o
|
||||
buffer.o imap.o imapfilter.o namespace.o request.o response.o: buffer.h
|
||||
@@ -42,19 +35,15 @@ auth.o cert.o imap.o imapfilter.o log.o
|
||||
imapfilter.o: version.h
|
||||
|
||||
install: $(BIN)
|
||||
|
@ -47,9 +47,11 @@ $NetBSD: patch-aa,v 1.5 2004/05/23 20:52:09 seb Exp $
|
|||
- cp -f $(AUXILIARY_LUA) $(SHAREDIR) && \
|
||||
- chmod 0644 $(SHAREDIR)/$(AUXILIARY_LUA)
|
||||
- if test ! -d $(MANDIR)/man1; then mkdir -p $(MANDIR)/man1; fi
|
||||
- cp -f $(MAN_BIN) $(MANDIR)/man1 && chmod 0644 $(MANDIR)/man1/$(MAN_BIN)
|
||||
- cp -f $(MAN_BIN) $(MANDIR)/man1 && \
|
||||
- chmod 0644 $(MANDIR)/man1/$(MAN_BIN)
|
||||
- if test ! -d $(MANDIR)/man5; then mkdir -p $(MANDIR)/man5; fi
|
||||
- cp -f $(MAN_CONFIG) $(MANDIR)/man5 && chmod 0644 $(MANDIR)/man5/$(MAN_CONFIG)
|
||||
- cp -f $(MAN_CONFIG) $(MANDIR)/man5 && \
|
||||
- chmod 0644 $(MANDIR)/man5/$(MAN_CONFIG)
|
||||
+ $(BSD_INSTALL_PROGRAM_DIR) $(BINDIR)
|
||||
+ $(BSD_INSTALL_PROGRAM) $(BIN) $(BINDIR)/$(BIN)
|
||||
+ $(BSD_INSTALL_DATA_DIR) $(SHAREDIR)
|
||||
|
|
Loading…
Reference in a new issue