Update to 1.13.3:

Changes in version 1.13.3, released on March 13, 2015

    --- MAJOR NEW FEATURES ---
 * When a manual is missing from an outdated database, let man(1)
   show it anyway, using a KISS file system lookup as a fallback.
 * Use this to always provide man(1), even without database support.
 * Fatal errors no longer exist.  If a file can be opened, mandoc
   will produce some output; at worst, the output may be almost empty.
 * New -Wunsupp message level.
    --- POTENTIONALLY SECURITY RELEVANT BUGFIXES ---
 * Fix a potential write buffer overrun on incomplete string conditionals.
   http://mdocml.bsd.lv/cgi-bin/cvsweb/roff.c#rev1.241
 * Fix a potential write buffer overrun on backslash at EOF in a conditional.
   http://mdocml.bsd.lv/cgi-bin/cvsweb/roff.c#rev1.247
 * Fix a use after free sometimes hit when validation deletes a block.
   http://mdocml.bsd.lv/cgi-bin/cvsweb/mdoc_macro.c#rev1.180
    --- MAJOR FUNCTIONALLY RELEVANT BUGFIXES ---
 * Let man(1) show manuals for the current architecture by default,
   and support the MACHINE environment variable.
 * Fix the man(1) and apropos(1) -m option, it didn't work at all.
 * Do not spawn a pager when there is no output.
 * In makewhatis(8), fix detection of hardlinked manuals on platforms
   having padding in struct inodev (typically 64bit platforms).
    --- PORTABILITY IMPROVEMENTS ---
 * Ignore O_CLOEXEC when the operating system doesn't provide it.
 * Avoid forward reference to enum type which violates ISO C99.
 * Support homebrew-style linking on Mac OS X.
    --- MINOR NEW FEATURES ---
 * lookup: Accept digit+letter and "n" as section names in man(1),
   and consistently handle digit+letter in file name extensions.
 * lookup: Speed up -s/-S by using the "mlinks" rather than the "keys" table.
 * output: Insert horizontal lines between formatted manual pages.
 * input: New stricter and more resilient UTF-8 parser.
 * mdoc(7): Refactor block rewinding for simpler and more robust parsing.
 * man(7): Use the -Ios option when .TH has less than four arguments.
 * tbl(7): Implement the "center" option.
 * tbl(7): New option and format parsers, improved in many respects.
 * roff(7): Basic implementation of the \o escape sequence (overstrike),
   and improved rendering of overstrikes in PostScript and PDF output.
 * Message improvements, in particular for, but not restricted to,
   eqn(7), tbl(7), and wrong numbers of arguments in mdoc(7) and man(7),
   in various cases also improving output generated by invalid input.
 * Delete the -V option.  It serves no purpose but keeps confusing people.
 * gmdiff: Minimal support for Heirloom roff.
    --- RELIABILITY BUGFIXES ---
 * tbl(7): Fix a read buffer overrun on 'f' at EOL in a layout.
 * roff(7): Fix a read buffer overrun on incomplete numerical conditions.
 * mdoc(7): Fix a NULL pointer access on .Nd followed by an explicit block.
 * mdoc(7): Fix a NULL pointer access on .It Xo without .Xc.
 * mdoc(7): Fix a NULL pointer access on .Eo without a tail.
 * mdoc(7): Fix a NULL pointer access in the validation of empty .St macros.
 * man(7)/tbl(7): Fix a NULL pointer access on .TS right after .TP.
 * tbl(7): Fix a NULL pointer access on layout lines without any cells.
 * eqn(7): Fix NULL pointer accesses in the terminal formatter.
 * roff(7): Fix a NULL pointer access on trailing \s-/\s+ without an argument.
 * gz: Fix a potential NULL pointer access after waitpid() failure.
 * roff(7): Don't let the modulo operator divide by zero.
 * input: Fix an assertion failure on certain invalid UTF-8 input.
 * terminal output: Allow arbitrary depth of the font stack (assertion fix).
 * mdoc(7): Fix assertion failures and endless loops on invalid block closing.
 * mdoc(7): Fix an assertion failure on .Bl .Sm not followed by .It.
 * mdoc(7): Fix an assertion failure on .Bl -column ... .El .Ta.
 * tbl(7): Fix assertion failures by macros inside table data,
   but do not throw away the macro arguments.
 * Prevent certain kinds of unreasonable input from producing excessive
   output, in one case caused by unsigned integer underflow.
 * Fix a potential memory leak in makewhatis(8) on very long filenames.
    --- MINOR BUGFIXES ---
 * mdoc(7): Fix parsing of badly nested blocks with multiple identical blocks.
 * mdoc(7): Support negative indentations for displays and lists.
 * mdoc(7): Don't mistreat negative .sp arguments as large positive ones.
 * mdoc(7): Some spacing fixes for .Eo/.Ec.
 * man(7): Support negative horizontal widths.
 * man(7): Do not print out invalid .IP arguments.
 * man(7): Correctly handle scaling units after .PD.
 * man(7): Support .RE with an argument.
 * man(7): Fix restoring indentation after .RS with large negative arguments.
 * tbl(7): Prevent tables from breaking the filling of preceding text.
 * tbl(7): Fix vertical spacing at the beginning of tables.
 * tbl(7): Parser and formatter fixes for line drawing and font modifiers.
 * tbl(7): Correct handling of blank data lines.
 * eqn(7): Add sometimes missing whitespace before equation output.
 * roff(7): Fix vertical scaling, most of it was wrong.
 * roff(7): Slightly improve \w width measurements.
 * roff(7): Accept the historic aliases \s10 to \s39 for \s(10 to \s(39.
 * roff(7): Correctly escape quotes when expanding macro arguments.
 * roff(7): Correctly handle scaling units in numerical expressions,
   and some other improvements to the parsing of numerical expressions.
 * roff(7): Three minor fixes with respect to evaluation of conditionals.
 * roff(7): Let .it accept numerical expressions, not just constants.
 * mandoc_char(7): Correct some character names and renderings.
 * If earlier files set a non-zero exit status, never reset it to zero.
    --- THANKS TO ---
 * Jonathan Gray (OpenBSD) for yet more testing with afl (the American
   Fuzzy Lop security fuzzer), again resulting in many bug reports.
 * Theo de Raadt (OpenBSD) for suggesting the main new feature (man(1) file
   system lookup) and for reporting an important bug (pager without output).
 * Theo Buehler for an important bug report (-s/-S slowness)
   and for proposing a nice new feature (lines between pages).
 * Jason McIntyre for an important bug report (hardlink detection)
   and multiple documentation patches.
 * Pascal Stumpf (OpenBSD) and Alessandro de Laurenzis for
   important bug reports (architecture and man -m, respectively).
 * Thomas Klausner (NetBSD) for proposing a new feature (man(7) -Ios),
   a bug report, and release testing.
 * Anthony Bentley, Daniel Dickman, Ted Unangst (OpenBSD) and
   Kristaps Dzonsons (bsd.lv) for source code patches and bug reports.
 * Christian Weisgerber (OpenBSD) for more than half a dozen bug reports.
 * Carsten Kunze (Heirloom troff) for bug reports and release testing.
 * Antoine Jacoutot (OpenBSD) for release testing.
 * Alexis Hildebrandt (Homebrew), Baptiste Daroussin (FreeBSD),
   Jonathan Perkin (SmartOS), Pedro Giffuni (FreeBSD), Svyatoslav
   Mishyn (Crux Linux), Ulrich Spoerlein (FreeBSD), Jan Stary, Patrick
   Keshishian, Sebastien Marie, and Steffen Nurpmeso for bug reports.
This commit is contained in:
wiz 2015-03-14 10:24:38 +00:00
parent 0b13cbda14
commit a40db14535
4 changed files with 16 additions and 33 deletions

View file

@ -1,6 +1,6 @@
# $NetBSD: Makefile,v 1.47 2014/12/23 02:30:32 obache Exp $
# $NetBSD: Makefile,v 1.48 2015/03/14 10:24:38 wiz Exp $
DISTNAME= mdocml-1.13.2
DISTNAME= mdocml-1.13.3
CATEGORIES= textproc devel
MASTER_SITES= http://mdocml.bsd.lv/snapshots/
@ -24,13 +24,13 @@ SUBST_SED.roff= -e 's,Xr roff,Xr mandoc-roff,g'
post-extract:
${ECHO} PREFIX=${PREFIX} > ${WRKSRC}/configure.local
${ECHO} MANDIR=${PREFIX}/${PKGMANDIR} >> ${WRKSRC}/configure.local
${ECHO} "CFLAGS=${CFLAGS:Q}" >> ${WRKSRC}/configure.local
${ECHO} CFLAGS=\"${CFLAGS:Q}\" >> ${WRKSRC}/configure.local
${ECHO} DBLIB=\"${LDFLAGS} -lsqlite3\" >> ${WRKSRC}/configure.local
${ECHO} "INSTALL=${INSTALL:Q}" >> ${WRKSRC}/configure.local
${ECHO} "INSTALL_PROGRAM=${INSTALL_PROGRAM:Q}" >> ${WRKSRC}/configure.local
${ECHO} "INSTALL_LIB=${INSTALL_DATA:Q}" >> ${WRKSRC}/configure.local
${ECHO} "INSTALL_MAN=${INSTALL_MAN:Q}" >> ${WRKSRC}/configure.local
${ECHO} "INSTALL_DATA=${INSTALL_DATA:Q}" >> ${WRKSRC}/configure.local
${ECHO} INSTALL=\"${INSTALL:Q}\" >> ${WRKSRC}/configure.local
${ECHO} INSTALL_PROGRAM=\"${INSTALL_PROGRAM:Q}\" >> ${WRKSRC}/configure.local
${ECHO} INSTALL_LIB=\"${INSTALL_DATA:Q}\" >> ${WRKSRC}/configure.local
${ECHO} INSTALL_MAN=\"${INSTALL_MAN:Q}\" >> ${WRKSRC}/configure.local
${ECHO} INSTALL_DATA=\"${INSTALL_DATA:Q}\" >> ${WRKSRC}/configure.local
${ECHO} MANM_ROFF="mandoc-roff" >> ${WRKSRC}/configure.local
# Mac OS X and Solaris 10 and newer do not support static binaries.
.if ${OPSYS} == "Darwin" || ${OPSYS} == "SunOS"

View file

@ -1,7 +1,6 @@
$NetBSD: distinfo,v 1.36 2015/01/05 13:21:17 jperkin Exp $
$NetBSD: distinfo,v 1.37 2015/03/14 10:24:38 wiz Exp $
SHA1 (mdocml-1.13.2.tar.gz) = 0d3c4e72214f73ee81c02e9b8863db0bc8f85aaf
RMD160 (mdocml-1.13.2.tar.gz) = 656085be209cd17738e5e7e27fcbfe375dbac5f3
Size (mdocml-1.13.2.tar.gz) = 348464 bytes
SHA1 (patch-compat_fts.c) = 2b028df04122d0f793ed58e6b83b5040aa965333
SHA1 (patch-roff.7) = f9e973594d14dc9189a15c99ce768572df35e4f5
SHA1 (mdocml-1.13.3.tar.gz) = 3ccfbb492a477b84343c97de743b3dd5bd3c763b
RMD160 (mdocml-1.13.3.tar.gz) = 47d1096708b45b15d8f198404fd6608d164bb66a
Size (mdocml-1.13.3.tar.gz) = 358971 bytes
SHA1 (patch-roff.7) = 22335024f83abc347ca39aabf7ab8d9cb38f7db2

View file

@ -1,16 +0,0 @@
$NetBSD: patch-compat_fts.c,v 1.1 2015/01/05 13:21:17 jperkin Exp $
Provide compat O_CLOEXEC define.
--- compat_fts.c.orig 2014-12-13 14:06:34.000000000 +0000
+++ compat_fts.c
@@ -66,6 +66,9 @@ static int fts_safe_changedir(FTS *, FT
#ifndef O_DIRECTORY
#define O_DIRECTORY 0
#endif
+#ifndef O_CLOEXEC
+#define O_CLOEXEC 0
+#endif
#define CLR(opt) (sp->fts_options &= ~(opt))
#define ISSET(opt) (sp->fts_options & (opt))

View file

@ -1,13 +1,13 @@
$NetBSD: patch-roff.7,v 1.5 2014/12/13 15:52:53 wiz Exp $
$NetBSD: patch-roff.7,v 1.6 2015/03/14 10:24:38 wiz Exp $
Install roff with 'mandoc-' prefix to avoid conflict with groff.
--- roff.7.orig 2014-12-13 14:06:34.000000000 +0000
--- roff.7.orig 2015-03-13 12:38:38.000000000 +0000
+++ roff.7
@@ -16,10 +16,10 @@
.\" OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
.\"
.Dd $Mdocdate: December 2 2014 $
.Dd $Mdocdate: February 17 2015 $
-.Dt ROFF 7
+.Dt MANDOC-ROFF 7
.Os