xsd: use external libcutl

fixes regexp processing on NetBSD.
This commit is contained in:
markd 2021-03-19 22:09:55 +00:00
parent dbafeecba7
commit a40ea1d869
3 changed files with 20 additions and 3 deletions

View file

@ -1,7 +1,8 @@
# $NetBSD: Makefile,v 1.40 2021/03/08 14:33:44 nia Exp $
# $NetBSD: Makefile,v 1.41 2021/03/19 22:09:55 markd Exp $
DISTNAME= xsd-4.0.0+dep
PKGNAME= ${DISTNAME:S/+dep//1}
PKGREVISION= 1
CATEGORIES= devel textproc
MASTER_SITES= https://www.codesynthesis.com/download/xsd/${PKGVERSION_NOREV:R}/
EXTRACT_SUFX= .tar.bz2
@ -21,6 +22,7 @@ MAKE_FILE= makefile
BUILD_TARGET= # no default target should be passed to gmake.
MAKE_FLAGS+= verbose=1
MAKE_FLAGS+= EXTERNAL_LIBCUTL=y
MAKE_FLAGS+= install_prefix=${DESTDIR}${PREFIX}
MAKE_FLAGS+= install_man_dir=${DESTDIR}${PREFIX}/${PKGMANDIR}
@ -29,6 +31,6 @@ post-patch:
${RM} -f ${WRKSRC}/version
${RM} -f ${WRKSRC}/build/import/lib*/version
.include "../../devel/boost-libs/buildlink3.mk"
.include "../../devel/libcutl/buildlink3.mk"
.include "../../textproc/xerces-c/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

View file

@ -1,9 +1,10 @@
$NetBSD: distinfo,v 1.7 2021/03/08 14:33:44 nia Exp $
$NetBSD: distinfo,v 1.8 2021/03/19 22:09:55 markd Exp $
SHA1 (xsd-4.0.0+dep.tar.bz2) = ad3de699eb140e747a0a214462d95fc81a21b494
RMD160 (xsd-4.0.0+dep.tar.bz2) = d1af702e6feb7216e04c2f30173311e2d4629313
SHA512 (xsd-4.0.0+dep.tar.bz2) = 1b7f5f7a50007e0c739e23c46cf34657845038c3c58f2da4f9978a9486a30674d829e4dfe428af32669207af79375eb8d413ac471c4ffd1c2bc842411f454ae9
Size (xsd-4.0.0+dep.tar.bz2) = 1642625 bytes
SHA1 (patch-libxsd-frontend_xsd-frontend_semantic-graph_elements.cxx) = a4af6f1f10167577df591edc252a48c228979a43
SHA1 (patch-xsd_doc_makefile) = 2440ca86fbcbe040e45a1859d76d0cad1b8c3865
SHA1 (patch-xsd_doc_xsd.1) = 1660f480c8410133ae490b64c9a0fb52b5b3466f
SHA1 (patch-xsd_doc_xsd.xhtml) = 52e4bcdcccf16cc32fffb3e81688a73558bf0a1b

View file

@ -0,0 +1,14 @@
$NetBSD: patch-libxsd-frontend_xsd-frontend_semantic-graph_elements.cxx,v 1.1 2021/03/19 22:09:55 markd Exp $
fix error: no match for 'operator<<'
--- libxsd-frontend/xsd-frontend/semantic-graph/elements.cxx.orig 2014-07-16 08:14:03.000000000 +0000
+++ libxsd-frontend/xsd-frontend/semantic-graph/elements.cxx
@@ -2,6 +2,7 @@
// copyright : Copyright (c) 2005-2014 Code Synthesis Tools CC
// license : GNU GPL v2 + exceptions; see accompanying LICENSE file
+#include <iostream>
#include <algorithm>
#include <cutl/compiler/type-info.hxx>