Fix build with modern GCC.

This commit is contained in:
joerg 2011-11-25 22:25:30 +00:00
parent df982418df
commit a411758f2e
11 changed files with 127 additions and 3 deletions

View file

@ -1,8 +1,17 @@
$NetBSD: distinfo,v 1.7 2011/01/29 11:24:43 wiz Exp $
$NetBSD: distinfo,v 1.8 2011/11/25 22:25:30 joerg Exp $
SHA1 (fbdesk-1.4.1.tar.gz) = b5a2f446fa27406d9adb9a9608f1dc3c638d37ff
RMD160 (fbdesk-1.4.1.tar.gz) = ce22936b73acd8273e9816f4c2a5458cc98cf45a
Size (fbdesk-1.4.1.tar.gz) = 426550 bytes
SHA1 (patch-aa) = 4412dfd20e31814ee674213ca798864dab25399f
SHA1 (patch-ab) = 4245733d9ec038f0c2bc3bd53e9a026e97e43d1e
SHA1 (patch-ab) = 9e2c2600561ba4228959a79cb2da603aab7e8ba3
SHA1 (patch-ac) = 7771adb86237b0c143baafc993cbd67998a1a17f
SHA1 (patch-src_FbDesk.cc) = 65ac9146794e1ea7388906a05bbc8b86fdd70b46
SHA1 (patch-src_FbTk_KeyUtil.cc) = b895774066d0f474ff6f1b0f6ee38477bd87fca3
SHA1 (patch-src_FbTk_StringUtil.cc) = fcc300d550a58995822f7ff9bc368d0e5f63bda7
SHA1 (patch-src_FbTk_TextBox.cc) = bf786dec9636e7941f9435baadb157684cb560b4
SHA1 (patch-src_FbTk_TextureRender.cc) = 56b1dc0ebf05ee2e188ab4c960eef518cdbd92a5
SHA1 (patch-src_FbTk_Theme.cc) = 842743e69a7b005fa12e4732270cdb218a23d990
SHA1 (patch-src_FbTk_ThemeItems.cc) = 61656f0b627455594816db1f09ad85d94a65e042
SHA1 (patch-src_FbTk_XFontImp.cc) = 331e1bff744ffe973a99eb819e0e88890b97abb1
SHA1 (patch-src_main.cc) = 0b1817c82ca507169821002b62510f21fedac03b

View file

@ -1,4 +1,4 @@
$NetBSD: patch-ab,v 1.2 2008/05/10 16:19:16 obache Exp $
$NetBSD: patch-ab,v 1.3 2011/11/25 22:25:31 joerg Exp $
--- src/FbTk/FbPixmap.cc.orig 2006-03-25 11:47:10.000000000 +0000
+++ src/FbTk/FbPixmap.cc
@ -7,3 +7,7 @@ $NetBSD: patch-ab,v 1.2 2008/05/10 16:19:16 obache Exp $
+#include <stdio.h>
+
#include "FbPixmap.hh"
@@ -32,2 +34,3 @@
#include <string>
+#include <cstring>

View file

@ -0,0 +1,12 @@
$NetBSD: patch-src_FbDesk.cc,v 1.1 2011/11/25 22:25:31 joerg Exp $
--- src/FbDesk.cc.orig 2011-11-25 17:43:42.000000000 +0000
+++ src/FbDesk.cc
@@ -39,6 +39,7 @@
#include <algorithm>
#include <unistd.h>
#include <cstdio>
+#include <cstring>
using namespace std;
using namespace FbTk;

View file

@ -0,0 +1,12 @@
$NetBSD: patch-src_FbTk_KeyUtil.cc,v 1.1 2011/11/25 22:25:31 joerg Exp $
--- src/FbTk/KeyUtil.cc.orig 2011-11-25 17:42:18.000000000 +0000
+++ src/FbTk/KeyUtil.cc
@@ -25,6 +25,7 @@
#include "App.hh"
#include <string>
+#include <strings.h>
namespace {

View file

@ -0,0 +1,13 @@
$NetBSD: patch-src_FbTk_StringUtil.cc,v 1.1 2011/11/25 22:25:31 joerg Exp $
--- src/FbTk/StringUtil.cc.orig 2011-11-25 17:41:16.000000000 +0000
+++ src/FbTk/StringUtil.cc
@@ -23,7 +23,7 @@
#include "StringUtil.hh"
-
+#include <cstring>
#ifdef HAVE_CSTDIO
#include <cstdio>
#else

View file

@ -0,0 +1,12 @@
$NetBSD: patch-src_FbTk_TextBox.cc,v 1.1 2011/11/25 22:25:31 joerg Exp $
--- src/FbTk/TextBox.cc.orig 2011-11-25 17:42:54.000000000 +0000
+++ src/FbTk/TextBox.cc
@@ -32,6 +32,7 @@
#else
#include <ctype.h>
#endif
+#include <cstdlib>
#include <X11/keysym.h>
#include <X11/Xutil.h>

View file

@ -0,0 +1,12 @@
$NetBSD: patch-src_FbTk_TextureRender.cc,v 1.1 2011/11/25 22:25:31 joerg Exp $
--- src/FbTk/TextureRender.cc.orig 2011-11-25 17:39:41.000000000 +0000
+++ src/FbTk/TextureRender.cc
@@ -32,6 +32,7 @@
#include "GContext.hh"
#include <iostream>
+#include <cstring>
#include <string>
#ifdef HAVE_CSTDIO
#include <cstdio>

View file

@ -0,0 +1,12 @@
$NetBSD: patch-src_FbTk_Theme.cc,v 1.1 2011/11/25 22:25:31 joerg Exp $
--- src/FbTk/Theme.cc.orig 2011-11-25 17:39:29.000000000 +0000
+++ src/FbTk/Theme.cc
@@ -29,6 +29,7 @@
#include "FileUtil.hh"
#include "Image.hh"
+#include <algorithm>
#ifdef HAVE_CSTDIO
#include <cstdio>
#else

View file

@ -0,0 +1,13 @@
$NetBSD: patch-src_FbTk_ThemeItems.cc,v 1.1 2011/11/25 22:25:31 joerg Exp $
--- src/FbTk/ThemeItems.cc.orig 2011-11-25 17:43:10.000000000 +0000
+++ src/FbTk/ThemeItems.cc
@@ -40,6 +40,8 @@
#include "StringUtil.hh"
#include <string>
+#include <cstdlib>
+#include <strings.h>
#ifdef HAVE_CSTDIO
#include <cstdio>
#else

View file

@ -0,0 +1,12 @@
$NetBSD: patch-src_FbTk_XFontImp.cc,v 1.1 2011/11/25 22:25:31 joerg Exp $
--- src/FbTk/XFontImp.cc.orig 2011-11-25 17:38:54.000000000 +0000
+++ src/FbTk/XFontImp.cc
@@ -29,6 +29,7 @@
#include <X11/Xutil.h>
#include <iostream>
+#include <cstdlib>
#include <new>
#ifdef HAVE_CSTDIO
#include <cstdio>

View file

@ -0,0 +1,13 @@
$NetBSD: patch-src_main.cc,v 1.1 2011/11/25 22:25:31 joerg Exp $
--- src/main.cc.orig 2011-11-25 17:43:54.000000000 +0000
+++ src/main.cc
@@ -24,6 +24,8 @@
#include "version.h"
#include <iostream>
+#include <cstring>
+#include <cstdlib>
#include <stdexcept>
#include <signal.h>
#include <sys/wait.h>