Do not rename the installed binary, because it breaks the package; keep the

gnome-terminal name, and add a missing CONFLICTS with gnome-core (they already
conflicted).  Fixes PR pkg/22266 by Rafal Boni.

While here, bump gnome2-dirs dependancy to 1.2.

Bump PKGREVISION to 1.
This commit is contained in:
jmmv 2003-09-08 18:07:21 +00:00
parent 04be87887c
commit a4207a9569
4 changed files with 8 additions and 19 deletions

View file

@ -1,8 +1,9 @@
# $NetBSD: Makefile,v 1.11 2003/07/25 09:14:10 jmmv Exp $
# $NetBSD: Makefile,v 1.12 2003/09/08 18:07:21 jmmv Exp $
#
DISTNAME= gnome-terminal-2.0.2
PKGNAME= ${DISTNAME:S/-/2-/}
PKGREVISION= 1
CATEGORIES= x11 gnome
MASTER_SITES= ${MASTER_SITE_GNOME:=sources/gnome-terminal/2.0/}
EXTRACT_SUFX= .tar.bz2
@ -12,7 +13,9 @@ HOMEPAGE= http://www.gnome.org/
COMMENT= Xterm like terminal program for GNOME 2
BUILD_USES_MSGFMT= YES
DEPENDS= gnome2-dirs>=1.0:../../misc/gnome2-dirs
DEPENDS= gnome2-dirs>=1.2:../../misc/gnome2-dirs
CONFLICTS= gnome-core-[0-9]*
USE_PERL5= build
GNU_CONFIGURE= YES

View file

@ -1,5 +1,5 @@
@comment $NetBSD: PLIST,v 1.4 2003/07/25 09:14:11 jmmv Exp $
bin/gnome2-terminal
@comment $NetBSD: PLIST,v 1.5 2003/09/08 18:07:21 jmmv Exp $
bin/gnome-terminal
lib/bonobo/servers/gnome-terminal.server
share/applications/gnome-terminal.desktop
share/gconf/schemas/gnome-terminal.schemas

View file

@ -1,5 +1,4 @@
$NetBSD: distinfo,v 1.4 2003/07/25 09:14:11 jmmv Exp $
$NetBSD: distinfo,v 1.5 2003/09/08 18:07:21 jmmv Exp $
SHA1 (gnome-terminal-2.0.2.tar.bz2) = 9bf4feaa60ae6e1a154a011173b373b543d5b4e5
Size (gnome-terminal-2.0.2.tar.bz2) = 684517 bytes
SHA1 (patch-aa) = f87211a54c16b23730566c8149a1b3f5efbd6acd

View file

@ -1,13 +0,0 @@
$NetBSD: patch-aa,v 1.3 2003/02/18 20:52:10 jmmv Exp $
--- src/Makefile.in.orig Mon Aug 5 03:05:07 2002
+++ src/Makefile.in
@@ -268,7 +268,7 @@ install-binPROGRAMS: $(bin_PROGRAMS)
@list='$(bin_PROGRAMS)'; for p in $$list; do \
if test -f $$p; then \
echo " $(LIBTOOL) --mode=install $(INSTALL_PROGRAM) $$p $(DESTDIR)$(bindir)/`echo $$p|sed 's/$(EXEEXT)$$//'|sed '$(transform)'|sed 's/$$/$(EXEEXT)/'`"; \
- $(LIBTOOL) --mode=install $(INSTALL_PROGRAM) $$p $(DESTDIR)$(bindir)/`echo $$p|sed 's/$(EXEEXT)$$//'|sed '$(transform)'|sed 's/$$/$(EXEEXT)/'`; \
+ $(LIBTOOL) --mode=install $(INSTALL_PROGRAM) $$p $(DESTDIR)$(bindir)/`echo $$p|sed 's/$(EXEEXT)$$//'|sed '$(transform)'|sed -e 's/$$/$(EXEEXT)/' -e 's/gnome/gnome2/'`; \
else :; fi; \
done