libkeyfinder: avoid ambiguous pow(3)

This commit is contained in:
tnn 2022-04-25 13:49:49 +00:00
parent 7a45a63bf5
commit a4287395bc
2 changed files with 17 additions and 1 deletions

View File

@ -1,5 +1,6 @@
$NetBSD: distinfo,v 1.1 2021/11/20 18:09:45 nia Exp $
$NetBSD: distinfo,v 1.2 2022/04/25 13:49:49 tnn Exp $
BLAKE2s (libkeyfinder-2.2.5.tar.gz) = 37abe2a1057e320df231cbfcceb0bd39fe8b58f12e1ce5a21cd962e3df5dc611
SHA512 (libkeyfinder-2.2.5.tar.gz) = 54463d1f1111dc474d3e43723fddd5579ea1a3842f99f43e50e85622a1d6ee6fe42b22c300ce5ba5807cf6b2d7067af741773af95974a42c5d863c53165893eb
Size (libkeyfinder-2.2.5.tar.gz) = 79220 bytes
SHA1 (patch-src_windowfunctions.cpp) = f3eb1a4bd739fa41e56aecddde1ce85a745df5a6

View File

@ -0,0 +1,15 @@
$NetBSD: patch-src_windowfunctions.cpp,v 1.1 2022/04/25 13:49:49 tnn Exp $
Explicitly use std::pow, avoids ambiguous reference on SunOS.
--- src/windowfunctions.cpp.orig 2021-07-17 22:04:12.000000000 +0000
+++ src/windowfunctions.cpp
@@ -21,6 +21,8 @@
#include "windowfunctions.h"
+using std::pow;
+
namespace KeyFinder {
double WindowFunction::window(temporal_window_t windowType, int n, int N) const {