Update mame and mess to 0.142. Lots of changes, as usual.

This commit is contained in:
wiz 2011-04-04 12:09:02 +00:00
parent 6899699545
commit a49878371c
13 changed files with 223 additions and 107 deletions

View file

@ -1,7 +1,7 @@
# $NetBSD: Makefile,v 1.1.1.1 2011/02/03 22:22:35 wiz Exp $
# $NetBSD: Makefile,v 1.2 2011/04/04 12:09:03 wiz Exp $
#
DISTNAME= mame0141s
DISTNAME= mame0142s
PKGNAME= ${DISTNAME:S/0/-0./:S/s$//}
MASTER_SITES= http://mamedev.org/downloader.php?file=releases/

View file

@ -1,10 +1,10 @@
$NetBSD: distinfo,v 1.4 2011/02/26 07:06:23 wiz Exp $
$NetBSD: distinfo,v 1.5 2011/04/04 12:09:03 wiz Exp $
SHA1 (mame0141s.zip) = 80225e2694469dac39a75815f227b864a4992f5e
RMD160 (mame0141s.zip) = c09ef461280dfd7e45ca638caaa66d8752a9794b
Size (mame0141s.zip) = 17092788 bytes
SHA1 (patch-makefile) = 59c3f439e3a250564e82ad6addc30b6c85dbc80c
SHA1 (patch-src_emu_debug_debugcpu.c) = 1838cca446d62ebd824a540d30770fe56819cf03
SHA1 (patch-src_emu_emucore.h) = 096ae265c2b0eb1021bd9b04b0b8b26e73519a9c
SHA1 (patch-src_lib_util_astring.h) = 9cd5fbc7bd477707ba4de328e0429c0d6cbe6924
SHA1 (patch-src_osd_sdl_sdlsync__ntc.c) = 1a8e940ad9cd59bd6bbc1850f24040a7d074b57a
SHA1 (mame0142s.zip) = 6d70b7a2a15abfdb7955772844ac4c6eae50ced4
RMD160 (mame0142s.zip) = 20b7fc0af868521462e8081021acbfbe98bea16d
Size (mame0142s.zip) = 17657289 bytes
SHA1 (patch-makefile) = 7117269c9818a1bf018c7d650a5fd64fc0ea3728
SHA1 (patch-src_emu_hash.c) = c2cf2d70c97c2f88538e974f962f53a0eb2647cc
SHA1 (patch-src_emu_input.c) = 2a7b5a607e2def30f501ea6ef25616ab0ab5aee3
SHA1 (patch-src_lib_util_astring.h) = 31612dcae07ada558afb7727395d67b0a1388eb5
SHA1 (patch-src_mame_machine_naomibd.c) = 7bc53bd57a6d75eae4e0d1d27b1b8cb7fd2fb4df

View file

@ -1,19 +1,9 @@
$NetBSD: patch-makefile,v 1.4 2011/02/26 07:06:24 wiz Exp $
$NetBSD: patch-makefile,v 1.5 2011/04/04 12:09:03 wiz Exp $
First chunk accepted upstream, second pkgsrc-only.
Pkgsrc-only patch.
--- makefile.orig 2010-12-29 22:50:26.000000000 +0000
+++ makefile
@@ -86,6 +88,9 @@ endif
ifeq ($(firstword $(filter GNU/kFreeBSD,$(UNAME))),GNU/kFreeBSD)
TARGETOS = freebsd
endif
+ifeq ($(firstword $(filter NetBSD,$(UNAME))),NetBSD)
+TARGETOS = netbsd
+endif
ifeq ($(firstword $(filter OpenBSD,$(UNAME))),OpenBSD)
TARGETOS = openbsd
endif
@@ -344,7 +349,7 @@ NAME = $(TARGET)$(SUBTARGET)
endif

View file

@ -1,15 +0,0 @@
$NetBSD: patch-src_emu_debug_debugcpu.c,v 1.4 2011/02/26 07:06:24 wiz Exp $
Sent upstream and accepted.
--- src/emu/debug/debugcpu.c.orig 2010-12-31 16:41:26.000000000 +0000
+++ src/emu/debug/debugcpu.c
@@ -51,7 +51,7 @@
#include "xmlfile.h"
#include <ctype.h>
#include <zlib.h>
-#ifdef SDLMAME_FREEBSD
+#if defined(SDLMAME_FREEBSD) || defined(SDLMAME_NETBSD)
# undef tolower
#endif

View file

@ -1,22 +0,0 @@
$NetBSD: patch-src_emu_emucore.h,v 1.4 2011/02/26 07:06:24 wiz Exp $
Sent upstream and accepted.
--- src/emu/emucore.h.orig 2010-12-31 14:59:46.000000000 +0000
+++ src/emu/emucore.h
@@ -686,6 +686,7 @@ inline void fatalerror_exitcode(running_
//**************************************************************************
// population count
+#ifndef SDLMAME_NETBSD
inline int popcount(UINT32 val)
{
int count;
@@ -694,6 +695,7 @@ inline int popcount(UINT32 val)
val &= val - 1;
return count;
}
+#endif
// convert a series of 32 bits into a float

View file

@ -0,0 +1,16 @@
$NetBSD: patch-src_emu_hash.c,v 1.1 2011/04/04 12:09:03 wiz Exp $
toupper is a macro on NetBSD.
Sent upstream.
--- src/emu/hash.c.orig 2011-03-29 09:38:54.000000000 +0000
+++ src/emu/hash.c
@@ -658,7 +658,7 @@ const char *hash_collection::macro_strin
buffer.reset();
for (hash_base *hash = m_hashlist.first(); hash != NULL; hash = hash->next())
{
- buffer.cat(temp.cpy(hash->name()).toupper());
+ buffer.cat(temp.cpy(hash->name()).upper());
buffer.cat("(").cat(hash->string(temp)).cat(") ");
}

View file

@ -0,0 +1,16 @@
$NetBSD: patch-src_emu_input.c,v 1.1 2011/04/04 12:09:03 wiz Exp $
toupper is a macro on NetBSD.
Sent upstream.
--- src/emu/input.c.orig 2011-03-29 08:50:06.000000000 +0000
+++ src/emu/input.c
@@ -829,7 +829,7 @@ void input_device_item_add(input_device
if (itemid > ITEM_ID_MAXIMUM)
{
/* copy the item name, removing spaces/underscores and making all caps */
- item->token.cpy(name).toupper().delchr(' ').delchr('_');
+ item->token.cpy(name).upper().delchr(' ').delchr('_');
}
/* otherwise, make sure we have a valid standard token */

View file

@ -1,17 +1,16 @@
$NetBSD: patch-src_lib_util_astring.h,v 1.4 2011/02/26 07:06:24 wiz Exp $
$NetBSD: patch-src_lib_util_astring.h,v 1.5 2011/04/04 12:09:03 wiz Exp $
Sent upstream and accepted.
toupper is a macro on NetBSD.
Sent upstream.
--- src/lib/util/astring.h.orig 2010-10-31 23:48:04.000000000 +0000
--- src/lib/util/astring.h.orig 2011-02-01 20:29:56.000000000 +0000
+++ src/lib/util/astring.h
@@ -296,6 +296,10 @@ INLINE astring *astring_assemble_5(astri
***************************************************************************/
@@ -396,7 +396,7 @@ public:
#ifdef __cplusplus
+#ifdef SDLMAME_NETBSD
+#undef toupper
+#undef tolower
+#endif
/* derived class for C++ */
class astring : public astring_base
astring &delchr(int ch) { return *astring_delchr(this, ch); }
astring &replacechr(int ch, int newch) { return *astring_replacechr(this, ch, newch); }
- astring &toupper() { return *astring_toupper(this); }
+ astring &upper() { return *astring_toupper(this); }
astring &tolower() { return *astring_tolower(this); }
astring &trimspace() { return *astring_trimspace(this); }
};

View file

@ -0,0 +1,24 @@
$NetBSD: patch-src_mame_machine_naomibd.c,v 1.1 2011/04/04 12:09:03 wiz Exp $
bswap16 is a macro on NetBSD.
Sent upstream.
--- src/mame/machine/naomibd.c.orig 2011-03-29 08:50:06.000000000 +0000
+++ src/mame/machine/naomibd.c
@@ -516,14 +516,14 @@ static void naomibd_m1_decode(naomibd_st
// Streaming M2/M3 protection and decompression
-INLINE UINT16 bswap16(UINT16 in)
+INLINE UINT16 naomi_bswap16(UINT16 in)
{
return ((in>>8) | (in<<8));
}
static UINT16 naomibd_get_decrypted_stream(naomibd_state *naomibd)
{
- UINT16 wordn = bswap16(naomibd->prot.ptr[naomibd->prot.count++]);
+ UINT16 wordn = naomi_bswap16(naomibd->prot.ptr[naomibd->prot.count++]);
naomibd->prot.aux_word = block_decrypt(naomibd->dc_gamekey, naomibd->dc_seqkey, naomibd->prot.seed++, wordn);
wordn = (naomibd->prot.last_word&~3) | (naomibd->prot.aux_word&3);

View file

@ -1,18 +0,0 @@
$NetBSD: patch-src_osd_sdl_sdlsync__ntc.c,v 1.4 2011/02/26 07:06:24 wiz Exp $
Sent upstream and accepted.
--- src/osd/sdl/sdlsync_ntc.c.orig 2010-01-15 20:12:06.000000000 +0000
+++ src/osd/sdl/sdlsync_ntc.c
@@ -19,6 +19,11 @@
#include <mach/mach.h>
#endif
+#ifdef SDLMAME_NETBSD
+/* for SIGKILL */
+#include <signal.h>
+#endif
+
// standard C headers
#include <math.h>
#include <unistd.h>

View file

@ -1,7 +1,7 @@
# $NetBSD: Makefile,v 1.1.1.1 2011/02/03 22:22:54 wiz Exp $
# $NetBSD: Makefile,v 1.2 2011/04/04 12:09:02 wiz Exp $
#
DISTNAME= mess0141s
DISTNAME= mess0142s
PKGNAME= ${DISTNAME:S/0/-0./:S/s$//}
MASTER_SITES= http://www.mess.org/files/
DISTFILES= ${DISTNAME:S/mess/mame/}${EXTRACT_SUFX} ${DISTNAME}${EXTRACT_SUFX}

View file

@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.1.1.1 2011/02/03 22:22:54 wiz Exp $
@comment $NetBSD: PLIST,v 1.2 2011/04/04 12:09:02 wiz Exp $
bin/castool
bin/imgtool
bin/mess
@ -321,9 +321,17 @@ share/doc/mess/sysinfo/z88.htm
share/doc/mess/sysinfo/zx80.htm
share/doc/mess/sysinfo/zx81.htm
share/mess/artwork/4004clk.zip
share/mess/artwork/academy.zip
share/mess/artwork/aim65.zip
share/mess/artwork/alm16.zip
share/mess/artwork/alm32.zip
share/mess/artwork/amsterd.zip
share/mess/artwork/avigo.zip
share/mess/artwork/berlinp.zip
share/mess/artwork/bpl32.zip
share/mess/artwork/gen32.zip
share/mess/artwork/gen32_41.zip
share/mess/artwork/gen32_oc.zip
share/mess/artwork/glasgow.zip
share/mess/artwork/hp48g.zip
share/mess/artwork/hp48gp.zip
@ -332,94 +340,212 @@ share/mess/artwork/hp48s.zip
share/mess/artwork/hp48sx.zip
share/mess/artwork/junior.zip
share/mess/artwork/kim1.zip
share/mess/artwork/lond020.zip
share/mess/artwork/lond030.zip
share/mess/artwork/lyon16.zip
share/mess/artwork/lyon32.zip
share/mess/artwork/milano.zip
share/mess/artwork/mk1.zip
share/mess/artwork/mk2.zip
share/mess/artwork/mm4.zip
share/mess/artwork/monteciv.zip
share/mess/artwork/mpf1.zip
share/mess/artwork/mpf1b.zip
share/mess/artwork/pc1401.zip
share/mess/artwork/pc1402.zip
share/mess/artwork/pc1403.zip
share/mess/artwork/polgar.zip
share/mess/artwork/sexpertc.zip
share/mess/artwork/ssystem3.zip
share/mess/artwork/supercon.zip
share/mess/artwork/thomson.zip
share/mess/artwork/van16.zip
share/mess/artwork/van32.zip
share/mess/hash/32x.xml
share/mess/hash/a2600.hsi
share/mess/hash/a5200.hsi
share/mess/hash/a5200.xml
share/mess/hash/a7800.hsi
share/mess/hash/a7800.xml
share/mess/hash/a800.hsi
share/mess/hash/a800.xml
share/mess/hash/a800xl.hsi
share/mess/hash/abc1600.xml
share/mess/hash/abc80.xml
share/mess/hash/abc800.xml
share/mess/hash/abc806.xml
share/mess/hash/advision.hsi
share/mess/hash/advision.xml
share/mess/hash/aes.xml
share/mess/hash/aim65.hsi
share/mess/hash/alice32.xml
share/mess/hash/apexc.hsi
share/mess/hash/apfm1000.hsi
share/mess/hash/apfm1000.xml
share/mess/hash/apple1.hsi
share/mess/hash/apple2.hsi
share/mess/hash/aquarius.hsi
share/mess/hash/aquarius.xml
share/mess/hash/arcadia.hsi
share/mess/hash/arcadia.xml
share/mess/hash/astrocde.hsi
share/mess/hash/astrocde.xml
share/mess/hash/atom.xml
share/mess/hash/bbca.hsi
share/mess/hash/bbcbc.xml
share/mess/hash/bw2.xml
share/mess/hash/c128.hsi
share/mess/hash/c16.hsi
share/mess/hash/c64.hsi
share/mess/hash/c64_cart.xml
share/mess/hash/casloopy.xml
share/mess/hash/cbm30.hsi
share/mess/hash/cbm40.hsi
share/mess/hash/cbm610.hsi
share/mess/hash/cbm80.hsi
share/mess/hash/cd32.xml
share/mess/hash/cdi.xml
share/mess/hash/cdtv.xml
share/mess/hash/cgenie.hsi
share/mess/hash/channelf.hsi
share/mess/hash/channelf.xml
share/mess/hash/coco.hsi
share/mess/hash/coleco.hsi
share/mess/hash/coleco.xml
share/mess/hash/cpc464.hsi
share/mess/hash/cpc6128.hsi
share/mess/hash/crvision.xml
share/mess/hash/dim68k.xml
share/mess/hash/dragon64.hsi
share/mess/hash/einstein.xml
share/mess/hash/ep128.hsi
share/mess/hash/exidy.hsi
share/mess/hash/fm77av.xml
share/mess/hash/fm7_cass.xml
share/mess/hash/fm7_disk.xml
share/mess/hash/gameboy.hsi
share/mess/hash/gameboy.xml
share/mess/hash/gamecom.hsi
share/mess/hash/gamecom.xml
share/mess/hash/gamegear.hsi
share/mess/hash/gamegear.xml
share/mess/hash/gamepock.xml
share/mess/hash/gba.xml
share/mess/hash/gbcolor.xml
share/mess/hash/genesis.hsi
share/mess/hash/gmaster.xml
share/mess/hash/gx4000.xml
share/mess/hash/ibm5170.xml
share/mess/hash/ibmpc.hsi
share/mess/hash/ibmpcjr.hsi
share/mess/hash/ibmpcjr_cart.xml
share/mess/hash/intv.hsi
share/mess/hash/jaguar.hsi
share/mess/hash/jaguar.xml
share/mess/hash/jupiter.hsi
share/mess/hash/laser210.hsi
share/mess/hash/lisa.xml
share/mess/hash/lisa2.hsi
share/mess/hash/lviv.hsi
share/mess/hash/lynx.hsi
share/mess/hash/lynx.xml
share/mess/hash/m5.hsi
share/mess/hash/m5.xml
share/mess/hash/max.hsi
share/mess/hash/max.xml
share/mess/hash/mc10.hsi
share/mess/hash/megacd.xml
share/mess/hash/megacdj.xml
share/mess/hash/megadriv.xml
share/mess/hash/megaduck.hsi
share/mess/hash/megaduck.xml
share/mess/hash/megapc.xml
share/mess/hash/megatech.xml
share/mess/hash/microtan.hsi
share/mess/hash/mo5.hsi
share/mess/hash/msx.hsi
share/mess/hash/msx2.hsi
share/mess/hash/mtx512.hsi
share/mess/hash/mz2500.xml
share/mess/hash/n64.hsi
share/mess/hash/n64.xml
share/mess/hash/nascom1.hsi
share/mess/hash/nes.hsi
share/mess/hash/nes.xml
share/mess/hash/ngp.xml
share/mess/hash/odyssey2.hsi
share/mess/hash/oric.hsi
share/mess/hash/p2000t.hsi
share/mess/hash/pasogo.xml
share/mess/hash/pb2000c.xml
share/mess/hash/pc8001_cass.xml
share/mess/hash/pc8001_flop.xml
share/mess/hash/pc8201.xml
share/mess/hash/pce.hsi
share/mess/hash/pce.xml
share/mess/hash/pcecd.xml
share/mess/hash/pdp1.hsi
share/mess/hash/pet.hsi
share/mess/hash/pico.hsi
share/mess/hash/pico.xml
share/mess/hash/pippin.xml
share/mess/hash/pippin_flop.xml
share/mess/hash/pokemini.hsi
share/mess/hash/pokemini.xml
share/mess/hash/psion.xml
share/mess/hash/psx.hsi
share/mess/hash/pv1000.xml
share/mess/hash/pv2000.xml
share/mess/hash/ql.xml
share/mess/hash/rx78.xml
share/mess/hash/samcoupe.hsi
share/mess/hash/scv.xml
share/mess/hash/segacd.xml
share/mess/hash/sg1000.xml
share/mess/hash/sgx.xml
share/mess/hash/smc777.xml
share/mess/hash/sms.hsi
share/mess/hash/sms.xml
share/mess/hash/snes.hsi
share/mess/hash/sordm5.hsi
share/mess/hash/snes.xml
share/mess/hash/softwarelist.dtd
share/mess/hash/sorcerer.xml
share/mess/hash/spectrum.hsi
share/mess/hash/spectrum.xml
share/mess/hash/st.xml
share/mess/hash/studio2.hsi
share/mess/hash/studio2.xml
share/mess/hash/supracan.xml
share/mess/hash/svi318.hsi
share/mess/hash/svi318_cart.xml
share/mess/hash/svi318_cass.xml
share/mess/hash/svi318_flop.xml
share/mess/hash/svision.hsi
share/mess/hash/svision.xml
share/mess/hash/tandy200.xml
share/mess/hash/tg16.xml
share/mess/hash/ti99_4a.hsi
share/mess/hash/trs80m2.xml
share/mess/hash/trsm100.xml
share/mess/hash/ts2068.hsi
share/mess/hash/tutor.xml
share/mess/hash/v1050.xml
share/mess/hash/vboy.hsi
share/mess/hash/vboy.xml
share/mess/hash/vc4000.hsi
share/mess/hash/vc4000.xml
share/mess/hash/vectrex.hsi
share/mess/hash/vectrex.xml
share/mess/hash/vg5k.xml
share/mess/hash/vic1001_cart.xml
share/mess/hash/vic20.hsi
share/mess/hash/vidbrain.xml
share/mess/hash/vii.xml
share/mess/hash/vixen.xml
share/mess/hash/wscolor.xml
share/mess/hash/wswan.hsi
share/mess/hash/wswan.xml
share/mess/hash/x1_cass.xml
share/mess/hash/x1_flop.xml
share/mess/hash/x68k_flop.xml
share/mess/hash/xegs.xml

View file

@ -1,13 +1,13 @@
$NetBSD: distinfo,v 1.3 2011/02/26 07:06:38 wiz Exp $
$NetBSD: distinfo,v 1.4 2011/04/04 12:09:02 wiz Exp $
SHA1 (mame0141s.zip) = 80225e2694469dac39a75815f227b864a4992f5e
RMD160 (mame0141s.zip) = c09ef461280dfd7e45ca638caaa66d8752a9794b
Size (mame0141s.zip) = 17092788 bytes
SHA1 (mess0141s.zip) = daaa1475578664a98396cb6c1f403eed9000ddd7
RMD160 (mess0141s.zip) = a6f486948421f48e9e876ce98027008a6a839ecc
Size (mess0141s.zip) = 20828322 bytes
SHA1 (patch-makefile) = 59c3f439e3a250564e82ad6addc30b6c85dbc80c
SHA1 (patch-src_emu_debug_debugcpu.c) = 1838cca446d62ebd824a540d30770fe56819cf03
SHA1 (patch-src_emu_emucore.h) = 096ae265c2b0eb1021bd9b04b0b8b26e73519a9c
SHA1 (patch-src_lib_util_astring.h) = 9cd5fbc7bd477707ba4de328e0429c0d6cbe6924
SHA1 (patch-src_osd_sdl_sdlsync__ntc.c) = 1a8e940ad9cd59bd6bbc1850f24040a7d074b57a
SHA1 (mame0142s.zip) = 6d70b7a2a15abfdb7955772844ac4c6eae50ced4
RMD160 (mame0142s.zip) = 20b7fc0af868521462e8081021acbfbe98bea16d
Size (mame0142s.zip) = 17657289 bytes
SHA1 (mess0142s.zip) = 6682f1cad54b9db4eae164046c09e79d69c44b57
RMD160 (mess0142s.zip) = e6fb3409892548632be8f2d95c71d1f148e6ad6e
Size (mess0142s.zip) = 40778589 bytes
SHA1 (patch-makefile) = 7117269c9818a1bf018c7d650a5fd64fc0ea3728
SHA1 (patch-src_emu_hash.c) = c2cf2d70c97c2f88538e974f962f53a0eb2647cc
SHA1 (patch-src_emu_input.c) = 2a7b5a607e2def30f501ea6ef25616ab0ab5aee3
SHA1 (patch-src_lib_util_astring.h) = 31612dcae07ada558afb7727395d67b0a1388eb5
SHA1 (patch-src_mame_machine_naomibd.c) = 7bc53bd57a6d75eae4e0d1d27b1b8cb7fd2fb4df