Patch exicyclog to work when commands have spaces in them
By default, pkgsrc uses 'mv -f' as MV_COMMAND. exicyclog is not resilient to this, and breaks as a result. This patch quotes the command names that are substituted into this script.
This commit is contained in:
parent
0d292ce591
commit
a4b0cd2d9f
3 changed files with 31 additions and 2 deletions
|
@ -1,6 +1,7 @@
|
|||
# $NetBSD: Makefile,v 1.177 2020/04/14 19:34:39 wiz Exp $
|
||||
# $NetBSD: Makefile,v 1.178 2020/04/25 12:48:57 gavan Exp $
|
||||
|
||||
DISTNAME= exim-4.93.0.4
|
||||
PKGREVISION= 1
|
||||
CATEGORIES= mail net
|
||||
MASTER_SITES= ftp://ftp.exim.org/pub/exim/exim4/
|
||||
MASTER_SITES+= https://ftp.exim.org/pub/exim/exim4/
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: distinfo,v 1.75 2020/04/14 19:34:39 wiz Exp $
|
||||
$NetBSD: distinfo,v 1.76 2020/04/25 12:48:57 gavan Exp $
|
||||
|
||||
SHA1 (exim-4.93.0.4.tar.xz) = 890bdf2fe00bb6916c47ed9e77a84cf85b385a4c
|
||||
RMD160 (exim-4.93.0.4.tar.xz) = c2ae47ef89f062bd94c1444baa9af4164bb37c37
|
||||
|
@ -8,3 +8,4 @@ SHA1 (patch-Local_Makefile.pkgsrc) = 7d6971cfe6f6fecf854926e90460b1a8bcd6a79d
|
|||
SHA1 (patch-OS_Makefile-Default) = 6af17f036ed02a3bc37c1f303269eea447fcb691
|
||||
SHA1 (patch-lookups_Makefile) = cfc40dba3f75ef37b9887f7767139ad50cf9d4e5
|
||||
SHA1 (patch-scripts_exim__install) = aa0a31e77d5f76e33bc92140c14d39c79f710b95
|
||||
SHA1 (patch-src_exicyclog.src) = cea5f04f52c9264fd7d279c046686dac2dc57a65
|
||||
|
|
27
mail/exim/patches/patch-src_exicyclog.src
Normal file
27
mail/exim/patches/patch-src_exicyclog.src
Normal file
|
@ -0,0 +1,27 @@
|
|||
$NetBSD: patch-src_exicyclog.src,v 1.1 2020/04/25 12:48:57 gavan Exp $
|
||||
|
||||
--- src/exicyclog.src.orig 2020-01-03 12:08:52.000000000 +0000
|
||||
+++ src/exicyclog.src
|
||||
@@ -49,15 +49,15 @@
|
||||
# varies from OS to OS. Sigh.
|
||||
|
||||
keep=EXICYCLOG_MAX
|
||||
-compress=COMPRESS_COMMAND
|
||||
+compress='COMPRESS_COMMAND'
|
||||
suffix=COMPRESS_SUFFIX
|
||||
|
||||
-chgrp=CHGRP_COMMAND
|
||||
-chmod=CHMOD_COMMAND
|
||||
-chown=CHOWN_COMMAND
|
||||
-mv=MV_COMMAND
|
||||
-rm=RM_COMMAND
|
||||
-touch=TOUCH_COMMAND
|
||||
+chgrp='CHGRP_COMMAND'
|
||||
+chmod='CHMOD_COMMAND'
|
||||
+chown='CHOWN_COMMAND'
|
||||
+mv='MV_COMMAND'
|
||||
+rm='RM_COMMAND'
|
||||
+touch='TOUCH_COMMAND'
|
||||
|
||||
# End of editable lines
|
||||
#########################################################################
|
Loading…
Reference in a new issue