Do not pass &int as ptrdiff_t* - that might cause bus errors on archs

where they have different size.
This commit is contained in:
martin 2006-11-17 13:37:36 +00:00
parent e9429a54af
commit a4b81c0fb5
2 changed files with 15 additions and 1 deletions

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.2 2006/11/17 08:12:14 martin Exp $
$NetBSD: distinfo,v 1.3 2006/11/17 13:37:36 martin Exp $
SHA1 (firefox-2.0-source.tar.bz2) = 2bbc6b80cf184bf27101ec4315a19023547c85d4
RMD160 (firefox-2.0-source.tar.bz2) = 88b284b236f29fa5e483a32cd75ceaadebd2f6c3
@ -63,3 +63,4 @@ SHA1 (patch-ea) = 14e31d17c2493e468cd01f99abfc996853a11032
SHA1 (patch-eb) = dc9232b10075d17f7ed742e7be8ea036db2f0241
SHA1 (patch-ec) = 8235af6634306b2a5725754cd5a32285b311b714
SHA1 (patch-ed) = ae922f591b871a1f427c4c32d76a2c25701382d4
SHA1 (patch-ee) = 0067b8df90c5547bab34f0e20a7db8fe517db5e5

View file

@ -0,0 +1,13 @@
$NetBSD: patch-ee,v 1.1 2006/11/17 13:37:36 martin Exp $
--- js/src/jsemit.c.orig 2006-10-10 20:01:02.000000000 +0200
+++ js/src/jsemit.c 2006-11-17 13:00:12.000000000 +0100
@@ -3867,7 +3867,7 @@ js_EmitTree(JSContext *cx, JSCodeGenerat
JSAtom *atom;
JSAtomListElement *ale;
jsatomid atomIndex;
- intN noteIndex;
+ ptrdiff_t noteIndex;
JSSrcNoteType noteType;
jsbytecode *pc;
JSOp op;