Re-import an older version of aide, aide-0.6, as security/aide06,

since there is a problem with aide-0.9 which results in it sending an
email warning on every run of the scanner.  Whilst this version may
have other problems (it believes opendir(3)'s output, IIRC), it does
keep quiet about them.

aide-0.6 creates a database from the regular expression rules that it finds
from the config file.  Once this database is initialized it can be
used to verify the integrity of the files.  It has several message
digest algorithms (md5,sha1,rmd160,tiger,haval,etc.) that are used to
check the integrity of the file.  More algorithms can be added with
relative ease.  All of the usual file attributes can also be checked
for inconsistencies.  It can read databases from older or newer
versions.  See the manual pages within the distribution for further
info.  There is also a beginning of a manual at

	http://www.cs.tut.fi/~rammer/aide/manual.html
This commit is contained in:
agc 2003-06-23 13:48:33 +00:00
parent ffa82444d4
commit a4bbacd6ef
6 changed files with 69 additions and 0 deletions

11
security/aide06/DESCR Normal file
View file

@ -0,0 +1,11 @@
It creates a database from the regular expression rules that it finds
from the config file. Once this database is initialized it can be
used to verify the integrity of the files. It has several message
digest algorithms (md5,sha1,rmd160,tiger,haval,etc.) that are used to
check the integrity of the file. More algorithms can be added with
relative ease. All of the usual file attributes can also be checked
for inconsistencies. It can read databases from older or newer
versions. See the manual pages within the distribution for further
info. There is also a beginning of a manual at
http://www.cs.tut.fi/~rammer/aide/manual.html

19
security/aide06/Makefile Normal file
View file

@ -0,0 +1,19 @@
# $NetBSD: Makefile,v 1.1.1.1 2003/06/23 13:48:33 agc Exp $
#
DISTNAME= aide-0.6
CATEGORIES= security
MASTER_SITES= ftp://ftp.cs.tut.fi/pub/src/gnu/
MAINTAINER= packages@netbsd.org
HOMEPAGE= http://www.cs.tut.fi/~rammer/aide.html
COMMENT= older intrusion detection system for checking file integrity
BUILD_DEPENDS+= bison-[0-9]*:../../devel/bison
GNU_CONFIGURE= yes
#don't set YACC so configure can correctly find bison
YACC=
USE_BUILDLINK2= yes
.include "../../mk/bsd.pkg.mk"

4
security/aide06/PLIST Normal file
View file

@ -0,0 +1,4 @@
@comment $NetBSD: PLIST,v 1.1.1.1 2003/06/23 13:48:33 agc Exp $
bin/aide
man/man1/aide.1
man/man5/aide.conf.5

6
security/aide06/distinfo Normal file
View file

@ -0,0 +1,6 @@
$NetBSD: distinfo,v 1.1.1.1 2003/06/23 13:48:33 agc Exp $
SHA1 (aide-0.6.tar.gz) = e6d112193ad96bdbbe1e1b685dac644d958a1155
Size (aide-0.6.tar.gz) = 212475 bytes
SHA1 (patch-aa) = db675e373464c5127f9bd4cbfd38e6634c950ebf
SHA1 (patch-ab) = 5cc5fdd9fcfde2c5e118bfa4cf68ec7e05215003

View file

@ -0,0 +1,16 @@
$NetBSD: patch-aa,v 1.1.1.1 2003/06/23 13:48:33 agc Exp $
--- include/aide.h.orig Wed Apr 26 14:45:29 2000
+++ include/aide.h Wed Apr 26 14:46:12 2000
@@ -23,10 +23,12 @@
#include "db_config.h"
#include "config.h"
+#ifndef __NetBSD__
#ifndef _POSIX_C_SOURCE
/* For _POSIX_THREAD_SEMANTICS _REENTRANT */
#define _POSIX_C_SOURCE 199506L
#endif /* _POSIX_C_SOURCE */
+#endif /* __NetBSD__ */
#define AIDEVERSION VERSION

View file

@ -0,0 +1,13 @@
$NetBSD: patch-ab,v 1.1.1.1 2003/06/23 13:48:33 agc Exp $
--- src/conf_yacc.y 2003/06/17 14:53:45 1.1
+++ src/conf_yacc.y 2003/06/17 14:54:11
@@ -142,7 +142,7 @@
conferror("Error in expression");
YYABORT;
}
- }
+ } ;
other : TRIGHTS { $$ =$1 ;} | TUSER {$$ =$1 ;}
| TGROUP {$$ =$1 ;} | TINODE {$$ =$1 ;}