Update gnome-desktop3 to 3.16.2
- Drop libgsystem dependency (#680326) - Modernize gtk-doc use (#742479) - Fix memory handling in GnomeRR and language code (#742111, #742569) - Fix mutex handling in thumbnailing code (#740666) - Fix thumbnailing failures due to internal cleanups (#684026) - Add installed tests (#737140) - Recognize builtin monitors in Dell machines (#740289) - Improve thumbnail handling (#684026) - languages: Use a more broadly compatible locale codeset suffix (#710412) - Remove unused code in gtk-reftest (#737123) - Translation updates
This commit is contained in:
parent
c7b91cda5b
commit
a4dc20ff33
5 changed files with 8 additions and 41 deletions
|
@ -1,6 +1,6 @@
|
|||
# $NetBSD: Makefile,v 1.21 2015/04/25 14:25:04 tnn Exp $
|
||||
# $NetBSD: Makefile,v 1.22 2015/06/11 08:34:40 prlw1 Exp $
|
||||
|
||||
DISTNAME= gnome-desktop-3.14.1
|
||||
DISTNAME= gnome-desktop-3.16.2
|
||||
PKGNAME= ${DISTNAME:S/desktop/desktop3/}
|
||||
PKGREVISION= 1
|
||||
CATEGORIES= x11 gnome
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
@comment $NetBSD: PLIST,v 1.4 2014/11/08 23:15:06 prlw1 Exp $
|
||||
@comment $NetBSD: PLIST,v 1.5 2015/06/11 08:34:40 prlw1 Exp $
|
||||
include/gnome-desktop-3.0/libgnome-desktop/gnome-bg-crossfade.h
|
||||
include/gnome-desktop-3.0/libgnome-desktop/gnome-bg-slide-show.h
|
||||
include/gnome-desktop-3.0/libgnome-desktop/gnome-bg.h
|
||||
|
@ -20,6 +20,7 @@ share/gtk-doc/html/gnome-desktop3/GnomeDesktopThumbnailFactory.html
|
|||
share/gtk-doc/html/gnome-desktop3/GnomeIdleMonitor.html
|
||||
share/gtk-doc/html/gnome-desktop3/GnomeWallClock.html
|
||||
share/gtk-doc/html/gnome-desktop3/GnomeXkbInfo.html
|
||||
share/gtk-doc/html/gnome-desktop3/annotation-glossary.html
|
||||
share/gtk-doc/html/gnome-desktop3/background.html
|
||||
share/gtk-doc/html/gnome-desktop3/gnome-desktop3-Language-Utilities.html
|
||||
share/gtk-doc/html/gnome-desktop3/gnome-desktop3-gnome-bg.html
|
||||
|
|
|
@ -1,8 +1,6 @@
|
|||
$NetBSD: distinfo,v 1.10 2014/11/08 23:15:06 prlw1 Exp $
|
||||
$NetBSD: distinfo,v 1.11 2015/06/11 08:34:40 prlw1 Exp $
|
||||
|
||||
SHA1 (gnome-desktop-3.14.1.tar.xz) = a5544c4dbebf7acf84ba295be1a0f360b1937c2b
|
||||
RMD160 (gnome-desktop-3.14.1.tar.xz) = 013e5fe4961d3c83c2ae90b7039cf16237f2770e
|
||||
Size (gnome-desktop-3.14.1.tar.xz) = 1122552 bytes
|
||||
SHA1 (gnome-desktop-3.16.2.tar.xz) = 4c23362987ac8e91170a096c66eeb50938801603
|
||||
RMD160 (gnome-desktop-3.16.2.tar.xz) = a5328fcc774e6d69aff13f6e004e740cbf9cb72c
|
||||
Size (gnome-desktop-3.16.2.tar.xz) = 1078328 bytes
|
||||
SHA1 (patch-aa) = 1d22c87b74aa554e4d9561cb5dcf0a8eae6b9e54
|
||||
SHA1 (patch-libgnome-desktop_libgsystem_gsystem-file-utils.c) = 0a4ab3e08c777e17e8809afeb8950b3a900e0c1a
|
||||
SHA1 (patch-libgnome-desktop_libgsystem_gsystem-shutil.c) = 4d8f05dee8e32f6621a0063b2bee2b0fc2335e08
|
||||
|
|
|
@ -1,16 +0,0 @@
|
|||
$NetBSD: patch-libgnome-desktop_libgsystem_gsystem-file-utils.c,v 1.4 2014/11/08 23:15:06 prlw1 Exp $
|
||||
|
||||
https://bugzilla.gnome.org/show_bug.cgi?id=737369
|
||||
|
||||
--- libgnome-desktop/libgsystem/gsystem-file-utils.c.orig 2014-06-03 15:05:13.000000000 +0000
|
||||
+++ libgnome-desktop/libgsystem/gsystem-file-utils.c
|
||||
@@ -453,6 +453,9 @@ gs_file_open_dir_fd (GFile *path
|
||||
GCancellable *cancellable,
|
||||
GError **error)
|
||||
{
|
||||
+#ifndef O_DIRECTORY
|
||||
+#define O_DIRECTORY 0
|
||||
+#endif
|
||||
/* Linux specific probably */
|
||||
*out_fd = open (gs_file_get_path_cached (path), O_RDONLY | O_NONBLOCK | O_DIRECTORY | O_CLOEXEC);
|
||||
if (*out_fd == -1)
|
|
@ -1,16 +0,0 @@
|
|||
$NetBSD: patch-libgnome-desktop_libgsystem_gsystem-shutil.c,v 1.2 2014/11/08 23:15:06 prlw1 Exp $
|
||||
|
||||
https://bugzilla.gnome.org/show_bug.cgi?id=737369
|
||||
|
||||
--- libgnome-desktop/libgsystem/gsystem-shutil.c.orig 2014-06-03 15:05:13.000000000 +0000
|
||||
+++ libgnome-desktop/libgsystem/gsystem-shutil.c
|
||||
@@ -322,6 +322,9 @@ gs_shutil_rm_rf_children (DIR
|
||||
|
||||
if (dent->d_type == DT_DIR)
|
||||
{
|
||||
+#ifndef O_DIRECTORY
|
||||
+#define O_DIRECTORY 0
|
||||
+#endif
|
||||
int child_dfd = openat (dfd, dent->d_name, O_RDONLY | O_NONBLOCK | O_DIRECTORY | O_CLOEXEC | O_NOFOLLOW);
|
||||
|
||||
if (child_dfd == -1)
|
Loading…
Reference in a new issue