Add a patch for build fix (GST_ELEMENT_ERROR usage) taken from upstream.
This commit is contained in:
parent
fe4c08ee1a
commit
a510901987
2 changed files with 18 additions and 1 deletions
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: distinfo,v 1.25 2010/02/16 13:16:53 drochner Exp $
|
||||
$NetBSD: distinfo,v 1.26 2010/02/18 07:09:00 obache Exp $
|
||||
|
||||
SHA1 (gst-plugins-good-0.10.18.tar.bz2) = 74a463ed6e300598bd14f3f8915f2765f5420bd5
|
||||
RMD160 (gst-plugins-good-0.10.18.tar.bz2) = e93dbf9ece210cb3951fa968cecdaadf826ef81d
|
||||
|
@ -7,3 +7,4 @@ SHA1 (patch-ab) = 2a12779158463e9a33b905beda09bbd39ff4881d
|
|||
SHA1 (patch-ac) = 156fcc3c6f14f5a5f92b2f3ebba508477337fc55
|
||||
SHA1 (patch-ba) = 0f2cc16c39f8bc2a4854ec928b7c0b60d0559eb5
|
||||
SHA1 (patch-bb) = ec781545a7583405a25e8a4dcf689e777f6ac51f
|
||||
SHA1 (patch-bc) = 3e13701ee1a462530d936c450b1eda25b0283b07
|
||||
|
|
16
multimedia/gst-plugins0.10-good/patches/patch-bc
Normal file
16
multimedia/gst-plugins0.10-good/patches/patch-bc
Normal file
|
@ -0,0 +1,16 @@
|
|||
$NetBSD: patch-bc,v 1.1 2010/02/18 07:09:01 obache Exp $
|
||||
|
||||
fix GST_ELEMENT_ERROR usage
|
||||
http://cgit.freedesktop.org/gstreamer/gst-plugins-good/commit/?id=a45b351ddf48dc876e8e0ee69575480b57ab3e96
|
||||
|
||||
--- gst/matroska/matroska-demux.c.orig 2010-02-04 17:36:43.000000000 +0000
|
||||
+++ gst/matroska/matroska-demux.c
|
||||
@@ -2298,7 +2298,7 @@ seek_error:
|
||||
{
|
||||
GST_OBJECT_UNLOCK (demux);
|
||||
GST_PAD_STREAM_UNLOCK (demux->sinkpad);
|
||||
- GST_ELEMENT_ERROR (demux, STREAM, DEMUX, NULL, ("Got a seek error"));
|
||||
+ GST_ELEMENT_ERROR (demux, STREAM, DEMUX, (NULL), ("Got a seek error"));
|
||||
return FALSE;
|
||||
}
|
||||
}
|
Loading…
Reference in a new issue