Updated package to latest version, 0.9.9. Removed obsolete patches, took over

maintainership (all this okayed by the old maintainer, Jeremy C. Reed).

Changes from 0.9.2 include (apart from various bugfixes):
- WPX_SEEK_END for WPXMemoryInputStream (Laurent Alonso)
- Metadata for wpd2html (David Hislop)
- Change source code layout so that public headers be in inc/ and its
  subdirectories
- libwpd.h and libwpd-stream.h are not generated headers anymore
- Change the way we get version from libwpd build
- Improvements to WPXOLEStream class
- Added MPL2+ to the licenses libwpd is released under
- Revert an accidental ABI change in WPXPropertyList
- Link the Windows static libraries with DLL runtimes
- libwpd-stream: Add experimental support for ZIP storages
- libwpd-stream: Add WPX_SEEK_END to the WPXSeekType enum
  (Be sure that you are at offset 0 using it and check return value
  in order to be compatible with lower versions of libwpd)
- New Visual Studio 2008 and Visual Studio 2010 build files
- Don't output points as integer. This solves some rounding issues along
  with possibility of writing 10.5 point font size (Fridrich)
- General improvement of code quality by buiding with -Weffc++ option (Fridrich)
- Improvement of textbox code (Laurent Alonso)
- Improvement of arabic charset mapping (Smokey Ardisson)
- Build system rewrite and improvement (Tomas Chvatal)
- Cleanup of return values (Thomas Klausner)
- Conversion of extended characters in WP 42 parser (Fridrich)
This commit is contained in:
jaapb 2013-08-24 21:50:24 +00:00
parent d69e81f296
commit a53ef5a428
6 changed files with 9 additions and 64 deletions

View file

@ -1,12 +1,11 @@
# $NetBSD: Makefile,v 1.27 2012/10/20 22:04:27 joerg Exp $
# $NetBSD: Makefile,v 1.28 2013/08/24 21:50:24 jaapb Exp $
DISTNAME= libwpd-0.9.2
PKGREVISION= 1
DISTNAME= libwpd-0.9.9
CATEGORIES= converters
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=libwpd/}
EXTRACT_SUFX= .tar.bz2
MAINTAINER= reed@reedmedia.net
MAINTAINER= jaapb@NetBSD.org
HOMEPAGE= http://libwpd.sourceforge.net/
COMMENT= Library for importing and exporting WordPerfect(tm) documents
LICENSE= gnu-lgpl-v2.1

View file

@ -1,11 +1,11 @@
# $NetBSD: buildlink3.mk,v 1.15 2010/11/25 10:41:17 wiz Exp $
# $NetBSD: buildlink3.mk,v 1.16 2013/08/24 21:50:24 jaapb Exp $
BUILDLINK_TREE+= libwpd
.if !defined(LIBWPD_BUILDLINK3_MK)
LIBWPD_BUILDLINK3_MK:=
BUILDLINK_API_DEPENDS.libwpd+= libwpd>=0.9.0
BUILDLINK_API_DEPENDS.libwpd+= libwpd>=0.9.5
BUILDLINK_PKGSRCDIR.libwpd?= ../../converters/libwpd
.endif # LIBWPD_BUILDLINK3_MK

View file

@ -1,8 +1,5 @@
$NetBSD: distinfo,v 1.10 2011/08/04 23:35:43 wiz Exp $
$NetBSD: distinfo,v 1.11 2013/08/24 21:50:24 jaapb Exp $
SHA1 (libwpd-0.9.2.tar.bz2) = 4cbf7e1534082156c4c4a1402d26cf2416649fda
RMD160 (libwpd-0.9.2.tar.bz2) = 6509411050260fa35d2c0b7d590e7781478b65cb
Size (libwpd-0.9.2.tar.bz2) = 614862 bytes
SHA1 (patch-aa) = 4c91375938db1761200af1b68cacd4714a4da004
SHA1 (patch-src_lib_WPXStreamImplementation.cpp) = 1695b86e7dc266f6dc1b087c1524dfb11295cb12
SHA1 (patch-src_lib_wp6graphicsfilenamepacket_cpp) = a129538c8f4591a27a023b1bc7af338dc95dd13a
SHA1 (libwpd-0.9.9.tar.bz2) = 74d13c4e5137edc78660059257671b5a1f40224d
RMD160 (libwpd-0.9.9.tar.bz2) = 5223e000a668ce021849eba6c7f5ba34cbf9da54
Size (libwpd-0.9.9.tar.bz2) = 684918 bytes

View file

@ -1,20 +0,0 @@
$NetBSD: patch-aa,v 1.1 2007/03/18 20:41:50 rillig Exp $
NetBSD 3.0 is missing the extern "C" around the definition of
vsnprintf() in <stdio.h>. In NetBSD 4.99.4, it is fixed.
--- src/lib/WPXString.cpp.orig 2007-03-04 10:44:21.000000000 +0100
+++ src/lib/WPXString.cpp 2007-03-18 21:29:54.000000000 +0100
@@ -24,6 +24,12 @@
* Corel Corporation or Corel Corporation Limited."
*/
+#if defined(__NetBSD__)
+extern "C" {
+#include <stdio.h>
+}
+#endif
+
#include "WPXString.h"
#include "libwpd_internal.h"

View file

@ -1,15 +0,0 @@
$NetBSD: patch-src_lib_WPXStreamImplementation.cpp,v 1.2 2011/08/04 23:35:43 wiz Exp $
http://bugzilla.abisource.com/show_bug.cgi?id=13127
--- src/lib/WPXStreamImplementation.cpp.orig 2011-02-04 19:44:52.000000000 +0000
+++ src/lib/WPXStreamImplementation.cpp
@@ -397,7 +397,7 @@ bool WPXStringStream::isOLEStream()
WPXInputStream* WPXStringStream::getDocumentOLEStream(const char * name)
{
if (!d->buffer.good())
- return false;
+ return NULL;
Storage *tmpStorage = new Storage( d->buffer );
Stream tmpStream( tmpStorage, name );

View file

@ -1,16 +0,0 @@
$NetBSD: patch-src_lib_wp6graphicsfilenamepacket_cpp,v 1.2 2011/08/04 23:35:43 wiz Exp $
Fix bug, caught by clang.
http://bugzilla.abisource.com/show_bug.cgi?id=13128
--- src/lib/WP6GraphicsFilenamePacket.cpp~ 2010-08-26 11:35:21.000000000 +0000
+++ src/lib/WP6GraphicsFilenamePacket.cpp
@@ -42,7 +42,7 @@ WP6GraphicsFilenamePacket::~WP6GraphicsF
void WP6GraphicsFilenamePacket::_readContents(WPXInputStream *input, WPXEncryption *encryption)
{
- if ((m_flags && 0x01) == 0x00)
+ if ((m_flags & 0x01) == 0x00)
return;
uint16_t tmpNumChildIds = readU16(input, encryption);
for (uint16_t i = 0; i < tmpNumChildIds; i++)