Bl3ify inn (and remove bl2.mk file since newsx is the only user).
Patch newsx's configure so that history method auto-detection can be bypassed, which allows build on system with unconfigured inn (such as for bulk-builds). Bump PKGREVISION because now newsx always use indexed method.
This commit is contained in:
parent
34d8c0e23a
commit
a58c4a46a9
6 changed files with 127 additions and 65 deletions
|
@ -1,25 +0,0 @@
|
|||
# $NetBSD: buildlink2.mk,v 1.1 2003/07/29 16:27:26 wiz Exp $
|
||||
#
|
||||
# This Makefile fragment is included by packages that use inn.
|
||||
#
|
||||
# This file was created automatically using createbuildlink 2.5.
|
||||
#
|
||||
|
||||
.if !defined(INN_BUILDLINK2_MK)
|
||||
INN_BUILDLINK2_MK= # defined
|
||||
|
||||
BUILDLINK_PACKAGES+= inn
|
||||
BUILDLINK_DEPENDS.inn?= inn>=2.3.4
|
||||
BUILDLINK_PKGSRCDIR.inn?= ../../news/inn
|
||||
|
||||
EVAL_PREFIX+= BUILDLINK_PREFIX.inn=inn
|
||||
BUILDLINK_PREFIX.inn_DEFAULT= ${LOCALBASE}
|
||||
BUILDLINK_FILES.inn= inn/lib/libinn.a
|
||||
BUILDLINK_FILES.inn+= inn/lib/libstorage.a
|
||||
BUILDLINK_FILES.inn+= include/inn/*
|
||||
|
||||
BUILDLINK_TARGETS+= inn-buildlink
|
||||
|
||||
inn-buildlink: _BUILDLINK_USE
|
||||
|
||||
.endif # INN_BUILDLINK2_MK
|
19
news/inn/buildlink3.mk
Normal file
19
news/inn/buildlink3.mk
Normal file
|
@ -0,0 +1,19 @@
|
|||
# $NetBSD: buildlink3.mk,v 1.1 2004/03/16 09:48:37 cube Exp $
|
||||
|
||||
BUILDLINK_DEPTH:= ${BUILDLINK_DEPTH}+
|
||||
INN_BUILDLINK3_MK:= ${INN_BUILDLINK3_MK}+
|
||||
|
||||
.if !empty(BUILDLINK_DEPTH:M+)
|
||||
BUILDLINK_DEPENDS+= inn
|
||||
.endif
|
||||
|
||||
BUILDLINK_PACKAGES:= ${BUILDLINK_PACKAGES:Ninn}
|
||||
BUILDLINK_PACKAGES+= inn
|
||||
|
||||
.if !empty(INN_BUILDLINK3_MK:M+)
|
||||
BUILDLINK_DEPENDS.inn+= inn>=2.3.4
|
||||
BUILDLINK_PKGSRCDIR.inn?= ../../news/inn
|
||||
|
||||
.endif # INN_BUILDLINK3_MK
|
||||
|
||||
BUILDLINK_DEPTH:= ${BUILDLINK_DEPTH:S/+$//}
|
|
@ -1,7 +1,8 @@
|
|||
# $NetBSD: Makefile,v 1.1.1.1 2003/12/31 13:28:36 cube Exp $
|
||||
# $NetBSD: Makefile,v 1.2 2004/03/16 09:48:37 cube Exp $
|
||||
#
|
||||
|
||||
DISTNAME= newsx-1.6
|
||||
PKGREVISION= 1
|
||||
CATEGORIES= news
|
||||
MASTER_SITES= ftp://ftp.kvaleberg.com/pub/
|
||||
|
||||
|
@ -10,12 +11,13 @@ HOMEPAGE= http://www.kvaleberg.com/newsx.html
|
|||
COMMENT= NNTP news exchange program
|
||||
|
||||
GNU_CONFIGURE= YES
|
||||
USE_BUILDLINK2= YES
|
||||
USE_BUILDLINK3= YES
|
||||
|
||||
.include "../../news/inn/Makefile.common"
|
||||
CONFIGURE_ARGS+= --with-newshome=${INN_PREFIX}/lib
|
||||
CONFIGURE_ARGS+= --with-rnews=${INN_PREFIX}/bin/rnews
|
||||
CONFIGURE_ARGS+= --with-inews=${INN_PREFIX}/bin/inews
|
||||
CONFIGURE_ARGS+= --with-history-mode=indexed
|
||||
|
||||
.include "../../news/inn/buildlink2.mk"
|
||||
.include "../../news/inn/buildlink3.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
||||
|
|
|
@ -1,5 +1,6 @@
|
|||
$NetBSD: distinfo,v 1.1.1.1 2003/12/31 13:28:36 cube Exp $
|
||||
$NetBSD: distinfo,v 1.2 2004/03/16 09:48:37 cube Exp $
|
||||
|
||||
SHA1 (newsx-1.6.tar.gz) = e128e89ba161ceb4ab6d652d8c132ae3a33fbb20
|
||||
Size (newsx-1.6.tar.gz) = 302821 bytes
|
||||
SHA1 (patch-aa) = 3928dcda9f7c1686a598dd38e141c96373280aa5
|
||||
SHA1 (patch-aa) = b0996217c88e250ed38900ad1f706d16b9900550
|
||||
SHA1 (patch-ab) = d3ca5f2231f14b27ff4ee375c1b19b5c158b71be
|
||||
|
|
|
@ -1,41 +1,63 @@
|
|||
$NetBSD: patch-aa,v 1.1.1.1 2003/12/31 13:28:36 cube Exp $
|
||||
$NetBSD: patch-aa,v 1.2 2004/03/16 09:48:37 cube Exp $
|
||||
|
||||
--- configure.orig 2003-05-18 19:25:34.000000000 +0200
|
||||
--- configure.orig 2004-01-11 18:31:22.000000000 +0100
|
||||
+++ configure
|
||||
@@ -1965,35 +1965,8 @@ echo $ECHO_N "checking history... $ECHO_
|
||||
@@ -861,6 +861,8 @@ Optional Packages:
|
||||
--without-history do not perform history database lookup
|
||||
--with-history=FILE use FILE as history database
|
||||
\
|
||||
+ --with-history-mode={indexed|tagged} set history hash mode
|
||||
+\
|
||||
--with-errlog=LOG_XX do syslog in category LOG_XX
|
||||
\
|
||||
--with-inhosts=DIR use DIR as in.hosts directory
|
||||
@@ -1743,6 +1745,12 @@ _ACEOF
|
||||
|
||||
fi
|
||||
|
||||
+# Check whether --with-history-mode or --without-history-mode was given.
|
||||
+if test "${with_history_mode+set}" = set; then
|
||||
+ withval="$with_history_mode"
|
||||
+
|
||||
+fi;
|
||||
+
|
||||
# Check whether --with-errlog or --without-errlog was given.
|
||||
if test "${with_errlog+set}" = set; then
|
||||
withval="$with_errlog"
|
||||
@@ -1964,6 +1972,28 @@ echo $ECHO_N "checking history... $ECHO_
|
||||
HISTORY="$with_history"
|
||||
fi
|
||||
fi
|
||||
+ if test x$with_history_mode != x; then
|
||||
+ case x$with_history_mode in
|
||||
+ xindexed )
|
||||
+ echo "$as_me:$LINENO: result: $HISTORY" >&5
|
||||
+echo "${ECHO_T}$HISTORY" >&6
|
||||
+ ;;
|
||||
+ xtagged )
|
||||
+ echo "$as_me:$LINENO: result: $HISTORY" >&5
|
||||
+echo "${ECHO_T}$HISTORY" >&6
|
||||
+
|
||||
+cat >>confdefs.h <<_ACEOF
|
||||
+#define DO_TAGGED_HASH 1
|
||||
+_ACEOF
|
||||
+
|
||||
+ ;;
|
||||
+ * )
|
||||
+ echo "$as_me:$LINENO: result: ERROR: unknown hash mode $with_history_mode" >&5
|
||||
+echo "${ECHO_T}ERROR: unknown hash mode $with_history_mode" >&6
|
||||
+ exit 1
|
||||
+ ;;
|
||||
+ esac
|
||||
+ else
|
||||
if test -f $HISTORY; then
|
||||
- if test -f $HISTORY.index; then
|
||||
- echo "$as_me:$LINENO: result: $HISTORY" >&5
|
||||
-echo "${ECHO_T}$HISTORY" >&6
|
||||
- elif test -f $HISTORY.pag; then
|
||||
-
|
||||
-cat >>confdefs.h <<_ACEOF
|
||||
-#define DO_TAGGED_HASH 1
|
||||
-_ACEOF
|
||||
-
|
||||
- echo "$as_me:$LINENO: result: $HISTORY" >&5
|
||||
-echo "${ECHO_T}$HISTORY" >&6
|
||||
- elif test -f $HISTORY.n.index; then
|
||||
- echo "$as_me:$LINENO: result: $HISTORY" >&5
|
||||
-echo "${ECHO_T}$HISTORY" >&6
|
||||
- elif test -f $HISTORY.n.pag; then
|
||||
-
|
||||
-cat >>confdefs.h <<_ACEOF
|
||||
-#define DO_TAGGED_HASH 1
|
||||
-_ACEOF
|
||||
-
|
||||
- echo "$as_me:$LINENO: result: $HISTORY" >&5
|
||||
+ echo "$as_me:$LINENO: result: $HISTORY" >&5
|
||||
echo "${ECHO_T}$HISTORY" >&6
|
||||
- else
|
||||
- echo "$as_me:$LINENO: result: ERROR: cannot determine hash mode of $HISTORY" >&5
|
||||
-echo "${ECHO_T}ERROR: cannot determine hash mode of $HISTORY" >&6
|
||||
- echo "$as_me:$LINENO: result: Try running makehistory first" >&5
|
||||
-echo "${ECHO_T}Try running makehistory first" >&6
|
||||
- exit 1
|
||||
- fi
|
||||
else
|
||||
echo "$as_me:$LINENO: result: ERROR: cannot find database $HISTORY" >&5
|
||||
if test -f $HISTORY.index; then
|
||||
echo "$as_me:$LINENO: result: $HISTORY" >&5
|
||||
@@ -1999,6 +2029,7 @@ echo "${ECHO_T}Try running makehistory f
|
||||
echo "${ECHO_T}ERROR: cannot find database $HISTORY" >&6
|
||||
exit 1
|
||||
fi
|
||||
+ fi
|
||||
fi
|
||||
|
||||
echo "$as_me:$LINENO: checking locks" >&5
|
||||
|
|
43
news/newsx/patches/patch-ab
Normal file
43
news/newsx/patches/patch-ab
Normal file
|
@ -0,0 +1,43 @@
|
|||
$NetBSD: patch-ab,v 1.1 2004/03/16 09:48:37 cube Exp $
|
||||
|
||||
--- configure.ac.orig 2003-05-18 12:57:24.000000000 +0200
|
||||
+++ configure.ac
|
||||
@@ -278,6 +278,8 @@ AC_ARG_WITH(history, \
|
||||
if test x$with_history != xno; then
|
||||
AC_DEFINE_UNQUOTED(WITH_HISTORY, 1, [perform history database lookup])
|
||||
fi
|
||||
+AC_ARG_WITH(history-mode, \
|
||||
+ [--with-history-mode={indexed|tagged} set history hash mode])
|
||||
AC_ARG_WITH(errlog, \
|
||||
[--with-errlog=LOG_XX do syslog in category LOG_XX],[
|
||||
if test x$with_errlog = xno; then
|
||||
@@ -433,6 +435,21 @@ else
|
||||
HISTORY="$with_history"
|
||||
fi
|
||||
fi
|
||||
+ if test x$with_history_mode != x; then
|
||||
+ case x$with_history_mode in
|
||||
+ xindexed )
|
||||
+ AC_MSG_RESULT($HISTORY, indexed hash)
|
||||
+ ;;
|
||||
+ xtagged )
|
||||
+ AC_MSG_RESULT($HISTORY, tagged hash)
|
||||
+ AC_DEFINE_UNQUOTED(DO_TAGGED_HASH, 1, [for INN 2.x and dbz v.6])
|
||||
+ ;;
|
||||
+ * )
|
||||
+ AC_MSG_RESULT(ERROR: unknown hash mode $with_history_mode)
|
||||
+ exit 1
|
||||
+ ;;
|
||||
+ esac
|
||||
+ else
|
||||
if test -f $HISTORY; then
|
||||
if test -f $HISTORY.index; then
|
||||
AC_MSG_RESULT($HISTORY, indexed hash)
|
||||
@@ -453,6 +470,7 @@ else
|
||||
AC_MSG_RESULT(ERROR: cannot find database $HISTORY)
|
||||
exit 1
|
||||
fi
|
||||
+ fi
|
||||
fi
|
||||
|
||||
dnl AC_MSG_CHECKING(error log)
|
Loading…
Reference in a new issue