tree-sitter: update to 0.22.2.

0.22.2

Install bugfix.

0.22.1

Bug Fixes

    Cli build script behavior on release


0.22.0

Breaking

    Remove top-level corpus dir for tests
    The cli will now only look in test/corpus for tests
    Remove redundant escape regex & curly brace regex preprocessing (#2838)
    bindings: Convert node bindings to NAPI (#3077)
    wasm: Make current*, is*, and has* methods properties (#3103)
    wasm: Keep API in-line with upstream and start aligning with node (#3149)

Features

    Add xtasks to assist with bumping crates (#3065)
    Improve language bindings (#2438)
    Expose the allocator and array header files for external scanners (#3063)
    Add typings for the node bindings
    Replace nan with node-addon-api and conditionally print logs
    bindings: Add more make targets
    bindings: Add peerDependencies for npm
    bindings: Add prebuildify to node
    bindings: Remove dsl types file (#3126)
    node: Type tag the language (#3109)
    test: Add attributes for corpus tests

Bug Fixes

    Apply some scan-build suggestions (unused assignment/garbage access) (#3056)
    Wrap || comparison in parentheses when && is used (#3070)
    Ignore unused variables in the array macros (#3083)
    binding.cc overwrite should replace PARSER_NAME (#3116)
    Don't use __declspec(dllexport) on windows (#3128)
    Parsers should export the language function on windows
    Allow the regex v flag (#3154)
    assertions: Case shouldn't matter for comment node detection
    bindings: Editorconfig and setup.py fixes (#3082)
    bindings: Insert types after main if it exists (#3122)
    bindings: Fix template oversights (#3155)
    cli: Only output the sources with --no-bindings (#3123)
    generate: Add .npmignore, populate Swift's exclude list (#3085)
    generate: Extern allocator functions for the template don't need to be "exported" (#3132)
    generate: Camel case name in Cargo.toml description (#3140)
    lib: Include api.h so ts_set_allocator is visible (#3092)

Documentation

    Add GitHub user and PR info to the changelog
    Add css for inline code (#2844)
    Document test attributes
    Add Ohm language parser
    Remove duplicate the's (#3120)
    Add discord and matrix badges (#3148)

Refactor

    Rename TS_REUSE_ALLOCATOR flag (#3088)
    Remove extern/const where possible
    array: Use pragma GCC in clang too
    bindings: Remove npmignore (#3089)

Testing

    Don't use TS_REUSE_ALLOCATOR on Darwin systems (#3087)
    Add test case for parse stack merging with incorrect error cost bug (#3098)

Build System and CI

    Improve changelog settings (#3064)
    Unify crate versions via workspace (#3074)
    Update cc to remove annoying debug output (#3075)
    Adjust dependabot settings (#3079)
    Use c11 everywhere
    Add uninstall command
    Don't skip tests on failing lint (#3102)
    Remove unused deps, bump deps, and bump MSRV to 1.74.1 (#3153)
    bindings: Metadata improvements
    bindings: Make everything c11 (#3099)
    dependabot: Update weekly instead of daily (#3112)
    deps: Bump the cargo group with 1 update (#3081)
    deps: Bump the cargo group with 1 update (#3097)
    deps: Bump deps & lockfile (#3060)
    deps: Bump the cargo group with 4 updates (#3134)
    lint: Detect if Cargo.lock needs to be updated (#3066)
    lint: Make lockfile check quiet (#3078)
    swift: Move 'cLanguageStandard' behind 'targets' (#3101)

Other

    Make Node.js language bindings context aware (#2841)
    They don't have any dynamic global data, so all it takes is just declaring them as such
    Fix crash when attempting to load ancient languages via wasm (#3068)
    Use workspace dependencies for internal crates like Tree-sitter (#3076)
    Remove vendored wasmtime headers (#3084)
    When building rust binding, use wasmtime headers provided via cargo
    by the wasmtime-c-api crate.
    Fix invalid parse stack recursive merging with mismatched error cost (#3086)
    Allowing this invalid merge caused an invariant to be violated
    later on during parsing, when handling a later error.
    Fix regression in subtree_compare (#3111)
    docs: Add Ohm language parser (#3114)
    Delete binding_files.rs (#3106)
    bindings: Consistent wording (#3096)
    bindings: Ignore more artifacts (#3119)
This commit is contained in:
wiz 2024-03-17 14:19:18 +00:00
parent 70c9cb3c49
commit a58ccb2bcc
4 changed files with 19 additions and 19 deletions

View File

@ -1,6 +1,6 @@
# $NetBSD: Makefile,v 1.5 2024/02/25 15:26:57 wiz Exp $
# $NetBSD: Makefile,v 1.6 2024/03/17 14:19:18 wiz Exp $
DISTNAME= tree-sitter-0.21.0
DISTNAME= tree-sitter-0.22.2
CATEGORIES= textproc
MASTER_SITES= ${MASTER_SITE_GITHUB:=tree-sitter/}
GITHUB_TAG= v${PKGVERSION_NOREV}

View File

@ -1,7 +1,7 @@
@comment $NetBSD: PLIST,v 1.2 2024/01/28 13:28:34 wiz Exp $
@comment $NetBSD: PLIST,v 1.3 2024/03/17 14:19:18 wiz Exp $
include/tree_sitter/api.h
lib/libtree-sitter.a
lib/libtree-sitter.so
lib/libtree-sitter.so.0
lib/libtree-sitter.so.0.0
lib/libtree-sitter.so.0.22
lib/pkgconfig/tree-sitter.pc

View File

@ -1,6 +1,6 @@
$NetBSD: distinfo,v 1.5 2024/02/25 15:26:57 wiz Exp $
$NetBSD: distinfo,v 1.6 2024/03/17 14:19:18 wiz Exp $
BLAKE2s (tree-sitter-0.21.0.tar.gz) = 091e154202aa1f71f0eb675039da66c9c0227fc0e9b51f85f956be0138a7be7d
SHA512 (tree-sitter-0.21.0.tar.gz) = b68a6f0fcf7bf8044bc82d861baf9a445d2e100a1e3fc39b78ecf38cd529281e35350916fe9e5811173a73cbb255fc0bb3f65b6dd6d6852026a7aab56fb8030d
Size (tree-sitter-0.21.0.tar.gz) = 3055055 bytes
SHA1 (patch-Makefile) = b4dccbfaccf544ffac1fe28bcb8d156ea820c1c3
BLAKE2s (tree-sitter-0.22.2.tar.gz) = aa454351d4e05854619ff0780692e29034e199f123410e37b12af30ef0801b9d
SHA512 (tree-sitter-0.22.2.tar.gz) = a42d744f6e1db7c7c842804f3435b87ccb5d0df2363a18eee38353f12f18c8cf0c6211bf0225fd5f2c0431ca8531aa4ddd73d87d42b80fa35c3c701cae2d7856
Size (tree-sitter-0.22.2.tar.gz) = 3040339 bytes
SHA1 (patch-Makefile) = 05d71cceda39bd1c83d015064fad562fbb077975

View File

@ -1,26 +1,26 @@
$NetBSD: patch-Makefile,v 1.3 2024/02/25 15:26:57 wiz Exp $
$NetBSD: patch-Makefile,v 1.4 2024/03/17 14:19:18 wiz Exp $
- Avoid to possibly pass extra optimization CFLAGS
- Do not override PCLIBDIR for FreeBSD, NetBSD and DragonFly
--- Makefile.orig 2024-02-21 18:32:29.000000000 +0000
--- Makefile.orig 2024-03-17 11:31:58.000000000 +0000
+++ Makefile
@@ -18,7 +18,7 @@ endif
OBJ := $(SRC:.c=.o)
@@ -19,7 +19,7 @@ OBJ := $(SRC:.c=.o)
# define default flags, and override to append mandatory flags
-override CFLAGS := -O3 -std=gnu11 -fPIC -fvisibility=hidden -Wall -Wextra -Wshadow -pedantic $(CFLAGS)
+override CFLAGS := -std=gnu11 -fPIC -fvisibility=hidden -Wall -Wextra -Wshadow -pedantic $(CFLAGS)
ARFLAGS := rcs
-CFLAGS ?= -O3 -Wall -Wextra -Wshadow -pedantic
+CFLAGS ?= -Wall -Wextra -Wshadow -pedantic
override CFLAGS += -std=c11 -fPIC -fvisibility=hidden
override CFLAGS += -Ilib/src -Ilib/src/wasm -Ilib/include
# ABI versioning
@@ -37,9 +37,6 @@ else
@@ -41,9 +41,6 @@ else
SOEXTVER = so.$(SONAME_MAJOR).$(SONAME_MINOR)
LINKSHARED += -shared -Wl,-soname,libtree-sitter.so.$(SONAME_MAJOR)
endif
-ifneq (,$(filter $(shell uname),FreeBSD NetBSD DragonFly))
-ifneq ($(filter $(shell uname),FreeBSD NetBSD DragonFly),)
- PCLIBDIR := $(PREFIX)/libdata/pkgconfig
-endif
all: libtree-sitter.a libtree-sitter.$(SOEXTVER)
all: libtree-sitter.a libtree-sitter.$(SOEXT) tree-sitter.pc