Update dcraw to 9.16.
PR 46718 by YAMAMOTO Takeshi. Changes since 9.04 from RCS file: * Support the Samsung NX1000 and Sony RX100. * Support the Canon EOS 650D, Samsung NX20, and Sigma SD1 * Fixed gravity sensor for Canon 5D Mark III with Firmware Version 1.1.x. * Decode CAMF and IMAG blocks from Sigma SD15 and DP cameras. Added "-E" and "-I" options to support raw pixel substitution. Support Adobe Lossy DNG and the Imacon Flexframe 3f format. Support the Canon G1-X, 1D-X, 5D Mark III, the Fuji X-Pro1, X-S1, and many others. * Support the Casio EX-Z500. * Support the Canon S100, Nikon 1 J1 and V1, Panasonic GX1, Fuji X10, and Samsung NX200 with color matrices from DNG Converter 6.6. * Copied new color matrices from DNG Converter 6.5. * Support ARRIRAW and Redcode R3D raw formats (video only). Support the Leica D-LUX 5 and V-LUX 2, Panasonic G3 and GF3, Olympus E-P3, Sony NEX-C3 and SLT-A35, and Canon SX30. Updated support for Nikon encrypted WB and Canon sRAW/mRAW. * Support the Fuji HS20EXR/F550EXR, Kodak Z990, Leaf AFi-II 12, Nikon D5100, and Samsung NX11 and NX100. * Support the Hasselblad 9044x6732 back, Leaf 1068x1464 back, Fuji X100, and Canon 600D and 1100D. * Support high-ISO images from the Samsung WB2000. * Read correct camera WB from Nikon NRW and Samsung SRW files. Copied color matrices from Adobe DNG Converter 6.3. * Support the Nikon D3100 & D7000 & P7000, Panasonic FZ40 & FZ100 & LX5, Samsung WB2000, Nokia X2, Canon SX120 & PowerShot G12, Hasselblad H4D, Pentax 645D & K-5 & K-r, Sony SLT-A33 & SLT-A55V.
This commit is contained in:
parent
a64fc28b14
commit
a5d36580c1
3 changed files with 13 additions and 13 deletions
|
@ -1,8 +1,7 @@
|
||||||
# $NetBSD: Makefile,v 1.35 2011/04/22 13:43:42 obache Exp $
|
# $NetBSD: Makefile,v 1.36 2012/08/11 09:45:11 obache Exp $
|
||||||
#
|
#
|
||||||
|
|
||||||
DISTNAME= dcraw-9.04
|
DISTNAME= dcraw-9.16
|
||||||
PKGREVISION= 1
|
|
||||||
CATEGORIES= graphics
|
CATEGORIES= graphics
|
||||||
MASTER_SITES= http://www.cybercom.net/~dcoffin/dcraw/archive/
|
MASTER_SITES= http://www.cybercom.net/~dcoffin/dcraw/archive/
|
||||||
|
|
||||||
|
@ -17,7 +16,7 @@ WRKSRC= ${WRKDIR}/${PKGBASE}
|
||||||
USE_TOOLS+= msgfmt
|
USE_TOOLS+= msgfmt
|
||||||
USE_LANGUAGES= c
|
USE_LANGUAGES= c
|
||||||
|
|
||||||
LIBS+= -lm -ljpeg
|
LIBS+= -lm -ljasper -ljpeg
|
||||||
CFLAGS+= -DLOCALEDIR=\"${PREFIX}/${PKGLOCALEDIR}/locale\"
|
CFLAGS+= -DLOCALEDIR=\"${PREFIX}/${PKGLOCALEDIR}/locale\"
|
||||||
|
|
||||||
DCRAW_MANS= ca cs da de eo es fr hu it pl pt ru sv zh_CN zh_TW
|
DCRAW_MANS= ca cs da de eo es fr hu it pl pt ru sv zh_CN zh_TW
|
||||||
|
@ -66,5 +65,6 @@ do-install:
|
||||||
.endfor
|
.endfor
|
||||||
|
|
||||||
.include "../../devel/gettext-lib/buildlink3.mk"
|
.include "../../devel/gettext-lib/buildlink3.mk"
|
||||||
|
.include "../../graphics/jasper/buildlink3.mk"
|
||||||
.include "../../mk/jpeg.buildlink3.mk"
|
.include "../../mk/jpeg.buildlink3.mk"
|
||||||
.include "../../mk/bsd.pkg.mk"
|
.include "../../mk/bsd.pkg.mk"
|
||||||
|
|
|
@ -1,6 +1,6 @@
|
||||||
$NetBSD: distinfo,v 1.24 2010/08/06 20:49:23 bad Exp $
|
$NetBSD: distinfo,v 1.25 2012/08/11 09:45:11 obache Exp $
|
||||||
|
|
||||||
SHA1 (dcraw-9.04.tar.gz) = c65a0c7bb52ccdd05c2adccf4b343f4d0caab40e
|
SHA1 (dcraw-9.16.tar.gz) = fb73ca3ccd703bd522a759e0366814f0a3411902
|
||||||
RMD160 (dcraw-9.04.tar.gz) = 6eae28242abc3aa0b222f227fb05ff6b8ff84022
|
RMD160 (dcraw-9.16.tar.gz) = 9ac7d3f1cb470e5dcbc9ed44f0b91c68bfb0c5a2
|
||||||
Size (dcraw-9.04.tar.gz) = 160533 bytes
|
Size (dcraw-9.16.tar.gz) = 166405 bytes
|
||||||
SHA1 (patch-aa) = 218fad02e1d1b2ddf89d4382b7d45504af1e8aed
|
SHA1 (patch-aa) = 4ee1a2ec5bdb4b13b47d5c8968ded9e86605d5d0
|
||||||
|
|
|
@ -1,9 +1,9 @@
|
||||||
$NetBSD: patch-aa,v 1.4 2008/03/02 09:48:42 wiz Exp $
|
$NetBSD: patch-aa,v 1.5 2012/08/11 09:45:11 obache Exp $
|
||||||
|
|
||||||
--- dcraw.c.orig 2008-02-22 16:43:39.000000000 +0100
|
--- dcraw.c.orig 2012-07-05 04:40:56.000000000 +0000
|
||||||
+++ dcraw.c
|
+++ dcraw.c
|
||||||
@@ -50,6 +50,7 @@
|
@@ -57,6 +57,7 @@
|
||||||
#include <lcms.h>
|
#include <lcms.h> /* Support color profiles */
|
||||||
#endif
|
#endif
|
||||||
#ifdef LOCALEDIR
|
#ifdef LOCALEDIR
|
||||||
+#include <locale.h>
|
+#include <locale.h>
|
||||||
|
|
Loading…
Reference in a new issue